summaryrefslogtreecommitdiff
path: root/dev-python/grpcio/grpcio-1.66.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-11 02:51:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-11 02:51:18 +0100
commitc593b94c4339242cc8d3bb94e3f861f894a57299 (patch)
tree31daea0f14f3a47cc9cc614b2c1f6fd980c3d8b7 /dev-python/grpcio/grpcio-1.66.1.ebuild
parent9bdccb1eaad0b86fe10772348126c737c1afb4bf (diff)
dev-python/grpcio{,-tools} : revision bump
Diffstat (limited to 'dev-python/grpcio/grpcio-1.66.1.ebuild')
-rw-r--r--dev-python/grpcio/grpcio-1.66.1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/grpcio/grpcio-1.66.1.ebuild b/dev-python/grpcio/grpcio-1.66.1.ebuild
deleted file mode 100644
index 58002b6a..00000000
--- a/dev-python/grpcio/grpcio-1.66.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1 flag-o-matic multiprocessing prefix pypi
-
-DESCRIPTION="High-performance RPC framework (python libraries)"
-HOMEPAGE="https://grpc.io"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-libs/openssl:=[-bindist(-)]
- dev-libs/re2:=
- <dev-python/protobuf-python-6[${PYTHON_USEDEP}]
- >=dev-python/protobuf-python-5.26.1[${PYTHON_USEDEP}]
- net-dns/c-ares:=
- sys-libs/zlib:=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
- hprefixify setup.py
-}
-
-python_configure_all() {
- # -Werror=odr -Werror=lto-type-mismatch
- # https://bugs.gentoo.org/856775
- # https://github.com/grpc/grpc/issues/36158
- filter-lto
-
- # os.environ.get('GRPC_BUILD_WITH_BORING_SSL_ASM', True)
- export GRPC_BUILD_WITH_BORING_SSL_ASM=
- export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY=1
- export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
- export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
- export GRPC_PYTHON_BUILD_WITH_SYSTEM_RE2=1
- export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
- export GRPC_PYTHON_BUILD_WITH_CYTHON=1
- export GRPC_PYTHON_BUILD_EXT_COMPILER_JOBS="$(makeopts_jobs)"
-}