summaryrefslogtreecommitdiff
path: root/dev-python/animation/animation-0.0.5-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-23 13:25:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-23 13:25:16 +0100
commit876e0eed5a97341e99e90968365dffd76f5e1480 (patch)
treef95fcc3b9130498ea6bc8e2e2ed81881d4ec7b77 /dev-python/animation/animation-0.0.5-r5.ebuild
parent279a651a3c5f53d8e1581e0ffb0542ba8842e96a (diff)
update metadata && dev-python/animation : update PYTHON_COMPAT
Diffstat (limited to 'dev-python/animation/animation-0.0.5-r5.ebuild')
-rw-r--r--dev-python/animation/animation-0.0.5-r5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/animation/animation-0.0.5-r5.ebuild b/dev-python/animation/animation-0.0.5-r5.ebuild
new file mode 100644
index 00000000..d5fd0a77
--- /dev/null
+++ b/dev-python/animation/animation-0.0.5-r5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools for terminal-based wait animations"
+HOMEPAGE="https://github.com/bprinty/animation"
+SRC_URI="https://github.com/bprinty/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="amd64 arm64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}