summaryrefslogtreecommitdiff
path: root/dev-python/animation/animation-0.0.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 12:23:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 12:23:41 +0100
commitc6c99bab7b9fcd608fc85c41313aa4062b3cb3cc (patch)
tree2fc2dd4789d5b803a5df1c548194ab6d76dea3b4 /dev-python/animation/animation-0.0.5-r1.ebuild
parent9e221e470364c143c2d596fe3ebb0ce5b7fcfb10 (diff)
dev-python/animation : revision bump, add python3.7 COMPAT
Diffstat (limited to 'dev-python/animation/animation-0.0.5-r1.ebuild')
-rw-r--r--dev-python/animation/animation-0.0.5-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/animation/animation-0.0.5-r1.ebuild b/dev-python/animation/animation-0.0.5-r1.ebuild
new file mode 100644
index 00000000..fff2882e
--- /dev/null
+++ b/dev-python/animation/animation-0.0.5-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools for terminal-based wait animations"
+HOMEPAGE="https://github.com/bprinty/animation"
+SRC_URI="https://github.com/bprinty/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}