summaryrefslogtreecommitdiff
path: root/app-portage/sisyphus/sisyphus-4.2102.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:39:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:39:29 +0000
commitc252f3586ad5a631a33ee45d558e83cc84799685 (patch)
treecc517b5b841375ced8bc5daf796f2b4bfcbc6202 /app-portage/sisyphus/sisyphus-4.2102.0.ebuild
parenta127a1432105f7b7ce5d53279043ae69bab232e6 (diff)
app-portage/sisyphus{,-qt} : version bump
Diffstat (limited to 'app-portage/sisyphus/sisyphus-4.2102.0.ebuild')
-rw-r--r--app-portage/sisyphus/sisyphus-4.2102.0.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/app-portage/sisyphus/sisyphus-4.2102.0.ebuild b/app-portage/sisyphus/sisyphus-4.2102.0.ebuild
deleted file mode 100644
index 8ef7cbd2..00000000
--- a/app-portage/sisyphus/sisyphus-4.2102.0.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 2016-2020 Redcore Linux Project
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit eutils python-single-r1 git-r3
-
-DESCRIPTION="A simple portage python wrapper which works like other package managers(apt-get/yum/dnf)"
-HOMEPAGE="http://redcorelinux.org"
-
-EGIT_REPO_URI="https://gitlab.com/redcore/sisyphus.git"
-EGIT_BRANCH="master"
-EGIT_COMMIT="4a0e1e81a257000e372877360eac419ff2a3c834"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="qt5"
-
-DEPEND="dev-lang/python[sqlite]"
-RDEPEND="${DEPEND}
- app-portage/portage-utils
- $(python_gen_cond_dep '
- app-portage/gentoolkit[${PYTHON_MULTI_USEDEP}]
- dev-python/animation[${PYTHON_MULTI_USEDEP}]
- dev-python/GitPython[${PYTHON_MULTI_USEDEP}]
- dev-python/typer[${PYTHON_MULTI_USEDEP}]
- dev-python/urllib3[${PYTHON_MULTI_USEDEP}]
- dev-python/wget[${PYTHON_MULTI_USEDEP}]
- sys-apps/portage[${PYTHON_MULTI_USEDEP}]
- ')
- sys-apps/gentoo-functions"
-PDEPEND="qt5? ( ~app-portage/sisyphus-qt-${PV} )"
-
-src_install() {
- emake DESTDIR="${D}" install-cli
-
- python_moduleinto "$(python_get_sitedir)"/"${PN}"
- python_domodule src/backend/*.py
-
- dosym /usr/share/"${PN}"/"${PN}"-cli.py /usr/bin/"${PN}"
- keepdir var/lib/"${PN}"/{csv,db}
-
- dodir etc/"${PN}"
- insinto etc/"${PN}"
- doins "${FILESDIR}"/mirrors.conf
-
- doins "${FILESDIR}"/sisyphus-custom.env
- doins "${FILESDIR}"/sisyphus-custom.make.conf
- doins "${FILESDIR}"/sisyphus-custom.package.accept_keywords
- doins "${FILESDIR}"/sisyphus-custom.package.env
- doins "${FILESDIR}"/sisyphus-custom.package.license
- doins "${FILESDIR}"/sisyphus-custom.package.mask
- doins "${FILESDIR}"/sisyphus-custom.package.unmask
- doins "${FILESDIR}"/sisyphus-custom.package.use
-
- # enforce the best available python implementation (CLI)
- python_setup
- python_fix_shebang "${ED}"usr/share/"${PN}"/"${PN}"-cli.py
-}
-
-pkg_postinst() {
- # Take care of the etc-update for the user
- if [ -e "${EROOT}"etc/"${PN}"/._cfg0000_mirrors.conf ] ; then
- rm -rf "${EROOT}"etc/._cfg0000_mirros.conf
- fi
-
- for i in sisyphus-custom.{env,make.conf,package.{accept_keywords,env,license,mask,unmask,use}}; do
- if [ -e "${EROOT}"etc/"${PN}"/._cfg000_"$i" ] ; then
- rm -rf "${EROOT}"etc/"${PN}"/._cfg000_"$i"
- fi
- done
-}