summaryrefslogtreecommitdiff
path: root/app-portage/sisyphus-qt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-30 00:20:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-30 00:20:01 +0000
commit826d1b3f488d3549cbd42ccc73ad90ea1ce88f0b (patch)
treea84b9e02a2ed47c2b0cac999a53205ba3c7cc5ae /app-portage/sisyphus-qt
parented5eafdd6cce789eb6b007f944fddf6f9f3174ba (diff)
app-portage/sisyphus : split => app-portage/sisyphus && app-portage/sisyphus-qt
Diffstat (limited to 'app-portage/sisyphus-qt')
-rw-r--r--app-portage/sisyphus-qt/sisyphus-qt-4.2009.0-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-portage/sisyphus-qt/sisyphus-qt-4.2009.0-r2.ebuild b/app-portage/sisyphus-qt/sisyphus-qt-4.2009.0-r2.ebuild
new file mode 100644
index 00000000..598871c3
--- /dev/null
+++ b/app-portage/sisyphus-qt/sisyphus-qt-4.2009.0-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2016-2020 Redcore Linux Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-qt/}"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit eutils python-r1 git-r3
+
+DESCRIPTION="A simple portage python wrapper which works like other package managers(apt-get/yum/dnf)"
+HOMEPAGE="http://redcorelinux.org"
+
+EGIT_REPO_URI="https://gitlab.com/redcore/sisyphus.git"
+EGIT_BRANCH="master"
+EGIT_COMMIT="1b5d87dc8393295568f8f82a5d48fbc086f2caaf"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-lang/python[sqlite]"
+RDEPEND="${DEPEND}
+ app-misc/tmux
+ app-portage/sisyphus
+ dev-python/PyQt5[designer,gui,widgets,${PYTHON_USEDEP}]"
+
+src_install() {
+ emake DESTDIR=${D} install-gui
+
+ # enforce the best available python implementation (CLI)
+ python_setup
+ python_fix_shebang "${ED}usr/share/${MY_PN}/${MY_PN}-gui.py"
+}