summaryrefslogtreecommitdiff
path: root/app-pda/usbmuxd/usbmuxd-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@rogentos.ro>2015-01-31 11:59:56 +0200
committerV3n3RiX <venerix@rogentos.ro>2015-01-31 11:59:56 +0200
commit8d9b256225be88b96262bd4f827b6ce1328951d2 (patch)
treee3c6c734cee37809acadaabc0f20cdeb00cd4021 /app-pda/usbmuxd/usbmuxd-1.1.0.ebuild
parent157d97123246b45224496d9c4dec52de33407573 (diff)
support IOS 8.1.3 devices, tested with iPhone 6 and works magic
Diffstat (limited to 'app-pda/usbmuxd/usbmuxd-1.1.0.ebuild')
-rw-r--r--app-pda/usbmuxd/usbmuxd-1.1.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-pda/usbmuxd/usbmuxd-1.1.0.ebuild b/app-pda/usbmuxd/usbmuxd-1.1.0.ebuild
new file mode 100644
index 00000000..f6a7ab89
--- /dev/null
+++ b/app-pda/usbmuxd/usbmuxd-1.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/usbmuxd/usbmuxd-1.0.8_p20140530.ebuild,v 1.2 2014/08/03 12:09:08 ssuominen Exp $
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils udev user
+
+DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
+HOMEPAGE="http://www.libimobiledevice.org/"
+SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
+#SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+# src/utils.h is LGPL-2.1+, rest is found in COPYING*
+LICENSE="GPL-2 GPL-3 LGPL-2.1+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND=">=app-pda/libimobiledevice-1.1.6
+ >=app-pda/libplist-1.11
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+ virtual/pkgconfig"
+
+pkg_setup() {
+ enewgroup plugdev
+ enewuser usbmux -1 -1 -1 "usb,plugdev"
+}
+
+src_install() {
+ autotools-utils_src_install udevrulesdir="$(get_udevdir)"/rules.d
+}