summaryrefslogtreecommitdiff
path: root/app-editors/featherpad/featherpad-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-22 12:02:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-22 12:02:23 +0100
commit283cc725c9cc835bcd0bf5d7657fe905666e23dc (patch)
tree362eb308c882f09b9a50bb9c1d30b909c821bcd7 /app-editors/featherpad/featherpad-0.10.0.ebuild
parent856a1c859d409252aabaf7c4f6fe05a48635b50d (diff)
app-editors/featherpad : version bump
Diffstat (limited to 'app-editors/featherpad/featherpad-0.10.0.ebuild')
-rw-r--r--app-editors/featherpad/featherpad-0.10.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-editors/featherpad/featherpad-0.10.0.ebuild b/app-editors/featherpad/featherpad-0.10.0.ebuild
new file mode 100644
index 00000000..4189920d
--- /dev/null
+++ b/app-editors/featherpad/featherpad-0.10.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils qmake-utils
+
+DESCRIPTION="Lightweight Qt5 Plain-Text Editor for Linux"
+SRC_URI="https://github.com/tsujan/FeatherPad/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtsvg:5
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/FeatherPad-"${PV}"
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr" fp.pro
+}
+
+src_install() {
+ make INSTALL_ROOT=${D} install || die
+}