summaryrefslogtreecommitdiff
path: root/app-admin/vasile/vasile-3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@rogentos.ro>2016-11-12 16:57:10 +0000
committerV3n3RiX <venerix@rogentos.ro>2016-11-12 16:57:10 +0000
commit0f8199d50a84cb9ed4c96db81a22a93c49ae61cf (patch)
tree5e374d293b00b4ff044a6572fa8651ce1732c13d /app-admin/vasile/vasile-3.0.ebuild
parent9a74f65027f7fa280fb94e26224b0ec5b9ea2e3e (diff)
bump vasile to v3.0
Diffstat (limited to 'app-admin/vasile/vasile-3.0.ebuild')
-rw-r--r--app-admin/vasile/vasile-3.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-admin/vasile/vasile-3.0.ebuild b/app-admin/vasile/vasile-3.0.ebuild
new file mode 100644
index 00000000..b0a7c567
--- /dev/null
+++ b/app-admin/vasile/vasile-3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils git-2
+
+DESCRIPTION="Versatile Advanced Script for ISO and Latest Enchantments"
+HOMEPAGE="http://redcorelinux.org"
+
+EGIT_BRANCH="master"
+EGIT_REPO_URI="https://gitlab.com/redcore/vasile.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+DEPEND="
+ sys-apps/gentoo-functions
+ sys-fs/squashfs-tools
+ sys-boot/grub:2
+ dev-libs/libisoburn
+ sys-fs/mtools"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dodir /usr/bin
+ exeinto /usr/bin
+ doexe ${S}/${PN}
+ dodir /usr/$(get_libdir)/${PN}
+ insinto /usr/$(get_libdir)/${PN}
+ doins ${S}/libvasile
+ dodir /usr/share/${PN}
+ insinto /usr/share/${PN}
+ insopts -m 755
+ doins ${S}/make*
+ doins ${S}/*mode
+}
+