summaryrefslogtreecommitdiff
path: root/app-admin/calamares/calamares-999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@rogentos.ro>2015-06-11 15:39:49 +0100
committerV3n3RiX <venerix@rogentos.ro>2015-06-11 15:39:49 +0100
commitec268627ad2cd8390ab7c6a203c31cc624476363 (patch)
treeaebf0c80be7eb8d7790762903d10b49252bf9afb /app-admin/calamares/calamares-999.ebuild
parentcde34b808013d6b2f265aa72daed957b3a52b14b (diff)
massive overhaul of calamares ebuild, ready to be upstreamed to gentoo
Diffstat (limited to 'app-admin/calamares/calamares-999.ebuild')
-rw-r--r--app-admin/calamares/calamares-999.ebuild50
1 files changed, 14 insertions, 36 deletions
diff --git a/app-admin/calamares/calamares-999.ebuild b/app-admin/calamares/calamares-999.ebuild
index 4373bc4c..6cf48d0e 100644
--- a/app-admin/calamares/calamares-999.ebuild
+++ b/app-admin/calamares/calamares-999.ebuild
@@ -7,8 +7,8 @@ PYTHON_COMPAT=( python3_3 )
inherit eutils cmake-utils python-r1 git-2
-EGIT_BRANCH="kogaion"
-EGIT_COMMIT="4aa0f9e1f24bf4700d4998627893344a2511051c"
+EGIT_BRANCH="master"
+EGIT_COMMIT="01cf42c2f9112687bc3928eeabbb426e7de84877"
EGIT_REPO_URI="https://github.com/Rogentos/calamares.git"
DESCRIPTION="Distribution-independent installer framework"
@@ -17,12 +17,15 @@ HOMEPAGE="http://calamares.io"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="+python"
S="${WORKDIR}/${PN}-${PV}"
DEPEND="dev-vcs/git
- >=dev-libs/boost-1.55.0-r2[python_targets_python3_3]
+ python? (
+ >=dev-lang/python-3.3.5-r1:3.3
+ >=dev-libs/boost-1.55.0-r2[python_targets_python3_3]
+ )
>=dev-qt/designer-5.4.0:5
>=dev-qt/linguist-tools-5.4.0:5
>=dev-qt/qtconcurrent-5.4.0:5
@@ -42,38 +45,7 @@ DEPEND="dev-vcs/git
>=dev-cpp/yaml-cpp-0.5.1
>=kde-frameworks/extra-cmake-modules-5.10.0"
-RDEPEND=">=dev-libs/boost-1.55.0-r2[python_targets_python3_3]
- >=dev-qt/designer-5.4.0:5
- >=dev-qt/linguist-tools-5.4.0:5
- >=dev-qt/qtconcurrent-5.4.0:5
- >=dev-qt/qtcore-5.4.0:5
- >=dev-qt/qtdbus-5.4.0:5
- >=dev-qt/qtdeclarative-5.4.0:5
- >=dev-qt/qtgui-5.4.0:5
- >=dev-qt/qtnetwork-5.4.0:5
- >=dev-qt/qtopengl-5.4.0:5
- >=dev-qt/qtprintsupport-5.4.0:5
- >=dev-qt/qtscript-5.4.0:5
- >=dev-qt/qtsvg-5.4.0:5
- >=dev-qt/qttest-5.4.0:5
- >=dev-qt/qtwidgets-5.4.0:5
- >=dev-qt/qtxml-5.4.0:5
- >=dev-qt/qtxmlpatterns-5.4.0:5
- >=dev-cpp/yaml-cpp-0.5.1
- >=dev-libs/libatasmart-0.19
- >=kde-frameworks/kconfig-5.10.0
- >=kde-frameworks/ki18n-5.10.0
- >=kde-frameworks/kcoreaddons-5.10.0
- >=kde-frameworks/solid-5.10.0
- >=net-misc/rsync-3.1[xattr]
- >=sys-block/parted-3.0
- >=sys-apps/gptfdisk-0.8.10
- >=sys-apps/dmidecode-2.12-r1
- >=sys-fs/squashfs-tools-4.3:0[xattr]
- >=sys-power/upower-0.99.0-r1
- sys-auth/polkit-qt[qt5]
- sys-fs/udisks:2[systemd]
- virtual/udev[systemd]"
+RDEPEND=">=app-misc/calamares-runtime-2.0[branding]"
src_prepare() {
# by default, python support is optional and calamares builds fine if is not found
@@ -86,6 +58,12 @@ src_prepare() {
# no longer needed, but keep it around, just in case
# default interpretor must be set to python3.3 for calamares to find required libs
+ # debug window causes a build failure with GCC 4.8.4 so disable it
+ epatch "${FILESDIR}/${PN}-disable-debug-window.patch"
+
+ # configure calamares with Kogaion specific paths, binary names && system defaults
+ epatch "${FILESDIR}/${PN}-kogaion-system-defaults.patch"
+
# If qtchooser is installed, it may break the build, because moc,rcc and uic binaries for wrong qt version may be used.
# Setting QT_SELECT environment variable will enforce correct binaries (fix taken from vlc ebuild)
export QT_SELECT=qt5