summaryrefslogtreecommitdiff
path: root/dev-python/qtstatemachine/qtstatemachine-1.1.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:24:26 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:24:26 +0200
commit7224c1253228e5c29c78cb3f0f26ce34770f2356 (patch)
tree1684924656132935256e034f35f92abee6623265 /dev-python/qtstatemachine/qtstatemachine-1.1.ebuild
Added ebuilds for kogaion desktop
Diffstat (limited to 'dev-python/qtstatemachine/qtstatemachine-1.1.ebuild')
-rw-r--r--dev-python/qtstatemachine/qtstatemachine-1.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/qtstatemachine/qtstatemachine-1.1.ebuild b/dev-python/qtstatemachine/qtstatemachine-1.1.ebuild
new file mode 100644
index 00000000..7d222db9
--- /dev/null
+++ b/dev-python/qtstatemachine/qtstatemachine-1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2004-2009 Sabayon Linux
+# Distributed under the terms of the GNU General Public License v2
+# $
+
+EAPI="2"
+inherit eutils base multilib
+
+DESCRIPTION="Qt State Machine Framework"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+SRC_URI="ftp://ftp.trolltech.com/qt/solutions/lgpl/qtstatemachine-1.1-opensource.tar.gz"
+RESTRICT="mirror"
+LICENSE="|| ( LGPL-2.1 GPL-3 QPL-1.0 )"
+
+RDEPEND="dev-libs/glib
+ media-libs/libpng
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}-opensource"
+
+src_configure() {
+
+ # build system is utterly broken
+ echo "yes" | ./configure -library || die "configure failed"
+
+}
+
+src_compile() {
+ qmake -makefile -nocache || die "qmake failed"
+ emake || "make failed"
+}
+
+src_install() {
+
+ # build system is broken
+ dolib.so lib/*
+
+}
+
+pkg_postinst() {
+ ewarn "This package is VERY EXPERIMENTAL."
+ ewarn "Its build system is utterly broken."
+ ewarn "No examples are installed because of the issue above"
+ ewarn "...and your cat will be eaten by a black hole!"
+ ewarn "plop!"
+}