summaryrefslogtreecommitdiff
path: root/app-editors/featherpad/featherpad-0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-06-03 08:56:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-06-03 08:56:17 +0100
commitdd6368eec25720584bd83d77c93f6588e01cc485 (patch)
tree88ebd747203a4a172db625a026a0738d1e3ecffc /app-editors/featherpad/featherpad-0.6.ebuild
parente7b82539c6de4448bc06a918d90553c420957eb7 (diff)
app-editors/featherpad : bump to v0.6
Diffstat (limited to 'app-editors/featherpad/featherpad-0.6.ebuild')
-rw-r--r--app-editors/featherpad/featherpad-0.6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-editors/featherpad/featherpad-0.6.ebuild b/app-editors/featherpad/featherpad-0.6.ebuild
new file mode 100644
index 00000000..fe43ad4b
--- /dev/null
+++ b/app-editors/featherpad/featherpad-0.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils qmake-utils git-r3
+
+DESCRIPTION="Lightweight Qt5 Plain-Text Editor for Linux"
+EGIT_REPO_URI="https://github.com/tsujan/FeatherPad.git"
+EGIT_COMMIT="00d2202758e5d830c90926fe800343e0946a521d"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtsvg:5
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr" fp.pro
+}
+
+src_install() {
+ make INSTALL_ROOT=${D} install || die
+}