From 6a4408b9bbd9fe61dc0966f587db94081fa5f52b Mon Sep 17 00:00:00 2001
From: V3n3RiX <venerix@koprulu.sector>
Date: Wed, 10 Jan 2024 19:03:44 +0000
Subject: gentoo auto-resync : 10:01:2024 - 19:03:44

---
 sys-apps/portage/Manifest                 |   2 +-
 sys-apps/portage/portage-3.0.61-r1.ebuild | 246 ++++++++++++++++++++++++++++++
 sys-apps/portage/portage-3.0.61.ebuild    | 246 ------------------------------
 3 files changed, 247 insertions(+), 247 deletions(-)
 create mode 100644 sys-apps/portage/portage-3.0.61-r1.ebuild
 delete mode 100644 sys-apps/portage/portage-3.0.61.ebuild

(limited to 'sys-apps')

diff --git a/sys-apps/portage/Manifest b/sys-apps/portage/Manifest
index b303af43b8cd..66a97c4f5e04 100644
--- a/sys-apps/portage/Manifest
+++ b/sys-apps/portage/Manifest
@@ -12,6 +12,6 @@ EBUILD portage-3.0.49-r2.ebuild 9527 BLAKE2B 6cad70f759ec4440c228193e2535d57d679
 EBUILD portage-3.0.57-r1.ebuild 6846 BLAKE2B 5c1c1fe393cd909d0bc05aa1351241acd172a72ce61cf3459e66a2535c0a3b3f573ca7644077e7ab5986edfdf8b5f1ac435951edab8092c67880e29f3f46e083 SHA512 90a8f909de1dca0bcfaa0b1c26779d9acb4ed4a299ebd6c5cc8aa82012d6dca7e81379a1e3a00ff780aa2c9e33b732ff433e65040339b7c4a8ce35e252832a63
 EBUILD portage-3.0.59-r1.ebuild 6917 BLAKE2B 3e117879101dd933d39db92e9a09532af81b4526cf187aa30ed3cc30b9cc9f5e6b82ee533d837c0380ba440d63a6f8eeaa589ccb1870412af871ece7a6336c3c SHA512 7458ae0657beebbfcc8c9c0601af3dc63334c6c9e8e3191b8e65343ed6f74bbf3e207f30aa7396767c3e2de1879203b0e89858efbc84aad3ade864356fc5f319
 EBUILD portage-3.0.60-r1.ebuild 6924 BLAKE2B aefe2a21564205f08b316354036061185aaa4d073c65bb841c61dc220e056298f117ae50202e260ed1007e2afc154b20572ae1858e1843fca1b706ea534de9ad SHA512 0aa410e2a4f445784fe2b9ab1c7d787763d3772367eb7415feaaaee364b563bb3b64a8ec1a968224e52eb3b9ce4e005990058a652e36321a96094023f152af15
-EBUILD portage-3.0.61.ebuild 6924 BLAKE2B b4281caf86b61a7653fbb1f5d9ace233d5c3969613e02a00de81fbd16a09f717798ea9f3e9ff00a0b273b3d70bc7d49a8a579a9a56d149c9f34869b1861d04b0 SHA512 53f97835922ce08cfc56458499ec9d9e7cde3a73c1832767098fa03509ed329a28ea1277d7c40cb7cc6a071b7fb2fb747e7f5bb09955b557820b3934734593d5
+EBUILD portage-3.0.61-r1.ebuild 6924 BLAKE2B aefe2a21564205f08b316354036061185aaa4d073c65bb841c61dc220e056298f117ae50202e260ed1007e2afc154b20572ae1858e1843fca1b706ea534de9ad SHA512 0aa410e2a4f445784fe2b9ab1c7d787763d3772367eb7415feaaaee364b563bb3b64a8ec1a968224e52eb3b9ce4e005990058a652e36321a96094023f152af15
 EBUILD portage-9999.ebuild 6924 BLAKE2B aefe2a21564205f08b316354036061185aaa4d073c65bb841c61dc220e056298f117ae50202e260ed1007e2afc154b20572ae1858e1843fca1b706ea534de9ad SHA512 0aa410e2a4f445784fe2b9ab1c7d787763d3772367eb7415feaaaee364b563bb3b64a8ec1a968224e52eb3b9ce4e005990058a652e36321a96094023f152af15
 MISC metadata.xml 1539 BLAKE2B 0efa1ae365449d6593909046c32158a9f6755aa9252c34ae00eb866dd29a0b6a5c2e7a4af9293d0f87c4dd9231132fc5361acb0818fb6beff6dd6fbbdc6f409b SHA512 675f5baa1b3079592e3930b11ca18f324e27c42b5515f9ae815a26e53a465640fa6e9c4069df0e2121932b9f1cc73f2c9469c1529728f3c5ed5c3e687743ac0d
diff --git a/sys-apps/portage/portage-3.0.61-r1.ebuild b/sys-apps/portage/portage-3.0.61-r1.ebuild
new file mode 100644
index 000000000000..36c0d5fdf384
--- /dev/null
+++ b/sys-apps/portage/portage-3.0.61-r1.ebuild
@@ -0,0 +1,246 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE='bzip2(+),threads(+)'
+TMPFILES_OPTIONAL=1
+
+inherit meson linux-info multiprocessing python-r1 tmpfiles
+
+DESCRIPTION="The package management and distribution system for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
+
+if [[ ${PV} == 9999 ]] ; then
+	EGIT_REPO_URI="
+		https://anongit.gentoo.org/git/proj/portage.git
+		https://github.com/gentoo/portage.git
+	"
+	inherit git-r3
+else
+	SRC_URI="https://gitweb.gentoo.org/proj/portage.git/snapshot/${P}.tar.bz2"
+	KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apidoc build doc gentoo-dev +ipc +native-extensions +rsync-verify selinux test xattr"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+# setuptools is still needed as a workaround for Python 3.12+ for now.
+# https://github.com/mesonbuild/meson/issues/7702
+#
+# >=meson-1.2.1-r1 for bug #912051
+BDEPEND="
+	${PYTHON_DEPS}
+	>=dev-util/meson-1.2.1-r1
+	|| (
+		>=dev-util/meson-1.3.0-r1
+		<dev-util/meson-1.3.0
+	)
+	$(python_gen_cond_dep '
+		dev-python/setuptools[${PYTHON_USEDEP}]
+	' python3_12)
+	test? (
+		dev-python/pytest-xdist[${PYTHON_USEDEP}]
+		dev-vcs/git
+	)
+"
+DEPEND="
+	${PYTHON_DEPS}
+	>=app-arch/tar-1.27
+	dev-lang/python-exec:2
+	>=sys-apps/sed-4.0.5
+	sys-devel/patch
+	!build? ( $(python_gen_impl_dep 'ssl(+)') )
+	apidoc? (
+		dev-python/sphinx[${PYTHON_USEDEP}]
+		dev-python/sphinx-epytext[${PYTHON_USEDEP}]
+	)
+	doc? (
+		~app-text/docbook-xml-dtd-4.4
+		app-text/xmlto
+	)
+"
+# Require sandbox-2.2 for bug #288863.
+# For whirlpool hash, require python[ssl] (bug #425046).
+RDEPEND="
+	${PYTHON_DEPS}
+	acct-user/portage
+	>=app-arch/tar-1.27
+	app-arch/zstd
+	>=app-misc/pax-utils-0.1.17
+	dev-lang/python-exec:2
+	>=sys-apps/baselayout-2.9
+	>=sys-apps/findutils-4.9
+	!build? (
+		>=app-admin/eselect-1.2
+		app-portage/getuto
+		>=app-shells/bash-5.0:0
+		>=sec-keys/openpgp-keys-gentoo-release-20230329
+		>=sys-apps/sed-4.0.5
+		rsync-verify? (
+			>=app-crypt/gnupg-2.2.4-r2[ssl(-)]
+			>=app-portage/gemato-14.5[${PYTHON_USEDEP}]
+		)
+	)
+	elibc_glibc? ( >=sys-apps/sandbox-2.2 )
+	elibc_musl? ( >=sys-apps/sandbox-2.2 )
+	kernel_linux? ( sys-apps/util-linux )
+	selinux? ( >=sys-libs/libselinux-2.0.94[python,${PYTHON_USEDEP}] )
+	xattr? ( kernel_linux? (
+		>=sys-apps/install-xattr-0.3
+	) )
+	!<app-admin/logrotate-3.8.0
+	!<app-portage/gentoolkit-0.4.6
+	!<app-portage/repoman-2.3.10
+	!~app-portage/repoman-3.0.0
+"
+# coreutils-6.4 rdep is for date format in emerge-webrsync #164532
+# NOTE: FEATURES=installsources requires debugedit and rsync
+PDEPEND="
+	!build? (
+		>=net-misc/rsync-2.6.4
+		>=sys-apps/coreutils-6.4
+		>=sys-apps/file-5.44-r3
+	)
+"
+
+pkg_pretend() {
+	local CONFIG_CHECK="~IPC_NS ~PID_NS ~NET_NS ~UTS_NS"
+
+	check_extra_config
+}
+
+src_prepare() {
+	default
+
+	if use prefix-guest; then
+		sed -e "s|^\(main-repo = \).*|\\1gentoo_prefix|" \
+			-e "s|^\\[gentoo\\]|[gentoo_prefix]|" \
+			-e "s|^\(sync-uri = \).*|\\1rsync://rsync.prefix.bitzolder.nl/gentoo-portage-prefix|" \
+			-i cnf/repos.conf || die "sed failed"
+	fi
+}
+
+src_configure() {
+	local code_only=false
+	python_foreach_impl my_src_configure
+}
+
+my_src_configure() {
+	local emesonargs=(
+		-Dcode-only=${code_only}
+		-Deprefix="${EPREFIX}"
+		-Dportage-bindir="${EPREFIX}/usr/lib/portage/${EPYTHON}"
+		-Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
+		$(meson_use doc)
+		$(meson_use apidoc)
+		$(meson_use gentoo-dev)
+		$(meson_use ipc)
+		$(meson_use xattr)
+	)
+
+	if use native-extensions && [[ "${EPYTHON}" != "pypy3" ]] ; then
+		emesonargs+=( -Dnative-extensions=true )
+	else
+		emesonargs+=( -Dnative-extensions=false )
+	fi
+
+	if use build; then
+		emesonargs+=( -Drsync-verify=false )
+	else
+		emesonargs+=( $(meson_use rsync-verify) )
+	fi
+
+	meson_src_configure
+	code_only=true
+}
+
+src_compile() {
+	python_foreach_impl meson_src_compile
+}
+
+src_test() {
+	local -x PYTEST_ADDOPTS="-vv -ra -l -o console_output_style=count -n $(makeopts_jobs) --dist=worksteal"
+
+	python_foreach_impl meson_src_test --no-rebuild --verbose
+}
+
+src_install() {
+	python_foreach_impl my_src_install
+	dotmpfiles "${FILESDIR}"/portage-{ccache,tmpdir}.conf
+
+	local scripts
+	mapfile -t scripts < <(awk '/^#!.*python/ {print FILENAME} {nextfile}' "${ED}"/usr/{bin,sbin}/* || die)
+	python_replicate_script "${scripts[@]}"
+}
+
+my_src_install() {
+	local pydirs=(
+		"${D}$(python_get_sitedir)"
+		"${ED}/usr/lib/portage/${EPYTHON}"
+	)
+
+	meson_src_install
+	python_fix_shebang "${pydirs[@]}"
+	python_optimize "${pydirs[@]}"
+}
+
+pkg_preinst() {
+	if ! use build && [[ -z ${ROOT} ]]; then
+		python_setup
+		local sitedir=$(python_get_sitedir)
+		[[ -d ${D}${sitedir} ]] || die "${D}${sitedir}: No such directory"
+		env -u DISTDIR \
+			-u PORTAGE_OVERRIDE_EPREFIX \
+			-u PORTAGE_REPOSITORIES \
+			-u PORTDIR \
+			-u PORTDIR_OVERLAY \
+			PYTHONPATH="${D}${sitedir}${PYTHONPATH:+:${PYTHONPATH}}" \
+			"${PYTHON}" -m portage._compat_upgrade.default_locations || die
+
+		env -u BINPKG_COMPRESS -u PORTAGE_REPOSITORIES \
+			PYTHONPATH="${D}${sitedir}${PYTHONPATH:+:${PYTHONPATH}}" \
+			"${PYTHON}" -m portage._compat_upgrade.binpkg_compression || die
+
+		env -u FEATURES -u PORTAGE_REPOSITORIES \
+			PYTHONPATH="${D}${sitedir}${PYTHONPATH:+:${PYTHONPATH}}" \
+			"${PYTHON}" -m portage._compat_upgrade.binpkg_multi_instance || die
+
+		env -u BINPKG_FORMAT \
+			PYTHONPATH="${D}${sitedir}${PYTHONPATH:+:${PYTHONPATH}}" \
+			"${PYTHON}" -m portage._compat_upgrade.binpkg_format || die
+	fi
+
+	# elog dir must exist to avoid logrotate error for bug #415911.
+	# This code runs in preinst in order to bypass the mapping of
+	# portage:portage to root:root which happens after src_install.
+	keepdir /var/log/portage/elog
+	# This is allowed to fail if the user/group are invalid for prefix users.
+	if chown portage:portage "${ED}"/var/log/portage{,/elog} 2>/dev/null ; then
+		chmod g+s,ug+rwx "${ED}"/var/log/portage{,/elog}
+	fi
+
+	if has_version "<${CATEGORY}/${PN}-2.3.77"; then
+		elog "The emerge --autounmask option is now disabled by default, except for"
+		elog "portions of behavior which are controlled by the --autounmask-use and"
+		elog "--autounmask-license options. For backward compatibility, previous"
+		elog "behavior of --autounmask=y and --autounmask=n is entirely preserved."
+		elog "Users can get the old behavior simply by adding --autounmask to the"
+		elog "make.conf EMERGE_DEFAULT_OPTS variable. For the rationale for this"
+		elog "change, see https://bugs.gentoo.org/658648."
+	fi
+}
+
+pkg_postinst() {
+	# Warn about obsolete "enotice" script, bug #867010
+	local bashrc=${EROOT}/etc/portage/profile/profile.bashrc
+	if [[ -e ${bashrc} ]] && grep -q enotice "${bashrc}"; then
+		eerror "Obsolete 'enotice' script detected!"
+		eerror "Please remove this from ${bashrc} to avoid problems."
+		eerror "See bug 867010 for more details."
+	fi
+}
diff --git a/sys-apps/portage/portage-3.0.61.ebuild b/sys-apps/portage/portage-3.0.61.ebuild
deleted file mode 100644
index 7d462427195c..000000000000
--- a/sys-apps/portage/portage-3.0.61.ebuild
+++ /dev/null
@@ -1,246 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-PYTHON_REQ_USE='bzip2(+),threads(+)'
-TMPFILES_OPTIONAL=1
-
-inherit meson linux-info multiprocessing python-r1 tmpfiles
-
-DESCRIPTION="The package management and distribution system for Gentoo"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
-
-if [[ ${PV} == 9999 ]] ; then
-	EGIT_REPO_URI="
-		https://anongit.gentoo.org/git/proj/portage.git
-		https://github.com/gentoo/portage.git
-	"
-	inherit git-r3
-else
-	SRC_URI="https://gitweb.gentoo.org/proj/portage.git/snapshot/${P}.tar.bz2"
-	KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="apidoc build doc gentoo-dev +ipc +native-extensions +rsync-verify selinux test xattr"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-# setuptools is still needed as a workaround for Python 3.12+ for now.
-# https://github.com/mesonbuild/meson/issues/7702
-#
-# >=meson-1.2.1-r1 for bug #912051
-BDEPEND="
-	${PYTHON_DEPS}
-	>=dev-util/meson-1.2.1-r1
-	|| (
-		>=dev-util/meson-1.3.0-r1
-		<dev-util/meson-1.3.0
-	)
-	$(python_gen_cond_dep '
-		dev-python/setuptools[${PYTHON_USEDEP}]
-	' python3_12)
-	test? (
-		dev-python/pytest-xdist[${PYTHON_USEDEP}]
-		dev-vcs/git
-	)
-"
-DEPEND="
-	${PYTHON_DEPS}
-	>=app-arch/tar-1.27
-	dev-lang/python-exec:2
-	>=sys-apps/sed-4.0.5
-	sys-devel/patch
-	!build? ( $(python_gen_impl_dep 'ssl(+)') )
-	apidoc? (
-		dev-python/sphinx[${PYTHON_USEDEP}]
-		dev-python/sphinx-epytext[${PYTHON_USEDEP}]
-	)
-	doc? (
-		~app-text/docbook-xml-dtd-4.4
-		app-text/xmlto
-	)
-"
-# Require sandbox-2.2 for bug #288863.
-# For whirlpool hash, require python[ssl] (bug #425046).
-RDEPEND="
-	${PYTHON_DEPS}
-	acct-user/portage
-	>=app-arch/tar-1.27
-	app-arch/zstd
-	>=app-misc/pax-utils-0.1.17
-	dev-lang/python-exec:2
-	>=sys-apps/baselayout-2.9
-	>=sys-apps/findutils-4.9
-	!build? (
-		>=app-admin/eselect-1.2
-		app-portage/getuto
-		>=app-shells/bash-5.0:0
-		>=sec-keys/openpgp-keys-gentoo-release-20230329
-		>=sys-apps/sed-4.0.5
-		rsync-verify? (
-			>=app-crypt/gnupg-2.2.4-r2[ssl(-)]
-			>=app-portage/gemato-14.5[${PYTHON_USEDEP}]
-		)
-	)
-	elibc_glibc? ( >=sys-apps/sandbox-2.2 )
-	elibc_musl? ( >=sys-apps/sandbox-2.2 )
-	kernel_linux? ( sys-apps/util-linux )
-	selinux? ( >=sys-libs/libselinux-2.0.94[python,${PYTHON_USEDEP}] )
-	xattr? ( kernel_linux? (
-		>=sys-apps/install-xattr-0.3
-	) )
-	!<app-admin/logrotate-3.8.0
-	!<app-portage/gentoolkit-0.4.6
-	!<app-portage/repoman-2.3.10
-	!~app-portage/repoman-3.0.0
-"
-# coreutils-6.4 rdep is for date format in emerge-webrsync #164532
-# NOTE: FEATURES=installsources requires debugedit and rsync
-PDEPEND="
-	!build? (
-		>=net-misc/rsync-2.6.4
-		>=sys-apps/coreutils-6.4
-		>=sys-apps/file-5.44-r3
-	)
-"
-
-pkg_pretend() {
-	local CONFIG_CHECK="~IPC_NS ~PID_NS ~NET_NS ~UTS_NS"
-
-	check_extra_config
-}
-
-src_prepare() {
-	default
-
-	if use prefix-guest; then
-		sed -e "s|^\(main-repo = \).*|\\1gentoo_prefix|" \
-			-e "s|^\\[gentoo\\]|[gentoo_prefix]|" \
-			-e "s|^\(sync-uri = \).*|\\1rsync://rsync.prefix.bitzolder.nl/gentoo-portage-prefix|" \
-			-i cnf/repos.conf || die "sed failed"
-	fi
-}
-
-src_configure() {
-	local code_only=false
-	python_foreach_impl my_src_configure
-}
-
-my_src_configure() {
-	local emesonargs=(
-		-Dcode-only=${code_only}
-		-Deprefix="${EPREFIX}"
-		-Dportage-bindir="${EPREFIX}/usr/lib/portage/${EPYTHON}"
-		-Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
-		$(meson_use doc)
-		$(meson_use apidoc)
-		$(meson_use gentoo-dev)
-		$(meson_use ipc)
-		$(meson_use xattr)
-	)
-
-	if use native-extensions && [[ "${EPYTHON}" != "pypy3" ]] ; then
-		emesonargs+=( -Dnative-extensions=true )
-	else
-		emesonargs+=( -Dnative-extensions=false )
-	fi
-
-	if use build; then
-		emesonargs+=( -Drsync-verify=false )
-	else
-		emesonargs+=( $(meson_use rsync-verify) )
-	fi
-
-	meson_src_configure
-	code_only=true
-}
-
-src_compile() {
-	python_foreach_impl meson_src_compile
-}
-
-src_test() {
-	local -x PYTEST_ADDOPTS="-vv -ra -l -o console_output_style=count -n $(makeopts_jobs) --dist=worksteal"
-
-	python_foreach_impl meson_src_test --no-rebuild --verbose
-}
-
-src_install() {
-	python_foreach_impl my_src_install
-	dotmpfiles "${FILESDIR}"/portage-{ccache,tmpdir}.conf
-
-	local scripts
-	mapfile -t scripts < <(awk '/^#!.*python/ {print FILENAME} {nextfile}' "${ED}"/usr/{bin,sbin}/* || die)
-	python_replicate_script "${scripts[@]}"
-}
-
-my_src_install() {
-	local pydirs=(
-		"${D}$(python_get_sitedir)"
-		"${ED}/usr/lib/portage/${EPYTHON}"
-	)
-
-	meson_src_install
-	python_optimize "${pydirs[@]}"
-	python_fix_shebang "${pydirs[@]}"
-}
-
-pkg_preinst() {
-	if ! use build && [[ -z ${ROOT} ]]; then
-		python_setup
-		local sitedir=$(python_get_sitedir)
-		[[ -d ${D}${sitedir} ]] || die "${D}${sitedir}: No such directory"
-		env -u DISTDIR \
-			-u PORTAGE_OVERRIDE_EPREFIX \
-			-u PORTAGE_REPOSITORIES \
-			-u PORTDIR \
-			-u PORTDIR_OVERLAY \
-			PYTHONPATH="${D}${sitedir}${PYTHONPATH:+:${PYTHONPATH}}" \
-			"${PYTHON}" -m portage._compat_upgrade.default_locations || die
-
-		env -u BINPKG_COMPRESS -u PORTAGE_REPOSITORIES \
-			PYTHONPATH="${D}${sitedir}${PYTHONPATH:+:${PYTHONPATH}}" \
-			"${PYTHON}" -m portage._compat_upgrade.binpkg_compression || die
-
-		env -u FEATURES -u PORTAGE_REPOSITORIES \
-			PYTHONPATH="${D}${sitedir}${PYTHONPATH:+:${PYTHONPATH}}" \
-			"${PYTHON}" -m portage._compat_upgrade.binpkg_multi_instance || die
-
-		env -u BINPKG_FORMAT \
-			PYTHONPATH="${D}${sitedir}${PYTHONPATH:+:${PYTHONPATH}}" \
-			"${PYTHON}" -m portage._compat_upgrade.binpkg_format || die
-	fi
-
-	# elog dir must exist to avoid logrotate error for bug #415911.
-	# This code runs in preinst in order to bypass the mapping of
-	# portage:portage to root:root which happens after src_install.
-	keepdir /var/log/portage/elog
-	# This is allowed to fail if the user/group are invalid for prefix users.
-	if chown portage:portage "${ED}"/var/log/portage{,/elog} 2>/dev/null ; then
-		chmod g+s,ug+rwx "${ED}"/var/log/portage{,/elog}
-	fi
-
-	if has_version "<${CATEGORY}/${PN}-2.3.77"; then
-		elog "The emerge --autounmask option is now disabled by default, except for"
-		elog "portions of behavior which are controlled by the --autounmask-use and"
-		elog "--autounmask-license options. For backward compatibility, previous"
-		elog "behavior of --autounmask=y and --autounmask=n is entirely preserved."
-		elog "Users can get the old behavior simply by adding --autounmask to the"
-		elog "make.conf EMERGE_DEFAULT_OPTS variable. For the rationale for this"
-		elog "change, see https://bugs.gentoo.org/658648."
-	fi
-}
-
-pkg_postinst() {
-	# Warn about obsolete "enotice" script, bug #867010
-	local bashrc=${EROOT}/etc/portage/profile/profile.bashrc
-	if [[ -e ${bashrc} ]] && grep -q enotice "${bashrc}"; then
-		eerror "Obsolete 'enotice' script detected!"
-		eerror "Please remove this from ${bashrc} to avoid problems."
-		eerror "See bug 867010 for more details."
-	fi
-}
-- 
cgit v1.2.3