From c9e9e39938097bf29063c271195ad0d7d7bd02a9 Mon Sep 17 00:00:00 2001
From: V3n3RiX <venerix@koprulu.sector>
Date: Sun, 17 Sep 2023 17:03:45 +0100
Subject: gentoo auto-resync : 17:09:2023 - 17:03:44

---
 net-misc/Manifest.gz                               | Bin 54443 -> 54443 bytes
 net-misc/netkit-bootparamd/Manifest                |   1 +
 .../netkit-bootparamd-0.17-r5.ebuild               |  56 +++++++++++++++++++++
 net-misc/netkit-talk/Manifest                      |   1 +
 net-misc/netkit-talk/netkit-talk-0.17-r8.ebuild    |  55 ++++++++++++++++++++
 net-misc/netkit-timed/Manifest                     |   1 +
 net-misc/netkit-timed/netkit-timed-0.17-r11.ebuild |  39 ++++++++++++++
 7 files changed, 153 insertions(+)
 create mode 100644 net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r5.ebuild
 create mode 100644 net-misc/netkit-talk/netkit-talk-0.17-r8.ebuild
 create mode 100644 net-misc/netkit-timed/netkit-timed-0.17-r11.ebuild

(limited to 'net-misc')

diff --git a/net-misc/Manifest.gz b/net-misc/Manifest.gz
index c78c15ae1376..1cd5c315c6b0 100644
Binary files a/net-misc/Manifest.gz and b/net-misc/Manifest.gz differ
diff --git a/net-misc/netkit-bootparamd/Manifest b/net-misc/netkit-bootparamd/Manifest
index f556b203f1e5..67521bffd1f9 100644
--- a/net-misc/netkit-bootparamd/Manifest
+++ b/net-misc/netkit-bootparamd/Manifest
@@ -4,4 +4,5 @@ AUX bootparamd.confd 29 BLAKE2B a2697cebfe9e2c7a9617b2624b70d0615b4ad920d034dbd0
 AUX bootparamd.initd 502 BLAKE2B ebc4d4c3381c1003924c402415aea4ad820e24f38520b4f0bc41643dc3f24642e8010907ae1451f7286607ab387d256e9e74f43ca53c5f3677e876956d0a686f SHA512 9326e3a3dfca43cd7233a289b1f58c22db22aabc2136cba2d61a4bdab17652f9d031e4eddc877126aa09e08e048e63ba9fcf4219f9dbbf55d6787e03d5ee2548
 DIST netkit-bootparamd_0.17.orig.tar.gz 13934 BLAKE2B d828175594b0aae60c5284d4f02c73b4bb91cee2601dc52c6cbfb21e02779825a03567de7dbcc945246104889b7b4bc74f0429b508bda082a365a1d605e213e5 SHA512 fc237c72efd0c7a671c179ee4596f64e13a7a637441d32c9e82e81f4133d987f468c98b00611fbada1f7d6e5fa791c9b513978bfc7a58efe7d93102a2d3b4dca
 EBUILD netkit-bootparamd-0.17-r4.ebuild 1454 BLAKE2B cb36308c62f7fe7186037150233352d2a780c52b13d94df3bdd4ae1ea016f3e6742c14899fb8b51b654eb3b94c703ec27121c42c625ef722202481396b6e617a SHA512 a48c201c0aa38f861ed0e5677a404814d5ebdb3c17079763d335e75fcc7c47a770f93d8567ff1a5f161a27a2d09d946e8de0dc533eb1030ff16372ff4013d9b9
+EBUILD netkit-bootparamd-0.17-r5.ebuild 1479 BLAKE2B 0af8ed8db970c1fe0e39477a84784f686a530112b520ef9f771c7190a68b72d7a8f8427da7aa9ce5078e0ea650956e903900d3870dcd73f92b1f509693c086b0 SHA512 2fb787255ad0f4177bb1265c9c9c6fb228c59594dec251915a1a1080609dbec02faed41b821e8faf8d07e38072f9e7e091bbb20d4af6a14de7bcb1d21fea3847
 MISC metadata.xml 268 BLAKE2B 91c62a36cbf68e44d577a77084141c8505ad6f4f4d0455c4e68aa99e758518505c09161acc56f77de536d94e05b22ed8f6eff2f61d4a1744e1e752d24ba785f1 SHA512 e08f7d0f198f125c9a66e8503eab99802b27d5bd5c2cfd99c03d9acc3bcc67e404c44945dd4271fed3257b123492ead2492cbce645dbf383ffc0b684a5050bb1
diff --git a/net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r5.ebuild b/net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r5.ebuild
new file mode 100644
index 000000000000..59faca2de934
--- /dev/null
+++ b/net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Netkit - bootparamd: Net-boot support daemon"
+HOMEPAGE="https://wiki.linuxfoundation.org/networking/netkit"
+SRC_URI="mirror://debian/pool/main/n/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="+libtirpc"
+
+DEPEND="
+	!<=net-misc/netkit-bootpd-0.17-r2
+	libtirpc? ( net-libs/rpcsvc-proto net-libs/libtirpc )
+	!libtirpc? ( sys-libs/glibc[rpc(-)] )
+"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+	"${FILESDIR}"/0.17-jumpstart.patch
+	"${FILESDIR}"/0.17-libtirpc.patch
+)
+
+src_prepare() {
+	# don't reset LDFLAGS (bug #335457), manpages into /usr/share/man
+	sed -i -e '/^LDFLAGS=/d ; /MANDIR=/s:man:share/man:' configure || die
+	sed -i -e 's:install -s:install:' rpc.bootparamd/Makefile || die
+	default
+}
+
+src_configure() {
+	if use libtirpc ; then
+		append-cflags -I/usr/include/tirpc
+		sed -i -e 's:^LIBS=$:LIBS=-ltirpc:' configure || die
+	fi
+
+	# Note this is not an autoconf configure
+	CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS}" ./configure || die
+}
+
+src_install() {
+	dodir usr/bin usr/sbin usr/share/man/man8
+	emake INSTALLROOT="${D}" install
+
+	newconfd "${FILESDIR}"/bootparamd.confd bootparamd
+	newinitd "${FILESDIR}"/bootparamd.initd bootparamd
+
+	doman rpc.bootparamd/bootparams.5
+	dodoc README ChangeLog
+	newdoc rpc.bootparamd/README README.bootparamd
+}
diff --git a/net-misc/netkit-talk/Manifest b/net-misc/netkit-talk/Manifest
index 48cae25519d7..88930fc39732 100644
--- a/net-misc/netkit-talk/Manifest
+++ b/net-misc/netkit-talk/Manifest
@@ -3,4 +3,5 @@ AUX netkit-talk-0.17-time.patch 385 BLAKE2B 5b49b4d562507c6b60911379e0623e17a2c5
 AUX talk.xinetd 265 BLAKE2B 94381bf30fa51682b9dd272174cd8a3fed94233ff8ec654044419016a3adedbfac4e0db1f86c3851c9f7aa1c63d6e7411def635ecd3aa8cc88ec4d50656985c8 SHA512 f4f29a6e57aa80ffd6acc45b3c4a5bc5086fc6061f8d9bdfbe4fea4f874cedbdd5f85f60e311aa473e53119c16c42289161011699d24b944992aee0aec9ccb1f
 DIST netkit-ntalk-0.17.tar.gz 37396 BLAKE2B cdc7af27bb5f0b6b1139e3d8b33ecc3d4c661a76ee9de4cca8f5954251a30b5b3dc926ff906a7b51223b1c8590ff99a408ca07642c454bfd095b91fff482dffb SHA512 5a886c0f73179060f926d4af781a6b9d4de7b62562a69db7b93c4fd783ad12b488ee967af18e5a11f98e7f94d659c1688d2a3d4ba4a00bdec31869aa39a321c5
 EBUILD netkit-talk-0.17-r7.ebuild 1168 BLAKE2B e7d85e2318f974a45a7e51902ba4820ea7a594b84fca05989326b4cea65ffa9360fb9b757423f5e560a94dbb62482be3ca5a51e75b2556ef7958846e577dfc0d SHA512 3531137056f85e6d586dd3d134779f8670867999a73f9ae964044412b293ca7e439b2e930ffc1c21fbfa91b43507d0863a52dc318713aeee05a86e9432f58ebb
+EBUILD netkit-talk-0.17-r8.ebuild 1180 BLAKE2B 7633053a7980f783cdef70a94d9752999e1e6c0cc100e91f65e17e98aeed2983510d92a2f39f147ca43bce625fa3919498f9b12245db07448f95189191ca9c85 SHA512 054d3509a1a714913f224683a1d6feec5b49a490ff14d9af8903733901bb7c25d61bba1c3f969c203e81dc014c38dc98aa65b8ce0e4a156007c29ff1b48cc41d
 MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/net-misc/netkit-talk/netkit-talk-0.17-r8.ebuild b/net-misc/netkit-talk/netkit-talk-0.17-r8.ebuild
new file mode 100644
index 000000000000..1832ecd0e9ab
--- /dev/null
+++ b/net-misc/netkit-talk/netkit-talk-0.17-r8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_P=netkit-ntalk-${PV}
+
+DESCRIPTION="Netkit - talkd: Daemon to help set up talk sessions"
+HOMEPAGE="https://wiki.linuxfoundation.org/networking/netkit"
+SRC_URI="http://ftp.linux.org.uk/pub/linux/Networking/netkit/${MY_P}.tar.gz"
+S="${WORKDIR}"/netkit-ntalk-${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=sys-libs/ncurses-5.2:="
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+	${DEPEND}
+	virtual/inetd
+"
+
+PATCHES=(
+	"${FILESDIR}"/${P}-time.patch
+	"${FILESDIR}"/${P}-ipv6.patch
+)
+
+src_prepare() {
+	default
+	sed -i configure -e '/^LDFLAGS=/d' || die
+}
+
+src_configure() {
+	# not autotools based?
+	./configure --with-c-compiler="$(tc-getCC)" || die
+}
+
+src_compile() {
+	emake LIBCURSES="$( $(tc-getPKG_CONFIG) --libs ncurses )"
+}
+
+src_install() {
+	insinto /etc/xinetd.d
+	newins "${FILESDIR}"/talk.xinetd talk
+	dobin talk/talk
+	doman talk/talk.1
+	dosbin talkd/talkd
+	dosym talkd /usr/sbin/in.talkd
+	doman talkd/talkd.8
+	dosym talkd.8 /usr/share/man/man8/in.talkd.8
+	dodoc README ChangeLog BUGS
+}
diff --git a/net-misc/netkit-timed/Manifest b/net-misc/netkit-timed/Manifest
index ea8f670ac749..31b5f68c635d 100644
--- a/net-misc/netkit-timed/Manifest
+++ b/net-misc/netkit-timed/Manifest
@@ -3,4 +3,5 @@ AUX 0.17-timed-opt-parsing.patch 403 BLAKE2B e0164998a4845da439b640d60b3cdac1dd8
 AUX timed.rc6 358 BLAKE2B 358a7b3fc14f30b0146e1269cf9327d9aaf64d8329b25c610b0405adfc91d4d21d6d14ec08c7234b53934460851db6f947117733b3d4070645503dbe1761eaa5 SHA512 cde2063563dd02b404560fa84bfa536f2f7c75e9271225e94b08630348d78639e386b8a0f59f04b389ad66f2d714c63edf2eed507b690d5ba989780b400547a4
 DIST netkit-timed-0.17.tar.gz 48655 BLAKE2B 5e076394e2605569b8a9a34d47b59234ffa0f643a13ef7ac688b40d259079ec5d2eef99a0efa35d7975e11118c1fe87bd138edd98199dde68cc4d8d9f10c3599 SHA512 781a41555953a165949dde7e7279298d4faf348575ba1214c6ce60cdbc74f6f03ab31002d57a441cbcaf674f7e2cc00afa17632bc3fcb28e2afd95d39cd70b99
 EBUILD netkit-timed-0.17-r10.ebuild 1019 BLAKE2B 000b7f43ea394aab89876c30d3f23bd3c63fa66010279c8dc6526653d8989c12089e3933ee4ea6637926cef2a3069674703cf345e64c3230d75a37b4bd3cf9b8 SHA512 c551b9a8d71a1b77ecfd72142924046e4d16882c274d129cda88fd06c26feba995afcc11ccb626e4e301cca3bba56fcc90a9c42fb011eebe1ab0b07a8c071635
+EBUILD netkit-timed-0.17-r11.ebuild 1061 BLAKE2B 211c3ad5aa6efc462161bf6fdc99f0f8c69908a8f88301cb0d004e68ede7fb23c4044bab0e5bc8bbbb7fcfb35ac0c8c8461bc7b1bc7d822cb5f629f8d15c0a1e SHA512 1968ad82aae9e35572912b30a3d9b69440bcde842b1590047a3f8dcb8f9d721f449a218f7ccdaab79f0e2a2e663be92f6e48e5bb098a337e24097a5ceb225d38
 MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/net-misc/netkit-timed/netkit-timed-0.17-r11.ebuild b/net-misc/netkit-timed/netkit-timed-0.17-r11.ebuild
new file mode 100644
index 000000000000..660a85f76e2a
--- /dev/null
+++ b/net-misc/netkit-timed/netkit-timed-0.17-r11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Netkit - timed: Time daemon"
+HOMEPAGE="https://wiki.linuxfoundation.org/networking/netkit"
+SRC_URI="http://ftp.linux.org.uk/pub/linux/Networking/netkit/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+LICENSE="BSD GPL-2"
+SLOT="0"
+
+src_prepare() {
+	eapply "${FILESDIR}"/0.17-CFLAG-DEF-fix.patch
+	eapply "${FILESDIR}"/0.17-timed-opt-parsing.patch
+	sed -i -e '/^LDFLAGS=/d' configure || die "sed configure"
+	sed -i -e "s|ar -cruv|\${AR} -cruv|g" timed/lib/Makefile || die
+	default
+}
+
+src_configure() {
+	tc-export AR
+	# Note this is not an autoconf configure script. econf fails
+	append-flags -DCLK_TCK=CLOCKS_PER_SEC
+	./configure --prefix=/usr --with-c-compiler="$(tc-getCC)" || die "bad configure"
+}
+
+src_install() {
+	dosbin timed/timed/timed
+	doman  timed/timed/timed.8
+	dosbin timed/timedc/timedc
+	doman  timed/timedc/timedc.8
+	einstalldocs
+
+	newinitd "${FILESDIR}"/timed.rc6 timed
+}
-- 
cgit v1.2.3