From 0f558761aa2dee1017b4751e4017205e015a9560 Mon Sep 17 00:00:00 2001
From: V3n3RiX <venerix@koprulu.sector>
Date: Wed, 29 Jun 2022 12:04:12 +0100
Subject: gentoo resync : 29.12.2022

---
 net-libs/rest/Manifest             |  2 +-
 net-libs/rest/rest-0.8.1-r1.ebuild | 60 +++++++++++++++++++++++++++++++++++++
 net-libs/rest/rest-0.8.1.ebuild    | 61 --------------------------------------
 3 files changed, 61 insertions(+), 62 deletions(-)
 create mode 100644 net-libs/rest/rest-0.8.1-r1.ebuild
 delete mode 100644 net-libs/rest/rest-0.8.1.ebuild

(limited to 'net-libs/rest')

diff --git a/net-libs/rest/Manifest b/net-libs/rest/Manifest
index dc04c2d813a2..dd6978961eed 100644
--- a/net-libs/rest/Manifest
+++ b/net-libs/rest/Manifest
@@ -1,3 +1,3 @@
 DIST rest-0.8.1.tar.xz 333376 BLAKE2B 595576f29ebe35121b7a896086abd3411ac3b2d324d2e50d646274c4060cfaffbd3b701eaae80afdc60d52c77bb5076135064648536378f2562f27c79c5738b7 SHA512 824a341db3827e4360abe03e33735918c68913c70d797699ef74271080a1985872006ec70fd994dc8fa3fbfef417e6fe979883c11286512d0ce623b8368e40c3
-EBUILD rest-0.8.1.ebuild 1516 BLAKE2B c35afb9790f3339f2140800a23ba5718056291052d05b661f31130194768d13fe00ac48559e0b182ff747fb1c18f9df74c48c85269739b85ab1421f5dbe6e04f SHA512 95e9637d13305285e6d85c2262e2863a65b6324a39e40d569a90b626589150b39162ddffe4b9680dda41b9a3faa5119eb9c71aa7b571773337c3b859569dff6f
+EBUILD rest-0.8.1-r1.ebuild 1483 BLAKE2B fd647f2cc7b7e945644118a38d98035373188fc2839bda61e4ef72d484731be4179e48c7b043240b7e529597165ab29c38e06c18f1153cf2a2bc3b3a32998504 SHA512 d6035981ef8410bb5b593606d567b2ea4c837941e8b3ad32cb8cf7b283d4be055cdb4d0ad40a7e7b26aa464cbdff8c868cbf1aeadae4f17ba6a0ef4b9df20c6e
 MISC metadata.xml 260 BLAKE2B 74a7980ab34785ba7920342b0a2708af439bed09b7ffdc1ae3ca6cbbaba8b7dbd7a6894375c6d5adf00819685f44f58b1e069dcd1062a70e99f0dbcfe39dc3d3 SHA512 f4c15c784194c80663c49692140afcfef3450b722254b99b2bd7fd0d7a08c57b463afcfa3b5609e799d0b2d6ff6451172eace91e93b886856d2591d491585c0c
diff --git a/net-libs/rest/rest-0.8.1-r1.ebuild b/net-libs/rest/rest-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..9e3edc280976
--- /dev/null
+++ b/net-libs/rest/rest-0.8.1-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 multilib-minimal virtualx
+
+DESCRIPTION="Helper library for RESTful services"
+HOMEPAGE="https://wiki.gnome.org/Projects/Librest"
+
+LICENSE="LGPL-2.1"
+SLOT="0.7"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 sparc x86"
+IUSE="+introspection test"
+RESTRICT="!test? ( test )"
+
+# Coverage testing should not be enabled
+RDEPEND="
+	app-misc/ca-certificates
+	>=dev-libs/glib-2.24:2[${MULTILIB_USEDEP}]
+	dev-libs/libxml2:2[${MULTILIB_USEDEP}]
+	net-libs/libsoup:2.4[${MULTILIB_USEDEP}]
+	introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+	dev-util/glib-utils
+	>=dev-util/gtk-doc-am-1.13
+	>=dev-util/intltool-0.40
+	virtual/pkgconfig
+	test? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
+"
+
+multilib_src_configure() {
+	# gnome support only adds dependency on obsolete libsoup-gnome
+	# https://bugzilla.gnome.org/show_bug.cgi?id=758166
+	ECONF_SOURCE="${S}" \
+	gnome2_src_configure \
+		--disable-gcov \
+		--without-gnome \
+		--with-ca-certificates="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt \
+		$(multilib_native_use_enable introspection)
+
+	if multilib_is_native_abi; then
+		ln -s "${S}"/docs/reference/rest/html docs/reference/rest/html || die
+	fi
+}
+
+multilib_src_test() {
+	# Tests need dbus
+	virtx emake check
+}
+
+multilib_src_compile() {
+	gnome2_src_compile
+}
+
+multilib_src_install() {
+	gnome2_src_install
+}
diff --git a/net-libs/rest/rest-0.8.1.ebuild b/net-libs/rest/rest-0.8.1.ebuild
deleted file mode 100644
index 1a871b83d473..000000000000
--- a/net-libs/rest/rest-0.8.1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-GNOME2_LA_PUNT="yes"
-
-inherit gnome2 multilib-minimal virtualx
-
-DESCRIPTION="Helper library for RESTful services"
-HOMEPAGE="https://wiki.gnome.org/Projects/Librest"
-
-LICENSE="LGPL-2.1"
-SLOT="0.7"
-IUSE="+introspection test"
-RESTRICT="!test? ( test )"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 sparc x86"
-
-# Coverage testing should not be enabled
-RDEPEND="
-	app-misc/ca-certificates
-	>=dev-libs/glib-2.24:2[${MULTILIB_USEDEP}]
-	dev-libs/libxml2:2[${MULTILIB_USEDEP}]
-	net-libs/libsoup:2.4[${MULTILIB_USEDEP}]
-	introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
-"
-DEPEND="${RDEPEND}
-	dev-util/glib-utils
-	>=dev-util/gtk-doc-am-1.13
-	>=dev-util/intltool-0.40
-	virtual/pkgconfig
-	test? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
-"
-
-multilib_src_configure() {
-	# gnome support only adds dependency on obsolete libsoup-gnome
-	# https://bugzilla.gnome.org/show_bug.cgi?id=758166
-	ECONF_SOURCE="${S}" \
-	gnome2_src_configure \
-		--disable-static \
-		--disable-gcov \
-		--without-gnome \
-		--with-ca-certificates="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt \
-		$(multilib_native_use_enable introspection)
-
-	if multilib_is_native_abi; then
-		ln -s "${S}"/docs/reference/rest/html docs/reference/rest/html || die
-	fi
-}
-
-multilib_src_test() {
-	# Tests need dbus
-	virtx emake check
-}
-
-multilib_src_compile() {
-	gnome2_src_compile
-}
-
-multilib_src_install() {
-	gnome2_src_install
-}
-- 
cgit v1.2.3