From b284a3168fa91a038925d2ecf5e4791011ea5e7d Mon Sep 17 00:00:00 2001
From: V3n3RiX <venerix@redcorelinux.org>
Date: Mon, 18 Nov 2019 10:15:03 +0000
Subject: gentoo resync : 18.11.2019

---
 gui-libs/Manifest.gz                  | Bin 883 -> 885 bytes
 gui-libs/wlroots/Manifest             |   3 +-
 gui-libs/wlroots/wlroots-0.6.0.ebuild |  77 ++++++++++++++++++++++++++++++++++
 gui-libs/wlroots/wlroots-0.8.1.ebuild |  75 ---------------------------------
 4 files changed, 79 insertions(+), 76 deletions(-)
 create mode 100644 gui-libs/wlroots/wlroots-0.6.0.ebuild
 delete mode 100644 gui-libs/wlroots/wlroots-0.8.1.ebuild

(limited to 'gui-libs')

diff --git a/gui-libs/Manifest.gz b/gui-libs/Manifest.gz
index ac930d8f6117..85ac01d21d81 100644
Binary files a/gui-libs/Manifest.gz and b/gui-libs/Manifest.gz differ
diff --git a/gui-libs/wlroots/Manifest b/gui-libs/wlroots/Manifest
index 673c273dee31..aa1bf0ff702d 100644
--- a/gui-libs/wlroots/Manifest
+++ b/gui-libs/wlroots/Manifest
@@ -1,5 +1,6 @@
+DIST wlroots-0.6.0.tar.gz 497934 BLAKE2B a0b631831752e533f83ed62e402ef69b0994df050fd643cf2ef89556face4a822b3936bc758b70ab160eedda8ced16c0992dc209600914095784bba97bd26ee2 SHA512 c205d4303a381e11ef2f4db2faac1ddf9ad85c675824aae9cfe62d9f8bd313f1568d4810db1d006416783b50c8364198648a46d1ba453a0d8f659d6920618286
 DIST wlroots-0.8.1.tar.gz 451814 BLAKE2B 85f221ba9068839f326e09df616f6182f518b9a129730dda794103305e3c0786d609a7cc6cb60a90c9d51cb77e3dbbc5993901271dcf1bd656c7744260561b06 SHA512 da41513de48e00303b31fde620463389103215011c6cc49b9a2420a1529889722aa54f26a211179c528709edb6b90ba2efdae5e4bcef18147d9516f3a94e365a
+EBUILD wlroots-0.6.0.ebuild 1882 BLAKE2B 1ecbd11added412bb951a2fcb2a3810e67788b2590ea5e7262bf8e86dd9fd7e34d5ee3845c8d7e0dba00d2750917b84d84645ced7e54c85162762221c34c7178 SHA512 03a62c755d4bf57a79be14fbce917245e658a09d57c71c5e8294dce579b189bc9ab64c9a87e06efe27214db281c9191a16d74ed6e545218a2fb81a23f1a8f619
 EBUILD wlroots-0.8.1-r1.ebuild 1884 BLAKE2B 700c130f84f1b46033a94be0f4322443cac7d5ed6b787a5dc8e124b615190701589e1509fc48a79839bdc8edb74e2502ae431b6f5c19e306be9afb84f3e72d3f SHA512 0e8437ccde986819667cafb5ebf303b1cd9abe7cba61631732be247d56e88f1c468cfb3463ef80a634980b0efff628efffc2302cf4027ed1d9b5e1ddd36144d1
-EBUILD wlroots-0.8.1.ebuild 1833 BLAKE2B edb5df931fcae891e93bc0b1cec73fe91e2ecb591247e8c393b87aa66ceb4428e69bfbd1fef32c0ea3f455bc0275d157544fa068b4e1e37b90cbdf03dd4afa23 SHA512 59103f8f703ff1a08a057d0745b0ebef61e32b4a921a06c93ab66618ede37ef16bdf10ec1652d12af5e5ac7b826b1a5ebb418773c6e505785f27289bab67aeed
 EBUILD wlroots-9999.ebuild 1836 BLAKE2B f18c1cba6f5a79b8824fa62280360efbd4c89c67f0b4ae1a83fc3aa5fd2a9dc5e5e12855c8e6a542b66b682405dd98c479d7043b2e687f7bf8b37305c7d6c6f3 SHA512 291b7060c3f782d26176fc38af7286c902283b3b20c64a50726368549f048e26b1b6666e442dc445f7a54a6f266f2e525cfd42a1e0615d52e4010108f217da81
 MISC metadata.xml 1611 BLAKE2B a52787db83324cc424c28255d7a6db05fa6ea7f92f2d5d7cd6ac4121e89f77b9e642be4ecccdb5b75be2f4ac9b1434f98d40743ae86be8044165f70cc59add65 SHA512 b04fbd1afea30e057f0feea17d05195fb76bf872aa80b5d5d6f20ac47a99c08c3703bee65b2352587a6ac588974a7da375228b439c82f861bdefa41537278a99
diff --git a/gui-libs/wlroots/wlroots-0.6.0.ebuild b/gui-libs/wlroots/wlroots-0.6.0.ebuild
new file mode 100644
index 000000000000..4b99b0444b45
--- /dev/null
+++ b/gui-libs/wlroots/wlroots-0.6.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit fcaps meson
+
+DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
+HOMEPAGE="https://github.com/swaywm/wlroots"
+
+if [[ ${PV} == 9999 ]]; then
+	EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+	inherit git-r3
+else
+	SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="amd64 arm64 x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="elogind icccm rdp systemd x11-backend X"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+	>=dev-libs/libinput-1.9.0:0=
+	>=dev-libs/wayland-1.17.0
+	media-libs/mesa[egl,gles2,gbm]
+	virtual/libudev
+	x11-libs/libdrm
+	x11-libs/libxkbcommon
+	x11-libs/pixman
+	elogind? ( >=sys-auth/elogind-237 )
+	icccm? ( x11-libs/xcb-util-wm )
+	rdp? ( net-misc/freerdp )
+	systemd? ( >=sys-apps/systemd-237 )
+	x11-backend? ( x11-libs/libxcb:0= )
+	X? (
+		x11-base/xorg-server[wayland]
+		x11-libs/libxcb:0=
+		x11-libs/xcb-util-image
+	)
+"
+RDEPEND="
+	${DEPEND}
+	media-video/ffmpeg:0=
+"
+BDEPEND="
+	>=dev-libs/wayland-protocols-1.17
+	virtual/pkgconfig
+"
+
+src_configure() {
+	# xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
+	local emesonargs=(
+		"-Dxcb-errors=disabled"
+		-Dlibcap=$(usex filecaps enabled disabled)
+		-Dxcb-icccm=$(usex icccm enabled disabled)
+		-Dxwayland=$(usex X enabled disabled)
+		-Dx11-backend=$(usex x11-backend enabled disabled)
+		"-Dexamples=false"
+		"-Dwerror=false"
+	)
+	if use systemd; then
+		emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
+	elif use elogind; then
+		emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=elogind")
+	else
+		emesonargs+=("-Dlogind=disabled")
+	fi
+
+	meson_src_configure
+}
+
+pkg_postinst() {
+	elog "You must be in the input group to allow your compositor"
+	elog "to access input devices via libinput."
+}
diff --git a/gui-libs/wlroots/wlroots-0.8.1.ebuild b/gui-libs/wlroots/wlroots-0.8.1.ebuild
deleted file mode 100644
index fb0cf5f0576d..000000000000
--- a/gui-libs/wlroots/wlroots-0.8.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit fcaps meson
-
-DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
-HOMEPAGE="https://github.com/swaywm/wlroots"
-
-if [[ ${PV} == 9999 ]]; then
-	EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
-	inherit git-r3
-else
-	SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-	KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0/8"
-IUSE="elogind icccm systemd x11-backend X"
-REQUIRED_USE="?? ( elogind systemd )"
-
-DEPEND="
-	>=dev-libs/libinput-1.9.0:0=
-	>=dev-libs/wayland-1.17.0
-	media-libs/mesa[egl,gles2,gbm]
-	virtual/libudev
-	x11-libs/libdrm
-	x11-libs/libxkbcommon
-	x11-libs/pixman
-	elogind? ( >=sys-auth/elogind-237 )
-	icccm? ( x11-libs/xcb-util-wm )
-	systemd? ( >=sys-apps/systemd-237 )
-	x11-backend? ( x11-libs/libxcb:0= )
-	X? (
-		x11-base/xorg-server[wayland]
-		x11-libs/libxcb:0=
-		x11-libs/xcb-util-image
-	)
-"
-RDEPEND="
-	${DEPEND}
-"
-BDEPEND="
-	>=dev-libs/wayland-protocols-1.17
-	virtual/pkgconfig
-"
-
-src_configure() {
-	# xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
-	local emesonargs=(
-		"-Dxcb-errors=disabled"
-		-Dlibcap=$(usex filecaps enabled disabled)
-		-Dxcb-icccm=$(usex icccm enabled disabled)
-		-Dxwayland=$(usex X enabled disabled)
-		-Dx11-backend=$(usex x11-backend enabled disabled)
-		"-Dexamples=false"
-		"-Dwerror=false"
-	)
-	if use systemd; then
-		emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
-	elif use elogind; then
-		emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=elogind")
-	else
-		emesonargs+=("-Dlogind=disabled")
-	fi
-
-	meson_src_configure
-}
-
-pkg_postinst() {
-	elog "You must be in the input group to allow your compositor"
-	elog "to access input devices via libinput."
-}
-- 
cgit v1.2.3