From deba8115d2c2af26df42966b91ef04ff4dd79cde Mon Sep 17 00:00:00 2001
From: V3n3RiX <venerix@redcorelinux.org>
Date: Thu, 14 May 2020 11:09:11 +0100
Subject: gentoo resync : 14.05.2020

---
 eclass/Manifest.gz            | Bin 36142 -> 36137 bytes
 eclass/bzr.eclass             |   3 +-
 eclass/distutils-r1.eclass    |   3 +-
 eclass/kernel-2.eclass        |   2 +-
 eclass/kernel-install.eclass  |   7 ++
 eclass/llvm.eclass            |   2 +-
 eclass/meson.eclass           | 156 ++++++++++++++++++++++++++++++++++++------
 eclass/mozconfig-v6.52.eclass |   2 +-
 eclass/python-utils-r1.eclass |  12 ++--
 eclass/rebar.eclass           |   8 ++-
 eclass/tests/distutils-r1.sh  |   2 +-
 eclass/tests/toolchain.sh     |   1 +
 eclass/texlive-module.eclass  |   6 +-
 eclass/toolchain.eclass       |   1 +
 eclass/twisted-r1.eclass      |   3 +-
 eclass/unpacker.eclass        |   3 +-
 16 files changed, 169 insertions(+), 42 deletions(-)

(limited to 'eclass')

diff --git a/eclass/Manifest.gz b/eclass/Manifest.gz
index 809d5b660b6e..9bdd44ac4406 100644
Binary files a/eclass/Manifest.gz and b/eclass/Manifest.gz differ
diff --git a/eclass/bzr.eclass b/eclass/bzr.eclass
index fc1de9dc9ccc..1c1e7dfa415e 100644
--- a/eclass/bzr.eclass
+++ b/eclass/bzr.eclass
@@ -1,6 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
+# @DEAD
 # @ECLASS: bzr.eclass
 # @MAINTAINER:
 # Ulrich Müller <ulm@gentoo.org>
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 51e99a009df1..254a25fd3a6e 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -416,7 +416,8 @@ distutils_enable_tests() {
 			;;
 		setup.py)
 			python_test() {
-				esetup.py test --verbose
+				nonfatal esetup.py test --verbose ||
+					die "Tests fail with ${EPYTHON}"
 			}
 			;;
 		unittest)
diff --git a/eclass/kernel-2.eclass b/eclass/kernel-2.eclass
index 6a6a268b264a..07af8d8ab2c5 100644
--- a/eclass/kernel-2.eclass
+++ b/eclass/kernel-2.eclass
@@ -1243,7 +1243,7 @@ unipatch() {
 					UNIPATCH_DROP+=" 5010_enable-additional-cpu-optimizations-for-gcc.patch"
 					UNIPATCH_DROP+=" 5010_enable-additional-cpu-optimizations-for-gcc-4.9.patch"
 					UNIPATCH_DROP+=" 5012_enable-cpu-optimizations-for-gcc91.patch"
-				elif [[ "${GCC_MAJOR_VER}" -eq 9 ]] && [[ ${GCC_MINOR_VER} -ge 1 ]]; then
+				elif [[ "${GCC_MAJOR_VER}" -ge 9 ]] && [[ ${GCC_MINOR_VER} -ge 1 ]]; then
 					UNIPATCH_DROP+=" 5010_enable-additional-cpu-optimizations-for-gcc.patch"
 					UNIPATCH_DROP+=" 5010_enable-additional-cpu-optimizations-for-gcc-4.9.patch"
 					UNIPATCH_DROP+=" 5011_enable-cpu-optimizations-for-gcc8.patch"
diff --git a/eclass/kernel-install.eclass b/eclass/kernel-install.eclass
index 1fdeb1bf4dc7..c26af5c2e88b 100644
--- a/eclass/kernel-install.eclass
+++ b/eclass/kernel-install.eclass
@@ -139,6 +139,7 @@ kernel-install_update_symlink() {
 	else
 		local symlink_target=$(readlink "${target}")
 		local symlink_ver=${symlink_target#${target##*/}-}
+		local updated=
 		if [[ ${symlink_target} == ${target##*/}-* && \
 				-z ${symlink_ver//[0-9.]/} ]]
 		then
@@ -151,8 +152,14 @@ kernel-install_update_symlink() {
 				ebegin "Updating ${target} symlink"
 				ln -f -n -s "${target##*/}-${version}" "${target}"
 				eend ${?}
+				updated=1
 			fi
 		fi
+
+		if [[ ! ${updated} ]]; then
+			elog "${target} points at another kernel, leaving it as-is."
+			elog "Please use 'eselect kernel' to update it when desired."
+		fi
 	fi
 }
 
diff --git a/eclass/llvm.eclass b/eclass/llvm.eclass
index 1a5b7176ae8a..a2da231b035a 100644
--- a/eclass/llvm.eclass
+++ b/eclass/llvm.eclass
@@ -81,7 +81,7 @@ if [[ ! ${_LLVM_ECLASS} ]]; then
 # @INTERNAL
 # @DESCRIPTION:
 # Correct values of LLVM slots, newest first.
-declare -g -r _LLVM_KNOWN_SLOTS=( 11 10 9 8 7 6 5 4 )
+declare -g -r _LLVM_KNOWN_SLOTS=( 11 10 9 8 )
 
 # @FUNCTION: get_llvm_prefix
 # @USAGE: [-b|-d] [<max_slot>]
diff --git a/eclass/meson.eclass b/eclass/meson.eclass
index 423a497e840c..e79faa1beea3 100644
--- a/eclass/meson.eclass
+++ b/eclass/meson.eclass
@@ -43,6 +43,10 @@ if [[ -z ${_MESON_ECLASS} ]]; then
 
 inherit multiprocessing ninja-utils python-utils-r1 toolchain-funcs
 
+if [[ ${EAPI} == 6 ]]; then
+	inherit eapi7-ver
+fi
+
 fi
 
 EXPORT_FUNCTIONS src_configure src_compile src_test src_install
@@ -125,17 +129,17 @@ _meson_env_array() {
 	python -c "${__MESON_ARRAY_PARSER}" "$@"
 }
 
-# @FUNCTION: _meson_create_cross_file
+# @FUNCTION: _meson_get_machine_info
+# @USAGE: <tuple>
+# @RETURN: system/cpu_family/cpu variables
 # @INTERNAL
 # @DESCRIPTION:
-# Creates a cross file. meson uses this to define settings for
-# cross-compilers. This function is called from meson_src_configure.
-_meson_create_cross_file() {
-	# Reference: http://mesonbuild.com/Cross-compilation.html
+# Translate toolchain tuple into machine values for meson.
+_meson_get_machine_info() {
+	local tuple=$1
 
 	# system roughly corresponds to uname -s (lowercase)
-	local system=unknown
-	case ${CHOST} in
+	case ${tuple} in
 		*-aix*)          system=aix ;;
 		*-cygwin*)       system=cygwin ;;
 		*-darwin*)       system=darwin ;;
@@ -145,19 +149,29 @@ _meson_create_cross_file() {
 		*-solaris*)      system=sunos ;;
 	esac
 
-	local cpu_family=$(tc-arch)
+	cpu_family=$(tc-arch "${tuple}")
 	case ${cpu_family} in
 		amd64) cpu_family=x86_64 ;;
 		arm64) cpu_family=aarch64 ;;
 	esac
 
 	# This may require adjustment based on CFLAGS
-	local cpu=${CHOST%%-*}
+	cpu=${tuple%%-*}
+}
+
+# @FUNCTION: _meson_create_cross_file
+# @RETURN: path to cross file
+# @INTERNAL
+# @DESCRIPTION:
+# Creates a cross file. meson uses this to define settings for
+# cross-compilers. This function is called from meson_src_configure.
+_meson_create_cross_file() {
+	local system cpu_family cpu
+	_meson_get_machine_info "${CHOST}"
 
-	local needs_exe_wrapper=false
-	tc-is-cross-compiler && needs_exe_wrapper=true
+	local fn=${T}/meson.${CHOST}.${ABI}.ini
 
-	cat > "${T}/meson.${CHOST}.${ABI}" <<-EOF
+	cat > "${fn}" <<-EOF
 	[binaries]
 	ar = $(_meson_env_array "$(tc-getAR)")
 	c = $(_meson_env_array "$(tc-getCC)")
@@ -181,16 +195,67 @@ _meson_create_cross_file() {
 	objc_link_args = $(_meson_env_array "${OBJCFLAGS} ${LDFLAGS}")
 	objcpp_args = $(_meson_env_array "${OBJCXXFLAGS} ${CPPFLAGS}")
 	objcpp_link_args = $(_meson_env_array "${OBJCXXFLAGS} ${LDFLAGS}")
-	needs_exe_wrapper = ${needs_exe_wrapper}
+	needs_exe_wrapper = true
 	sys_root = '${SYSROOT}'
-	pkg_config_libdir = '${PKG_CONFIG_LIBDIR-${EPREFIX}/usr/$(get_libdir)/pkgconfig}'
+	pkg_config_libdir = '${PKG_CONFIG_LIBDIR:-${EPREFIX}/usr/$(get_libdir)/pkgconfig}'
 
 	[host_machine]
 	system = '${system}'
 	cpu_family = '${cpu_family}'
 	cpu = '${cpu}'
-	endian = '$(tc-endian)'
+	endian = '$(tc-endian "${CHOST}")'
 	EOF
+
+	echo "${fn}"
+}
+
+# @FUNCTION: _meson_create_native_file
+# @RETURN: path to native file
+# @INTERNAL
+# @DESCRIPTION:
+# Creates a native file. meson uses this to define settings for
+# native compilers. This function is called from meson_src_configure.
+_meson_create_native_file() {
+	local system cpu_family cpu
+	_meson_get_machine_info "${CBUILD}"
+
+	local fn=${T}/meson.${CBUILD}.${ABI}.ini
+
+	cat > "${fn}" <<-EOF
+	[binaries]
+	ar = $(_meson_env_array "$(tc-getBUILD_AR)")
+	c = $(_meson_env_array "$(tc-getBUILD_CC)")
+	cpp = $(_meson_env_array "$(tc-getBUILD_CXX)")
+	fortran = $(_meson_env_array "$(tc-getBUILD_PROG FC gfortran)")
+	llvm-config = '$(tc-getBUILD_PROG LLVM_CONFIG llvm-config)'
+	objc = $(_meson_env_array "$(tc-getBUILD_PROG OBJC cc)")
+	objcpp = $(_meson_env_array "$(tc-getBUILD_PROG OBJCXX c++)")
+	pkgconfig = '$(tc-getBUILD_PKG_CONFIG)'
+	strip = $(_meson_env_array "$(tc-getBUILD_STRIP)")
+	windres = $(_meson_env_array "$(tc-getBUILD_PROG RC windres)")
+
+	[properties]
+	c_args = $(_meson_env_array "${BUILD_CFLAGS} ${BUILD_CPPFLAGS}")
+	c_link_args = $(_meson_env_array "${BUILD_CFLAGS} ${BUILD_LDFLAGS}")
+	cpp_args = $(_meson_env_array "${BUILD_CXXFLAGS} ${BUILD_CPPFLAGS}")
+	cpp_link_args = $(_meson_env_array "${BUILD_CXXFLAGS} ${BUILD_LDFLAGS}")
+	fortran_args = $(_meson_env_array "${BUILD_FCFLAGS}")
+	fortran_link_args = $(_meson_env_array "${BUILD_FCFLAGS} ${BUILD_LDFLAGS}")
+	objc_args = $(_meson_env_array "${BUILD_OBJCFLAGS} ${BUILD_CPPFLAGS}")
+	objc_link_args = $(_meson_env_array "${BUILD_OBJCFLAGS} ${BUILD_LDFLAGS}")
+	objcpp_args = $(_meson_env_array "${BUILD_OBJCXXFLAGS} ${BUILD_CPPFLAGS}")
+	objcpp_link_args = $(_meson_env_array "${BUILD_OBJCXXFLAGS} ${BUILD_LDFLAGS}")
+	needs_exe_wrapper = false
+	pkg_config_libdir = '${BUILD_PKG_CONFIG_LIBDIR:-${EPREFIX}/usr/$(get_libdir)/pkgconfig}'
+
+	[build_machine]
+	system = '${system}'
+	cpu_family = '${cpu_family}'
+	cpu = '${cpu}'
+	endian = '$(tc-endian "${CBUILD}")'
+	EOF
+
+	echo "${fn}"
 }
 
 # @FUNCTION: meson_use
@@ -226,6 +291,34 @@ meson_feature() {
 meson_src_configure() {
 	debug-print-function ${FUNCNAME} "$@"
 
+	local BUILD_CFLAGS=${BUILD_CFLAGS}
+	local BUILD_CPPFLAGS=${BUILD_CPPFLAGS}
+	local BUILD_CXXFLAGS=${BUILD_CXXFLAGS}
+	local BUILD_FCFLAGS=${BUILD_FCFLAGS}
+	local BUILD_OBJCFLAGS=${BUILD_OBJCFLAGS}
+	local BUILD_OBJCXXFLAGS=${BUILD_OBJCXXFLAGS}
+	local BUILD_LDFLAGS=${BUILD_LDFLAGS}
+	local BUILD_PKG_CONFIG_LIBDIR=${BUILD_PKG_CONFIG_LIBDIR}
+	local BUILD_PKG_CONFIG_PATH=${BUILD_PKG_CONFIG_PATH}
+
+	if tc-is-cross-compiler; then
+		: ${BUILD_CFLAGS:=-O1 -pipe}
+		: ${BUILD_CXXFLAGS:=-O1 -pipe}
+		: ${BUILD_FCFLAGS:=-O1 -pipe}
+		: ${BUILD_OBJCFLAGS:=-O1 -pipe}
+		: ${BUILD_OBJCXXFLAGS:=-O1 -pipe}
+	else
+		: ${BUILD_CFLAGS:=${CFLAGS}}
+		: ${BUILD_CPPFLAGS:=${CPPFLAGS}}
+		: ${BUILD_CXXFLAGS:=${CXXFLAGS}}
+		: ${BUILD_FCFLAGS:=${FCFLAGS}}
+		: ${BUILD_LDFLAGS:=${LDFLAGS}}
+		: ${BUILD_OBJCFLAGS:=${OBJCFLAGS}}
+		: ${BUILD_OBJCXXFLAGS:=${OBJCXXFLAGS}}
+		: ${BUILD_PKG_CONFIG_LIBDIR:=${PKG_CONFIG_LIBDIR}}
+		: ${BUILD_PKG_CONFIG_PATH:=${PKG_CONFIG_PATH}}
+	fi
+
 	local mesonargs=(
 		meson setup
 		--buildtype plain
@@ -234,12 +327,13 @@ meson_src_configure() {
 		--prefix "${EPREFIX}/usr"
 		--sysconfdir "${EPREFIX}/etc"
 		--wrap-mode nodownload
-		--pkg-config-path="${PKG_CONFIG_PATH-${EPREFIX}/usr/share/pkgconfig}"
+		--build.pkg-config-path "${BUILD_PKG_CONFIG_PATH}${BUILD_PKG_CONFIG_PATH:+:}${EPREFIX}/usr/share/pkgconfig"
+		--pkg-config-path "${PKG_CONFIG_PATH}${PKG_CONFIG_PATH:+:}${EPREFIX}/usr/share/pkgconfig"
+		--native-file "$(_meson_create_native_file)"
 	)
 
-	if tc-is-cross-compiler || [[ ${ABI} != ${DEFAULT_ABI-${ABI}} ]]; then
-		_meson_create_cross_file || die "unable to write meson cross file"
-		mesonargs+=( --cross-file "${T}/meson.${CHOST}.${ABI}" )
+	if tc-is-cross-compiler; then
+		mesonargs+=( --cross-file "$(_meson_create_cross_file)" )
 	fi
 
 	BUILD_DIR="${BUILD_DIR:-${WORKDIR}/${P}-build}"
@@ -272,8 +366,28 @@ meson_src_configure() {
 	# https://bugs.gentoo.org/625396
 	python_export_utf8_locale
 
-	echo "${mesonargs[@]}" >&2
-	tc-env_build "${mesonargs[@]}" || die
+	# https://bugs.gentoo.org/721786
+	local -x BOOST_INCLUDEDIR="${BOOST_INCLUDEDIR-${EPREFIX}/usr/include}"
+	local -x BOOST_LIBRARYDIR="${BOOST_LIBRARYDIR-${EPREFIX}/usr/$(get_libdir)}"
+
+	(
+		# https://bugs.gentoo.org/720860
+		if ver_test "$(meson --version)" -lt "0.54"; then
+			local -x CFLAGS=${BUILD_CFLAGS}
+			local -x CPPFLAGS=${BUILD_CPPFLAGS}
+			local -x CXXFLAGS=${BUILD_CXXFLAGS}
+			local -x FFLAGS=${BUILD_FCFLAGS}
+			local -x OBJCFLAGS=${BUILD_OBJCFLAGS}
+			local -x OBJCXXFLAGS=${BUILD_OBJCXXFLAGS}
+			local -x LDFLAGS=${BUILD_LDFLAGS}
+		else
+			# https://bugs.gentoo.org/720818
+			export -n {C,CPP,CXX,F,OBJC,OBJCXX,LD}FLAGS PKG_CONFIG_{LIBDIR,PATH}
+		fi
+
+		echo "${mesonargs[@]}" >&2
+		"${mesonargs[@]}"
+	) || die
 }
 
 # @FUNCTION: meson_src_compile
diff --git a/eclass/mozconfig-v6.52.eclass b/eclass/mozconfig-v6.52.eclass
index b8d9bb57c0db..42e6fb030cd3 100644
--- a/eclass/mozconfig-v6.52.eclass
+++ b/eclass/mozconfig-v6.52.eclass
@@ -118,7 +118,7 @@ RDEPEND=">=app-text/hunspell-1.2:=
 	>=dev-libs/glib-2.26:2
 	>=sys-libs/zlib-1.2.3
 	>=virtual/libffi-3.0.10
-	virtual/ffmpeg
+	media-video/ffmpeg
 	x11-libs/libX11
 	x11-libs/libXcomposite
 	x11-libs/libXdamage
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index e85aefda792a..4af710da363b 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -378,13 +378,11 @@ _python_export() {
 				local d
 				case ${impl} in
 					python2.7)
-						PYTHON_PKG_DEP='>=dev-lang/python-2.7.17-r1:2.7';;
-					python3.6)
-						PYTHON_PKG_DEP=">=dev-lang/python-3.6.10:3.6";;
-					python3.7)
-						PYTHON_PKG_DEP=">=dev-lang/python-3.7.7-r1:3.7";;
-					python3.8)
-						PYTHON_PKG_DEP=">=dev-lang/python-3.8.2:3.8";;
+						PYTHON_PKG_DEP='>=dev-lang/python-2.7.5-r2:2.7';;
+					python*)
+						PYTHON_PKG_DEP="dev-lang/python:${impl#python}";;
+					pypy)
+						PYTHON_PKG_DEP='>=dev-python/pypy-7.3.0:0=';;
 					pypy3)
 						PYTHON_PKG_DEP='>=dev-python/pypy3-7.3.0:0=';;
 					*)
diff --git a/eclass/rebar.eclass b/eclass/rebar.eclass
index f2a620fd8979..7f712905c407 100644
--- a/eclass/rebar.eclass
+++ b/eclass/rebar.eclass
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 # @ECLASS: rebar.eclass
 # @MAINTAINER:
-# Amadeusz Żołnowski <aidecoe@gentoo.org>
+# maintainer-needed@gentoo.org
 # @AUTHOR:
 # Amadeusz Żołnowski <aidecoe@gentoo.org>
 # @SUPPORTED_EAPIS: 6
@@ -32,7 +32,7 @@ esac
 
 EXPORT_FUNCTIONS src_prepare src_compile src_test src_install
 
-RDEPEND="dev-lang/erlang"
+RDEPEND="dev-lang/erlang:="
 DEPEND="${RDEPEND}
 	dev-util/rebar
 	>=sys-apps/gawk-4.1"
@@ -105,6 +105,8 @@ erebar() {
 	(( $# > 0 )) || die "erebar: at least one target is required"
 
 	local -x ERL_LIBS="${EPREFIX}$(get_erl_libs)"
+	[[ ${1} == eunit ]] && local -x ERL_LIBS="."
+
 	rebar -v skip_deps=true "$@" || die -n "rebar $@ failed"
 }
 
diff --git a/eclass/tests/distutils-r1.sh b/eclass/tests/distutils-r1.sh
index 10f57b59edf9..9ef4562edf1a 100755
--- a/eclass/tests/distutils-r1.sh
+++ b/eclass/tests/distutils-r1.sh
@@ -63,7 +63,7 @@ tend
 einfo distutils_enable_tests
 eindent
 BASE_IUSE="python_targets_python2_7"
-BASE_DEPS="python_targets_python2_7? ( >=dev-lang/python-2.7.17-r1:2.7 ) >=dev-lang/python-exec-2:=[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]"
+BASE_DEPS="python_targets_python2_7? ( >=dev-lang/python-2.7.5-r2:2.7 ) >=dev-lang/python-exec-2:=[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]"
 TEST_RESTRICT=" !test? ( test )"
 
 einfo "empty RDEPEND"
diff --git a/eclass/tests/toolchain.sh b/eclass/tests/toolchain.sh
index 1d05f6c126ba..e69e0c8f1dd2 100755
--- a/eclass/tests/toolchain.sh
+++ b/eclass/tests/toolchain.sh
@@ -83,6 +83,7 @@ test_downgrade_arch_flags 3.3 "-march=k6-2"       "-march=geode -mtune=barcelona
 test_downgrade_arch_flags 3.4 "-march=k8"         "-march=btver2 -mtune=generic"
 
 test_downgrade_arch_flags 10  "-march=native"     "-march=native"
+test_downgrade_arch_flags 8   "-march=znver1"     "-march=znver2"
 test_downgrade_arch_flags 4.2 "-march=native"     "-march=native"
 test_downgrade_arch_flags 4.1 "-march=nocona"     "-march=native"
 
diff --git a/eclass/texlive-module.eclass b/eclass/texlive-module.eclass
index 0ebf3565c0b3..75ef570cdd8c 100644
--- a/eclass/texlive-module.eclass
+++ b/eclass/texlive-module.eclass
@@ -97,7 +97,7 @@ BDEPEND="${COMMON_DEPEND}
 
 for i in ${TEXLIVE_MODULE_CONTENTS}; do
 	for tldev in ${TEXLIVE_DEVS}; do
-		SRC_URI="${SRC_URI} https://dev.gentoo.org/~${tldev}/distfiles/texlive/texlive-module-${i}-${PV}.${PKGEXT}"
+		SRC_URI="${SRC_URI} https://dev.gentoo.org/~${tldev}/distfiles/texlive/tl-${i}-${PV}.${PKGEXT}"
 	done
 done
 
@@ -105,7 +105,7 @@ done
 [[ -n ${TEXLIVE_MODULE_DOC_CONTENTS} ]] && SRC_URI="${SRC_URI} doc? ("
 for i in ${TEXLIVE_MODULE_DOC_CONTENTS}; do
 	for tldev in ${TEXLIVE_DEVS}; do
-		SRC_URI="${SRC_URI} https://dev.gentoo.org/~${tldev}/distfiles/texlive/texlive-module-${i}-${PV}.${PKGEXT}"
+		SRC_URI="${SRC_URI} https://dev.gentoo.org/~${tldev}/distfiles/texlive/tl-${i}-${PV}.${PKGEXT}"
 	done
 done
 [[ -n ${TEXLIVE_MODULE_DOC_CONTENTS} ]] && SRC_URI="${SRC_URI} )"
@@ -115,7 +115,7 @@ if [[ -n ${TEXLIVE_MODULE_SRC_CONTENTS} ]] ; then
 	SRC_URI="${SRC_URI} source? ("
 	for i in ${TEXLIVE_MODULE_SRC_CONTENTS}; do
 		for tldev in ${TEXLIVE_DEVS}; do
-			SRC_URI="${SRC_URI} https://dev.gentoo.org/~${tldev}/distfiles/texlive/texlive-module-${i}-${PV}.${PKGEXT}"
+			SRC_URI="${SRC_URI} https://dev.gentoo.org/~${tldev}/distfiles/texlive/tl-${i}-${PV}.${PKGEXT}"
 		done
 	done
 	SRC_URI="${SRC_URI} )"
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index c7eeb63b6d22..a8fd3e953bc3 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -1403,6 +1403,7 @@ downgrade_arch_flags() {
 
 	# "added" "arch" "replacement"
 	local archlist=(
+		9 znver2 znver1
 		4.9 bdver4 bdver3
 		4.9 bonnell atom
 		4.9 broadwell core-avx2
diff --git a/eclass/twisted-r1.eclass b/eclass/twisted-r1.eclass
index 7f0f796ec960..16faf25866c0 100644
--- a/eclass/twisted-r1.eclass
+++ b/eclass/twisted-r1.eclass
@@ -1,6 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
+# @DEAD
 # @ECLASS: twisted-r1.eclass
 # @MAINTAINER:
 # Gentoo Python Project <python@gentoo.org>
diff --git a/eclass/unpacker.eclass b/eclass/unpacker.eclass
index 370f0a9c59ab..865e2e1a1a58 100644
--- a/eclass/unpacker.eclass
+++ b/eclass/unpacker.eclass
@@ -279,7 +279,8 @@ unpack_deb() {
 			done
 		} < "${deb}"
 	else
-		ar x "${deb}"
+		local AR=${AR-ar}
+		${AR} x "${deb}" || die
 	fi
 
 	unpacker ./data.tar*
-- 
cgit v1.2.3