From 0f558761aa2dee1017b4751e4017205e015a9560 Mon Sep 17 00:00:00 2001
From: V3n3RiX <venerix@koprulu.sector>
Date: Wed, 29 Jun 2022 12:04:12 +0100
Subject: gentoo resync : 29.12.2022

---
 dev-python/sh/Manifest            |  4 ++--
 dev-python/sh/metadata.xml        |  4 ++++
 dev-python/sh/sh-1.14.2-r1.ebuild | 29 +++++++++++++++++++++++++++++
 dev-python/sh/sh-1.14.2.ebuild    | 25 -------------------------
 4 files changed, 35 insertions(+), 27 deletions(-)
 create mode 100644 dev-python/sh/sh-1.14.2-r1.ebuild
 delete mode 100644 dev-python/sh/sh-1.14.2.ebuild

(limited to 'dev-python/sh')

diff --git a/dev-python/sh/Manifest b/dev-python/sh/Manifest
index 35ce30b28fce..e11bf78c4808 100644
--- a/dev-python/sh/Manifest
+++ b/dev-python/sh/Manifest
@@ -1,5 +1,5 @@
 AUX sh-1.12.14-skip-unreliable-test.patch 317 BLAKE2B 3c45673daeec13cbdf851dd97061df85c41783a1b5d760d9d45386b8b4e3f88e25e3f98cbdbce44796e5803614d5474444e554d305089d098fab2cb07075cf71 SHA512 6adc7fd1e2a9f52804272bba1d83eddd6db82b4b67569fc75d169794a19c505d51fd53c949eaabdeb775119a5e3929902c2bbf3883ed299b2de0e4faad597835
 AUX sh-1.14.0-skip-unreliable-test.patch 237 BLAKE2B 55b600d9426f127704cb698bb4df90b103b0ee08d29165f4d45e3fa56f1c0e20d3ab63b404cfa8d2bc372549a77474a2396903081c606516837ff295990eb47d SHA512 632f195df6a85cd65890d093400f4fed099c2344fe4e7f9d46f3decd817405ea587a18b271da3449088cc23519b5f16b30a2030a81d3bfcee30d4d55c591d5fe
 DIST sh-1.14.2.tar.gz 63779 BLAKE2B adc9004334a53f3704e22c318df6b4f60fd9ca2d31f5a9601f84abfaf0fe2ded06938b165e10b1a977ed38fcad7d0fa08799f2f552fc2c6b9b4c2a6476477115 SHA512 b7917504ae85606e1986b681274077777ad3011639bfe933d4133c3ed16f930842e03b572caa396ca4d58f41fd5594bef776cc16c4b0fbd1242e57c6aad19e62
-EBUILD sh-1.14.2.ebuild 638 BLAKE2B 9c1fc4ae2b43ca4b7d55106f940a09e26e59c673713fb0b8f03e2ff5ce8340fdc5f30367fb62a29d61d2ba430eed08d2d9aa05fd249a77cad246b9fc29b0d346 SHA512 bd9721fe1b73f89425ee7e36226c10ad5cae2c8454351c27a07effc797f1447ef216b1b86cb89ecaa63249a4829115c5038680762c5d0264df95321bef76d033
-MISC metadata.xml 701 BLAKE2B 313f610698f39483c7ed9a099cf9c0378d1720c5b2de272f96b3b51524f0661634a1c109fa2d2e52d6c3bfefd309966520e17843c65283887dbf1764595ef213 SHA512 583172c28986254e7f691b6c63e68bcdbfc566983f89e04a918b95a757b3b9512c5195c508605bae1e3216de69c0678ebb8191715f8dc084c9965883b864e2a6
+EBUILD sh-1.14.2-r1.ebuild 704 BLAKE2B 0f3c0a04c8ca495d757c3bf3c76dcd970b81a541046be3dcfeea8b0e603f06d1c81f4b915ee4ff305815c75100fcde4a99f6eb16a45bf168871b1bb6747a285c SHA512 a46e1a22e2bdef6cc621e6b63e2597b5b442e261c84160155e25f1153d844ff9804962c00b2df6cdd1b6d4ad94e9b5bb45c32287dc3a17504aeb7c37b5184df2
+MISC metadata.xml 802 BLAKE2B 4eb5ab2ef69633f88a1f16f226eb78a161632232ca2d127acd89e1271ab7b31d551aa9759ee5f327cd94f06a6b11e9463d6a6fe1432d4be84489afa009ce7f6e SHA512 b3b21507c5eb85f9289499ee87a2db852b254b2cd1e9feef61cb731a9cd035f0c6c8e3f7bcb4a1267fe97faa34655674354ba696ca26cc18247e7fd150f60816
diff --git a/dev-python/sh/metadata.xml b/dev-python/sh/metadata.xml
index 4c9215bf03bf..06d79e11c18c 100644
--- a/dev-python/sh/metadata.xml
+++ b/dev-python/sh/metadata.xml
@@ -5,6 +5,10 @@
 		<email>chutzpah@gentoo.org</email>
 		<name>Patrick McLean</name>
 	</maintainer>
+	<maintainer type="project">
+		<email>python@gentoo.org</email>
+		<name>Python</name>
+	</maintainer>
 	<longdescription lang="en">
 	sh (previously pbs) is a full-fledged subprocess interface 
 	for Python 2.6 - 3.2 that allows you to call any program 
diff --git a/dev-python/sh/sh-1.14.2-r1.ebuild b/dev-python/sh/sh-1.14.2-r1.ebuild
new file mode 100644
index 000000000000..3e3501afdcd1
--- /dev/null
+++ b/dev-python/sh/sh-1.14.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python subprocess interface"
+HOMEPAGE="
+	https://github.com/amoffat/sh/
+	https://pypi.org/project/sh/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+
+PATCHES=(
+	"${FILESDIR}/sh-1.12.14-skip-unreliable-test.patch"
+	"${FILESDIR}/sh-1.14.0-skip-unreliable-test.patch"
+)
+
+python_test() {
+	"${EPYTHON}" test.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/sh/sh-1.14.2.ebuild b/dev-python/sh/sh-1.14.2.ebuild
deleted file mode 100644
index 0d89eb85d313..000000000000
--- a/dev-python/sh/sh-1.14.2.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python subprocess interface"
-HOMEPAGE="https://github.com/amoffat/sh"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
-PATCHES=(
-	"${FILESDIR}/sh-1.12.14-skip-unreliable-test.patch"
-	"${FILESDIR}/sh-1.14.0-skip-unreliable-test.patch"
-)
-
-python_test() {
-	"${EPYTHON}" test.py || die "Tests fail with ${EPYTHON}"
-}
-- 
cgit v1.2.3