From 7bb2a634b4e693c8545db3823c080e6edec25e77 Mon Sep 17 00:00:00 2001
From: V3n3RiX <venerix@koprulu.sector>
Date: Wed, 13 Sep 2023 04:43:25 +0100
Subject: gentoo auto-resync : 13:09:2023 - 04:43:25

---
 dev-python/google-api-python-client/Manifest       |  2 +
 .../google-api-python-client-2.99.0.ebuild         | 49 ++++++++++++++++++++++
 2 files changed, 51 insertions(+)
 create mode 100644 dev-python/google-api-python-client/google-api-python-client-2.99.0.ebuild

(limited to 'dev-python/google-api-python-client')

diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 15ec58fb3972..e877e1b954a5 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,5 +1,7 @@
 DIST google-api-python-client-2.97.0.tar.gz 11493962 BLAKE2B 243ee33b169f13e311839a3c57a4922a7ef8c09be9ffb02520580bd11b894ffa1116479abd0942503627d958f4553bc1e921a20c9ab05a4cd1386f585ca286c5 SHA512 bdbe64c3186347f111138963e70411f13ba3a8fd342cac5e93d8415093404c8ade9f53b3d81c8fb6e876095eb0016dc4efc1de9e61df1e308d6d359a3578db96
 DIST google-api-python-client-2.98.0.tar.gz 11651975 BLAKE2B 11dbe1ef86243d948887490421926c951339714b79ae62746b2c0b016505cae6e62dad8102f93ea48031dd686f21ad353210e5ac9843ab39fe9bb1d87eac4580 SHA512 dbf2b2bf6ae8934f7d2c20369eecc0ee00d21d96615e064bacdf4999ebda4a58897b0cab463958bfa39404fe7c1b922168710ef30d5f37849a076c409e2d12e0
+DIST google-api-python-client-2.99.0.tar.gz 11708318 BLAKE2B fa022efa0d747469f5ada202f959bdb518d7edbb7a5d18cb98f401b5c1af0f909426a86df6295bf06931548449e59ddae0b2b1ae4204cb8b7cee86e5d23d157a SHA512 b01aa1b1d6b74d77cdcb5f9c14d52ef96a248cb2cedaecfd321d7f295884ae6c12331099ad1ceab1eb6639957eed038f0ff9078962f9315c4c088b3f3c8e6dff
 EBUILD google-api-python-client-2.97.0.ebuild 1314 BLAKE2B 4b94f53adfddc78245531b7528b46e0f22ea97b1c3a2f856657d9239308e302abb13d95c75f7118e12c459f8350c035cea63691a55db8c9c089345bb1353e67e SHA512 ea3465da7f85594297f735b66d1e2378e2b2eceb530da38dda71ef2ff0ab26f5abddc8c0cfaafbd34abb040e114c67e55c71aa9a3e84fcede68ee298b1f32fbe
 EBUILD google-api-python-client-2.98.0.ebuild 1316 BLAKE2B d6d158b0cdd8c45d8d79dbc2977291d7e3342c7f53da3adcb227708ae8f3161413381d971dddf63b941a32b94133a6cd4c661d7b76863a5d3162db0495fdceaa SHA512 762a1b2c0e8c06f60e01fd9045abc4255999039a97e86145bdbe8ea7727d2bbfd3defd6c6e932a726f0efe001cb0364d1640f2a808c531ff57ec66d8740d9d13
+EBUILD google-api-python-client-2.99.0.ebuild 1316 BLAKE2B d6d158b0cdd8c45d8d79dbc2977291d7e3342c7f53da3adcb227708ae8f3161413381d971dddf63b941a32b94133a6cd4c661d7b76863a5d3162db0495fdceaa SHA512 762a1b2c0e8c06f60e01fd9045abc4255999039a97e86145bdbe8ea7727d2bbfd3defd6c6e932a726f0efe001cb0364d1640f2a808c531ff57ec66d8740d9d13
 MISC metadata.xml 538 BLAKE2B bf0b8ab3a89ce9ab1d2159f4c0ebfe3f2646aced20bd2006485510c12d22e83cc130fac979f699ae6431a610c8d2acf86c04b39bc262abaf167c20571a860810 SHA512 30d004d944055660165954f8475e57ba45cef56423c80a324118836d78e5376261409955155a40c9bd988f230f3e2fc44c6aeb6fae3028c78c55a382ccd83bff
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.99.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.99.0.ebuild
new file mode 100644
index 000000000000..0194f9640998
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.99.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+	https://github.com/googleapis/google-api-python-client/
+	https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+	>=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+	<dev-python/httplib2-1[${PYTHON_USEDEP}]
+	>=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+	>=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+	>=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+	>=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+	<dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+	test? (
+		dev-python/mock[${PYTHON_USEDEP}]
+		dev-python/pandas[${PYTHON_USEDEP}]
+		dev-python/parameterized[${PYTHON_USEDEP}]
+	)
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+	local EPYTEST_DESELECT=(
+		# require Internet access (and credentials)
+		tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+		tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+	)
+
+	epytest tests
+}
-- 
cgit v1.2.3