From 6ec19c7f1bc4aa70e5f8a86cd29d579a95d97035 Mon Sep 17 00:00:00 2001
From: V3n3RiX <venerix@redcorelinux.org>
Date: Sat, 18 Jan 2020 18:58:09 +0000
Subject: gentoo resync : 18.01.2020

---
 dev-ml/dune/dune-2.1.0.ebuild | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
 create mode 100644 dev-ml/dune/dune-2.1.0.ebuild

(limited to 'dev-ml/dune')

diff --git a/dev-ml/dune/dune-2.1.0.ebuild b/dev-ml/dune/dune-2.1.0.ebuild
new file mode 100644
index 000000000000..81bdc3273583
--- /dev/null
+++ b/dev-ml/dune/dune-2.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multiprocessing
+
+DESCRIPTION="A composable build system for OCaml"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+DEPEND="dev-lang/ocaml"
+RDEPEND="${DEPEND}
+	!dev-ml/jbuilder"
+BDEPEND=""
+
+RESTRICT="test"
+
+src_configure() {
+	ocaml configure.ml --libdir "${EPREFIX}/usr/$(get_libdir)/ocaml" || die
+}
+
+src_install() {
+	default
+	mv "${D}"/usr/doc "${D}"/usr/share/doc/${PF}
+	mv "${D}"/usr/man "${D}"/usr/share/man
+}
-- 
cgit v1.2.3