From debb2c431b40a6b4750a39956cc5fcfa5a4a6476 Mon Sep 17 00:00:00 2001
From: V3n3RiX <venerix@koprulu.sector>
Date: Fri, 7 Apr 2023 17:30:28 +0100
Subject: gentoo auto-resync : 07:04:2023 - 17:30:27

---
 dev-lang/Manifest.gz                        | Bin 19484 -> 19486 bytes
 dev-lang/rust-bin/Manifest                  |   2 +-
 dev-lang/rust-bin/rust-bin-1.68.2-r1.ebuild | 226 +++++++++++++++++++++++++++
 dev-lang/rust-bin/rust-bin-1.68.2.ebuild    | 229 ----------------------------
 4 files changed, 227 insertions(+), 230 deletions(-)
 create mode 100644 dev-lang/rust-bin/rust-bin-1.68.2-r1.ebuild
 delete mode 100644 dev-lang/rust-bin/rust-bin-1.68.2.ebuild

(limited to 'dev-lang')

diff --git a/dev-lang/Manifest.gz b/dev-lang/Manifest.gz
index 9fa2b00c1ec3..c7c490236b98 100644
Binary files a/dev-lang/Manifest.gz and b/dev-lang/Manifest.gz differ
diff --git a/dev-lang/rust-bin/Manifest b/dev-lang/rust-bin/Manifest
index e9f68beaf0d5..137673169723 100644
--- a/dev-lang/rust-bin/Manifest
+++ b/dev-lang/rust-bin/Manifest
@@ -169,5 +169,5 @@ EBUILD rust-bin-1.65.0-r1.ebuild 6793 BLAKE2B d0a58b6ef31ddb223cccdc65998038e9ff
 EBUILD rust-bin-1.66.1-r1.ebuild 6798 BLAKE2B 6c814eb21abe2a4f3e3511d609e7ccc9196f49dd2d3ac060e3c8727c84258206f80173cbe6ca544f27b4fd1a32346cf6c9ba308f4d3e2abaabbdefe3051169e7 SHA512 71c77d41dd56c309b7e9103a0cd87ff54b5a9fb7ec51ea62d871041a0cb18bcc44cd98d431507339d03bcedcadc1804bb2c86637e4e5c6ba707f95b0d3b98a35
 EBUILD rust-bin-1.67.1-r2.ebuild 6815 BLAKE2B 2de4c538189f9a2aad2b4d89c3dda55fa66f8dc9db229f3aef19191d6b1185e304e4a4041f52bd14513af7a02b950ea61697302d50432fabba346bf42dca8108 SHA512 610825359ada60e639220f0f9c48ef751b3e74c3a50723028605916e1391abecbc2748949a26105e25da2c8a95387109039d8db576fdec630a4fc86e57a02d01
 EBUILD rust-bin-1.68.1.ebuild 6815 BLAKE2B b47f39533ff91271bbc4042a2a235156284d4cdea92ce5f1ddc9a04f7b4c068275f582569f92b4d679b5bccc187b6a1265f069a3a328ff55c0ba2d7c32246e94 SHA512 261381915bbe46ca516b0ed49b6da19ec1354d335401a973514e1e09238b924d6cee6c0e5189a8b0c13dd4378257f77515b07eea4cc1679333fd8969cbed2eee
-EBUILD rust-bin-1.68.2.ebuild 6815 BLAKE2B 46ba4159a947db9df4e0514024e7eb04bbd05c24b5451509977e142cce9229d2026328293ab3bd7c4892ef2bba1b60b92213adba6054f6cf1dacc4dccf9301c4 SHA512 a047a0a1e136ca3bade956660543f874c8ff28b13c69d0c01daa78408b73b539efe95e3e6d59c87c225057d2469e65ddf179590f3db9441259b60deac44d93fc
+EBUILD rust-bin-1.68.2-r1.ebuild 6770 BLAKE2B 7b40eeaeecce67b8a1c2b4705805d966644db051701f9e9c367bd6dfaf1ff8b12933c4f8b82759db1e26ec64ad9f765cf1aff5f7f108538588002bd16a1cd2cd SHA512 c30549581c8acd13453fffb9cca41c33dc2155279de6c58522dd6710c6bada519aaea7fd781284e652c15ff53915af4e31ef06121e9816fd4bf2876e8ceb63f4
 MISC metadata.xml 602 BLAKE2B 8e74f441d22eeb8b276d77ed0a9c5bde01540a3f34d6053185b2be77dd9188b80c01c536f8bb18c4c60214bd0bf366a504c1f3627110a213332120b533f7ddd2 SHA512 5f120deec600c7453d503b6acb9460d1c765a567954c79749654365721b1b6fa2dd48d60d5f3fc86191e79d5f7f78d7aa1e9634e6127f333f81e546f9b0f74ac
diff --git a/dev-lang/rust-bin/rust-bin-1.68.2-r1.ebuild b/dev-lang/rust-bin/rust-bin-1.68.2-r1.ebuild
new file mode 100644
index 000000000000..efd643da0fd7
--- /dev/null
+++ b/dev-lang/rust-bin/rust-bin-1.68.2-r1.ebuild
@@ -0,0 +1,226 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib prefix rust-toolchain toolchain-funcs verify-sig multilib-minimal
+
+MY_P="rust-${PV}"
+# curl -L static.rust-lang.org/dist/channel-rust-${PV}.toml 2>/dev/null | grep "xz_url.*rust-src"
+MY_SRC_URI="${RUST_TOOLCHAIN_BASEURL%/}/2023-03-28/rust-src-${PV}.tar.xz"
+GENTOO_BIN_BASEURI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}" # omit leading slash
+
+DESCRIPTION="Systems programming language from Mozilla"
+HOMEPAGE="https://www.rust-lang.org/"
+SRC_URI="$(rust_all_arch_uris ${MY_P})
+	rust-src? ( ${MY_SRC_URI} )
+"
+# Keep this separate to allow easy commenting out if not yet built
+#SRC_URI+=" sparc? ( ${GENTOO_BIN_BASEURI}/${MY_P}-sparc64-unknown-linux-gnu.tar.xz ) "
+
+LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4 UoI-NCSA"
+SLOT="stable"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~x86"
+IUSE="clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
+
+DEPEND=""
+
+RDEPEND="
+	>=app-eselect/eselect-rust-20190311
+	dev-libs/openssl
+	sys-apps/lsb-release
+	sys-devel/gcc:*
+"
+
+BDEPEND="
+	prefix? ( dev-util/patchelf )
+	verify-sig? ( sec-keys/openpgp-keys-rust )
+"
+
+REQUIRED_USE="x86? ( cpu_flags_x86_sse2 )"
+
+QA_PREBUILT="
+	opt/${P}/bin/.*
+	opt/${P}/lib/.*.so
+	opt/${P}/libexec/.*
+	opt/${P}/lib/rustlib/.*/bin/.*
+	opt/${P}/lib/rustlib/.*/lib/.*
+"
+
+# An rmeta file is custom binary format that contains the metadata for the crate.
+# rmeta files do not support linking, since they do not contain compiled object files.
+# so we can safely silence the warning for this QA check.
+QA_EXECSTACK="opt/${P}/lib/rustlib/*/lib*.rlib:lib.rmeta"
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/rust.asc"
+
+pkg_pretend() {
+	if [[ "$(tc-is-softfloat)" != "no" ]] && [[ ${CHOST} == armv7* ]]; then
+		die "${CHOST} is not supported by upstream Rust. You must use a hard float version."
+	fi
+}
+
+src_unpack() {
+	# sadly rust-src tarball does not have corresponding .asc file
+	# so do partial verification
+	if use verify-sig; then
+		for f in ${A}; do
+			if [[ -f ${DISTDIR}/${f}.asc ]]; then
+				verify-sig_verify_detached "${DISTDIR}/${f}" "${DISTDIR}/${f}.asc"
+			fi
+		done
+	fi
+
+	default_src_unpack
+
+	mv "${WORKDIR}/${MY_P}-$(rust_abi)" "${S}" || die
+}
+
+patchelf_for_bin() {
+	local filetype=$(file -b ${1})
+	if [[ ${filetype} == *ELF*interpreter* ]]; then
+		einfo "${1}'s interpreter changed"
+		patchelf ${1} --set-interpreter ${2} || die
+	elif [[ ${filetype} == *script* ]]; then
+		hprefixify ${1}
+	fi
+}
+
+multilib_src_install() {
+	if multilib_is_native_abi; then
+
+	# start native abi install
+	pushd "${S}" >/dev/null || die
+	local analysis std
+	analysis="$(grep 'analysis' ./components)"
+	std="$(grep 'std' ./components)"
+	local components="rustc,cargo,${std}"
+	use doc && components="${components},rust-docs"
+	use clippy && components="${components},clippy-preview"
+	use rustfmt && components="${components},rustfmt-preview"
+	use rust-analyzer && components="${components},rust-analyzer-preview,${analysis}"
+	# Rust component 'rust-src' is extracted from separate archive
+	if use rust-src; then
+		einfo "Combining rust and rust-src installers"
+		mv -v "${WORKDIR}/rust-src-${PV}/rust-src" "${S}" || die
+		echo rust-src >> ./components || die
+		components="${components},rust-src"
+	fi
+	./install.sh \
+		--components="${components}" \
+		--disable-verify \
+		--prefix="${ED}/opt/${P}" \
+		--mandir="${ED}/opt/${P}/man" \
+		--disable-ldconfig \
+		|| die
+
+	if use prefix; then
+		local interpreter=$(patchelf --print-interpreter ${EPREFIX}/bin/bash)
+		ebegin "Changing interpreter to ${interpreter} for Gentoo prefix at ${ED}/opt/${P}/bin"
+		find "${ED}/opt/${P}/bin" -type f -print0 | \
+			while IFS=  read -r -d '' filename; do
+				patchelf_for_bin ${filename} ${interpreter} \; || die
+			done
+		eend $?
+	fi
+
+	local symlinks=(
+		cargo
+		rustc
+		rustdoc
+		rust-gdb
+		rust-gdbgui
+		rust-lldb
+	)
+
+	use clippy && symlinks+=( clippy-driver cargo-clippy )
+	use rustfmt && symlinks+=( rustfmt cargo-fmt )
+	use rust-analyzer && symlinks+=( rust-analyzer )
+
+	einfo "installing eselect-rust symlinks and paths"
+	local i
+	for i in "${symlinks[@]}"; do
+		# we need realpath on /usr/bin/* symlink return version-appended binary path.
+		# so /usr/bin/rustc should point to /opt/rust-bin-<ver>/bin/rustc-<ver>
+		local ver_i="${i}-bin-${PV}"
+		ln -v "${ED}/opt/${P}/bin/${i}" "${ED}/opt/${P}/bin/${ver_i}" || die
+		dosym "../../opt/${P}/bin/${ver_i}" "/usr/bin/${ver_i}"
+	done
+
+	# symlinks to switch components to active rust in eselect
+	dosym "../../../opt/${P}/lib" "/usr/lib/rust/lib-bin-${PV}"
+	dosym "../../../opt/${P}/man" "/usr/lib/rust/man-bin-${PV}"
+	dosym "../../opt/${P}/lib/rustlib" "/usr/lib/rustlib-bin-${PV}"
+	dosym "../../../opt/${P}/share/doc/rust" "/usr/share/doc/${P}"
+
+	# make all capital underscored variable
+	local CARGO_TRIPLET="$(rust_abi)"
+	CARGO_TRIPLET="${CARGO_TRIPLET//-/_}"
+	CARGO_TRIPLET="${CARGO_TRIPLET^^}"
+	cat <<-_EOF_ > "${T}/50${P}"
+	LDPATH="${EPREFIX}/usr/lib/rust/lib"
+	MANPATH="${EPREFIX}/usr/lib/rust/man"
+	$(usev elibc_musl "CARGO_TARGET_${CARGO_TRIPLET}_RUSTFLAGS=\"-C target-feature=-crt-static\"")
+	_EOF_
+	doenvd "${T}/50${P}"
+
+	# note: eselect-rust adds EROOT to all paths below
+	cat <<-_EOF_ > "${T}/provider-${P}"
+	/usr/bin/cargo
+	/usr/bin/rustdoc
+	/usr/bin/rust-gdb
+	/usr/bin/rust-gdbgui
+	/usr/bin/rust-lldb
+	/usr/lib/rustlib
+	/usr/lib/rust/lib
+	/usr/lib/rust/man
+	/usr/share/doc/rust
+	_EOF_
+
+	if use clippy; then
+		echo /usr/bin/clippy-driver >> "${T}/provider-${P}"
+		echo /usr/bin/cargo-clippy >> "${T}/provider-${P}"
+	fi
+	if use rustfmt; then
+		echo /usr/bin/rustfmt >> "${T}/provider-${P}"
+		echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"
+	fi
+	if use rust-analyzer; then
+		echo /usr/bin/rust-analyzer >> "${T}/provider-${P}"
+	fi
+
+	insinto /etc/env.d/rust
+	doins "${T}/provider-${P}"
+	popd >/dev/null || die
+	#end native abi install
+
+	else
+		local rust_target
+		rust_target="$(rust_abi $(get_abi_CHOST ${v##*.}))"
+		dodir "/opt/${P}/lib/rustlib"
+		cp -vr "${WORKDIR}/rust-${PV}-${rust_target}/rust-std-${rust_target}/lib/rustlib/${rust_target}"\
+			"${ED}/opt/${P}/lib/rustlib" || die
+	fi
+
+	# BUG: installs x86_64 binary on other arches
+	rm -f "${ED}/opt/${P}/lib/rustlib/"*/bin/rust-llvm-dwp || die
+}
+
+pkg_postinst() {
+	eselect rust update
+
+	elog "Rust installs a helper script for calling GDB now,"
+	elog "for your convenience it is installed under /usr/bin/rust-gdb-bin-${PV}."
+
+	if has_version app-editors/emacs; then
+		elog "install app-emacs/rust-mode to get emacs support for rust."
+	fi
+
+	if has_version app-editors/gvim || has_version app-editors/vim; then
+		elog "install app-vim/rust-vim to get vim support for rust."
+	fi
+}
+
+pkg_postrm() {
+	eselect rust cleanup
+}
diff --git a/dev-lang/rust-bin/rust-bin-1.68.2.ebuild b/dev-lang/rust-bin/rust-bin-1.68.2.ebuild
deleted file mode 100644
index 61bcd4214d77..000000000000
--- a/dev-lang/rust-bin/rust-bin-1.68.2.ebuild
+++ /dev/null
@@ -1,229 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib prefix rust-toolchain toolchain-funcs verify-sig multilib-minimal
-
-MY_P="rust-${PV}"
-# curl -L static.rust-lang.org/dist/channel-rust-${PV}.toml 2>/dev/null | grep "xz_url.*rust-src"
-MY_SRC_URI="${RUST_TOOLCHAIN_BASEURL%/}/2023-03-28/rust-src-${PV}.tar.xz"
-GENTOO_BIN_BASEURI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}" # omit leading slash
-
-DESCRIPTION="Systems programming language from Mozilla"
-HOMEPAGE="https://www.rust-lang.org/"
-SRC_URI="$(rust_all_arch_uris ${MY_P})
-	rust-src? ( ${MY_SRC_URI} )
-"
-# Keep this separate to allow easy commenting out if not yet built
-#SRC_URI+=" sparc? ( ${GENTOO_BIN_BASEURI}/${MY_P}-sparc64-unknown-linux-gnu.tar.xz ) "
-
-LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4 UoI-NCSA"
-SLOT="stable"
-KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~x86"
-IUSE="clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
-
-DEPEND=""
-
-RDEPEND="
-	>=app-eselect/eselect-rust-20190311
-	|| (
-		dev-libs/openssl-compat:1.1.1
-		<dev-libs/openssl-3
-	)
-	sys-apps/lsb-release
-	sys-devel/gcc:*
-"
-
-BDEPEND="
-	prefix? ( dev-util/patchelf )
-	verify-sig? ( sec-keys/openpgp-keys-rust )
-"
-
-REQUIRED_USE="x86? ( cpu_flags_x86_sse2 )"
-
-QA_PREBUILT="
-	opt/${P}/bin/.*
-	opt/${P}/lib/.*.so
-	opt/${P}/libexec/.*
-	opt/${P}/lib/rustlib/.*/bin/.*
-	opt/${P}/lib/rustlib/.*/lib/.*
-"
-
-# An rmeta file is custom binary format that contains the metadata for the crate.
-# rmeta files do not support linking, since they do not contain compiled object files.
-# so we can safely silence the warning for this QA check.
-QA_EXECSTACK="opt/${P}/lib/rustlib/*/lib*.rlib:lib.rmeta"
-
-VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/rust.asc"
-
-pkg_pretend() {
-	if [[ "$(tc-is-softfloat)" != "no" ]] && [[ ${CHOST} == armv7* ]]; then
-		die "${CHOST} is not supported by upstream Rust. You must use a hard float version."
-	fi
-}
-
-src_unpack() {
-	# sadly rust-src tarball does not have corresponding .asc file
-	# so do partial verification
-	if use verify-sig; then
-		for f in ${A}; do
-			if [[ -f ${DISTDIR}/${f}.asc ]]; then
-				verify-sig_verify_detached "${DISTDIR}/${f}" "${DISTDIR}/${f}.asc"
-			fi
-		done
-	fi
-
-	default_src_unpack
-
-	mv "${WORKDIR}/${MY_P}-$(rust_abi)" "${S}" || die
-}
-
-patchelf_for_bin() {
-	local filetype=$(file -b ${1})
-	if [[ ${filetype} == *ELF*interpreter* ]]; then
-		einfo "${1}'s interpreter changed"
-		patchelf ${1} --set-interpreter ${2} || die
-	elif [[ ${filetype} == *script* ]]; then
-		hprefixify ${1}
-	fi
-}
-
-multilib_src_install() {
-	if multilib_is_native_abi; then
-
-	# start native abi install
-	pushd "${S}" >/dev/null || die
-	local analysis std
-	analysis="$(grep 'analysis' ./components)"
-	std="$(grep 'std' ./components)"
-	local components="rustc,cargo,${std}"
-	use doc && components="${components},rust-docs"
-	use clippy && components="${components},clippy-preview"
-	use rustfmt && components="${components},rustfmt-preview"
-	use rust-analyzer && components="${components},rust-analyzer-preview,${analysis}"
-	# Rust component 'rust-src' is extracted from separate archive
-	if use rust-src; then
-		einfo "Combining rust and rust-src installers"
-		mv -v "${WORKDIR}/rust-src-${PV}/rust-src" "${S}" || die
-		echo rust-src >> ./components || die
-		components="${components},rust-src"
-	fi
-	./install.sh \
-		--components="${components}" \
-		--disable-verify \
-		--prefix="${ED}/opt/${P}" \
-		--mandir="${ED}/opt/${P}/man" \
-		--disable-ldconfig \
-		|| die
-
-	if use prefix; then
-		local interpreter=$(patchelf --print-interpreter ${EPREFIX}/bin/bash)
-		ebegin "Changing interpreter to ${interpreter} for Gentoo prefix at ${ED}/opt/${P}/bin"
-		find "${ED}/opt/${P}/bin" -type f -print0 | \
-			while IFS=  read -r -d '' filename; do
-				patchelf_for_bin ${filename} ${interpreter} \; || die
-			done
-		eend $?
-	fi
-
-	local symlinks=(
-		cargo
-		rustc
-		rustdoc
-		rust-gdb
-		rust-gdbgui
-		rust-lldb
-	)
-
-	use clippy && symlinks+=( clippy-driver cargo-clippy )
-	use rustfmt && symlinks+=( rustfmt cargo-fmt )
-	use rust-analyzer && symlinks+=( rust-analyzer )
-
-	einfo "installing eselect-rust symlinks and paths"
-	local i
-	for i in "${symlinks[@]}"; do
-		# we need realpath on /usr/bin/* symlink return version-appended binary path.
-		# so /usr/bin/rustc should point to /opt/rust-bin-<ver>/bin/rustc-<ver>
-		local ver_i="${i}-bin-${PV}"
-		ln -v "${ED}/opt/${P}/bin/${i}" "${ED}/opt/${P}/bin/${ver_i}" || die
-		dosym "../../opt/${P}/bin/${ver_i}" "/usr/bin/${ver_i}"
-	done
-
-	# symlinks to switch components to active rust in eselect
-	dosym "../../../opt/${P}/lib" "/usr/lib/rust/lib-bin-${PV}"
-	dosym "../../../opt/${P}/man" "/usr/lib/rust/man-bin-${PV}"
-	dosym "../../opt/${P}/lib/rustlib" "/usr/lib/rustlib-bin-${PV}"
-	dosym "../../../opt/${P}/share/doc/rust" "/usr/share/doc/${P}"
-
-	# make all capital underscored variable
-	local CARGO_TRIPLET="$(rust_abi)"
-	CARGO_TRIPLET="${CARGO_TRIPLET//-/_}"
-	CARGO_TRIPLET="${CARGO_TRIPLET^^}"
-	cat <<-_EOF_ > "${T}/50${P}"
-	LDPATH="${EPREFIX}/usr/lib/rust/lib"
-	MANPATH="${EPREFIX}/usr/lib/rust/man"
-	$(usev elibc_musl "CARGO_TARGET_${CARGO_TRIPLET}_RUSTFLAGS=\"-C target-feature=-crt-static\"")
-	_EOF_
-	doenvd "${T}/50${P}"
-
-	# note: eselect-rust adds EROOT to all paths below
-	cat <<-_EOF_ > "${T}/provider-${P}"
-	/usr/bin/cargo
-	/usr/bin/rustdoc
-	/usr/bin/rust-gdb
-	/usr/bin/rust-gdbgui
-	/usr/bin/rust-lldb
-	/usr/lib/rustlib
-	/usr/lib/rust/lib
-	/usr/lib/rust/man
-	/usr/share/doc/rust
-	_EOF_
-
-	if use clippy; then
-		echo /usr/bin/clippy-driver >> "${T}/provider-${P}"
-		echo /usr/bin/cargo-clippy >> "${T}/provider-${P}"
-	fi
-	if use rustfmt; then
-		echo /usr/bin/rustfmt >> "${T}/provider-${P}"
-		echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"
-	fi
-	if use rust-analyzer; then
-		echo /usr/bin/rust-analyzer >> "${T}/provider-${P}"
-	fi
-
-	insinto /etc/env.d/rust
-	doins "${T}/provider-${P}"
-	popd >/dev/null || die
-	#end native abi install
-
-	else
-		local rust_target
-		rust_target="$(rust_abi $(get_abi_CHOST ${v##*.}))"
-		dodir "/opt/${P}/lib/rustlib"
-		cp -vr "${WORKDIR}/rust-${PV}-${rust_target}/rust-std-${rust_target}/lib/rustlib/${rust_target}"\
-			"${ED}/opt/${P}/lib/rustlib" || die
-	fi
-
-	# BUG: installs x86_64 binary on other arches
-	rm -f "${ED}/opt/${P}/lib/rustlib/"*/bin/rust-llvm-dwp || die
-}
-
-pkg_postinst() {
-	eselect rust update
-
-	elog "Rust installs a helper script for calling GDB now,"
-	elog "for your convenience it is installed under /usr/bin/rust-gdb-bin-${PV}."
-
-	if has_version app-editors/emacs; then
-		elog "install app-emacs/rust-mode to get emacs support for rust."
-	fi
-
-	if has_version app-editors/gvim || has_version app-editors/vim; then
-		elog "install app-vim/rust-vim to get vim support for rust."
-	fi
-}
-
-pkg_postrm() {
-	eselect rust cleanup
-}
-- 
cgit v1.2.3