From 7fa8a1e3f149eea4c844c47cfe26136ed7614c58 Mon Sep 17 00:00:00 2001
From: V3n3RiX <venerix@koprulu.sector>
Date: Mon, 15 Apr 2024 12:04:03 +0100
Subject: gentoo auto-resync : 15:04:2024 - 12:04:02

---
 app-misc/Manifest.gz                      | Bin 50609 -> 50603 bytes
 app-misc/golly/Manifest                   |   2 +-
 app-misc/golly/golly-4.2-r1.ebuild        |  70 +++++++++++++++++++++++++
 app-misc/golly/golly-4.2.ebuild           |  70 -------------------------
 app-misc/pax-utils/Manifest               |   6 +--
 app-misc/pax-utils/pax-utils-1.3.5.ebuild |  82 ------------------------------
 app-misc/pax-utils/pax-utils-1.3.7.ebuild |   2 +-
 app-misc/pax-utils/pax-utils-9999.ebuild  |   4 +-
 8 files changed, 76 insertions(+), 160 deletions(-)
 create mode 100644 app-misc/golly/golly-4.2-r1.ebuild
 delete mode 100644 app-misc/golly/golly-4.2.ebuild
 delete mode 100644 app-misc/pax-utils/pax-utils-1.3.5.ebuild

(limited to 'app-misc')

diff --git a/app-misc/Manifest.gz b/app-misc/Manifest.gz
index 54192425b1ed..222db47cc56e 100644
Binary files a/app-misc/Manifest.gz and b/app-misc/Manifest.gz differ
diff --git a/app-misc/golly/Manifest b/app-misc/golly/Manifest
index b33ead30da85..4b73ce5f3ca0 100644
--- a/app-misc/golly/Manifest
+++ b/app-misc/golly/Manifest
@@ -1,4 +1,4 @@
 AUX golly-4.0-CFLAGS.patch 686 BLAKE2B 1d82b951bee9f336931ad2589bae03bd8e52ac2f982294f18abd5297bc0d5cbd877ece2716736ce8dfcf044c823cb707d6ce8923177b3ab2bbf09a3d0e247b92 SHA512 b883702ed44bd8469255bbc43191bbf91da64ff0048d4cc3c7cc0c5103e01fe49f9017ad1723d041ab080dfa46b68f4bab0b9abd850b74b1803d5bcebb04c36a
 DIST golly-4.2-src.tar.gz 15348982 BLAKE2B 21ebed4c282a77a3f61aafa98936c0bb39b39a7c97505e96fc43ac720bd2eea4cf20996ca28c801f79a46577a0cf99ff60614ce134081605d14ca5972c841d50 SHA512 b9f5cfdfe9b96590411695805dd8b875329c81027fef98dff3f16b832018be2ad3a06583bb64e12fb305268feba2347ef63c4586ff0e645721a8085f04ab382a
-EBUILD golly-4.2.ebuild 1481 BLAKE2B da8efee8856ec2f00f3c1e6ea2ba33cc28f7cf09da424f749049dabfeb97db36e5d52cc9a9d3fdd01c5e5f16fb2049084b5d9885f8759feac8bd1a4a9a4bdfa9 SHA512 293359d4150f9ed8458f597bcf590dae54d0eb98229493d7a98c7143b0be012fcbb1e4fb24bbcdfc247b95adde5eb1a2787d4e49965a5932c48580af78817489
+EBUILD golly-4.2-r1.ebuild 1482 BLAKE2B bcbf8fb6a1d9725833c7976cbc8ff84adb7ba1ad43281cac8491f88c3828a2e1296db9e35aad1c9a2544bd2a35d17ecebccf1cdfe81dbe8635a31d4961b796b3 SHA512 3bd1c11eb7546b45b93f9353443021024cfd9869c39c4c2ca54ee7eab6ae447b9a26457b4e3a884af562ac56dc15633f4ba318b96e79af33354b04271f656c30
 MISC metadata.xml 571 BLAKE2B 64399eaf28ab52d39c1338758ca1abc2f67f195e4320b01d411d00fc3e434065d25cbab6c886dddfcd18611cef4d057c0b74c22c73e432ce1c3efb22e523164a SHA512 7ddf9bbb0cb55f5beb5377b2f0a7823e125195d0019f45dfd26c0868fe57c69913d11946de5060416856ac68bca863fd06a1a1128704a8fa53fd494df4b106e5
diff --git a/app-misc/golly/golly-4.2-r1.ebuild b/app-misc/golly/golly-4.2-r1.ebuild
new file mode 100644
index 000000000000..c7e51fab9793
--- /dev/null
+++ b/app-misc/golly/golly-4.2-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER=3.2-gtk3
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit desktop python-single-r1 toolchain-funcs wxwidgets xdg
+
+DESCRIPTION="simulator for Conway's Game of Life and other cellular automata"
+HOMEPAGE="http://golly.sourceforge.net/
+	https://sourceforge.net/projects/golly/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+S="${WORKDIR}/${P}-src"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+	sys-libs/zlib
+	virtual/opengl
+	x11-libs/wxGTK:${WX_GTK_VER}[X,curl,opengl,sdl,tiff]
+	${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.0-CFLAGS.patch )
+
+pkg_setup() {
+	python-single-r1_pkg_setup
+	setup-wxwidgets
+}
+
+src_compile() {
+	local -a mymakeopts=(
+		ENABLE_SOUND=yes
+		GOLLYDIR="${EPREFIX}/usr/share/${PN}"
+		PYTHON=${EPYTHON}
+		WX_CONFIG=${WX_CONFIG}
+		AR="$(tc-getAR)"
+		CC="$(tc-getCC)"
+		CXX="$(tc-getCXX)"
+		CXXC="$(tc-getCXX)"
+		RANLIB="$(tc-getRANLIB)"
+	)
+	emake -C gui-wx -f makefile-gtk "${mymakeopts[@]}"
+}
+
+src_install() {
+	# Has no 'make install', let's install files manually.
+	exeinto /usr/bin
+	doexe golly bgolly
+
+	insinto /usr/share/${PN}
+	doins -r Help Patterns Scripts Rules docs
+
+	newicon --size 32 gui-wx/icons/appicon.xpm ${PN}.xpm
+	make_desktop_entry ${PN} "Golly" ${PN} "Science"
+}
+
+pkg_postinst() {
+	xdg_icon_cache_update
+}
+
+pkg_postrm() {
+	xdg_icon_cache_update
+}
diff --git a/app-misc/golly/golly-4.2.ebuild b/app-misc/golly/golly-4.2.ebuild
deleted file mode 100644
index a35f1c8f3a23..000000000000
--- a/app-misc/golly/golly-4.2.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-WX_GTK_VER=3.2-gtk3
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit desktop python-single-r1 toolchain-funcs wxwidgets xdg
-
-DESCRIPTION="simulator for Conway's Game of Life and other cellular automata"
-HOMEPAGE="http://golly.sourceforge.net/
-	https://sourceforge.net/projects/golly/"
-SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
-S="${WORKDIR}/${P}-src"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
-	sys-libs/zlib
-	virtual/opengl
-	x11-libs/wxGTK:${WX_GTK_VER}[X,curl,opengl,sdl,tiff]
-	${PYTHON_DEPS}
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}"/${PN}-4.0-CFLAGS.patch )
-
-pkg_setup() {
-	python-single-r1_pkg_setup
-	setup-wxwidgets
-}
-
-src_compile() {
-	local -a mymakeopts=(
-		ENABLE_SOUND=yes
-		GOLLYDIR="${EPREFIX}/usr/share/${PN}"
-		PYTHON=${EPYTHON}
-		WX_CONFIG=${WX_CONFIG}
-		AR="$(tc-getAR)"
-		CC="$(tc-getCC)"
-		CXX="$(tc-getCXX)"
-		CXXC="$(tc-getCXX)"
-		RANLIB="$(tc-getRANLIB)"
-	)
-	emake -C gui-wx -f makefile-gtk "${mymakeopts[@]}"
-}
-
-src_install() {
-	# Has no 'make install', let's install files manually.
-	exeinto /usr/bin
-	doexe golly bgolly
-
-	insinto /usr/share/${PN}
-	doins -r Help Patterns Scripts Rules docs
-
-	newicon --size 32 gui-wx/icons/appicon.xpm ${PN}.xpm
-	make_desktop_entry ${PN} "Golly" ${PN} "Science"
-}
-
-pkg_postinst() {
-	xdg_icon_cache_update
-}
-
-pkg_postrm() {
-	xdg_icon_cache_update
-}
diff --git a/app-misc/pax-utils/Manifest b/app-misc/pax-utils/Manifest
index 1eb5e37faf28..39b1cd569ee7 100644
--- a/app-misc/pax-utils/Manifest
+++ b/app-misc/pax-utils/Manifest
@@ -1,7 +1,5 @@
 AUX pax-utils-1.3.5-man-reorder-xmlto-arguments.patch 921 BLAKE2B c97680a374985c23602c98227ad8045f2dbeedd5c5a23374b26f7ce30fe0dedc789077229c4fed4bd8cc18ecb8e9c61f9a13a768dfcb500165e120ef7a7a7d06 SHA512 74ff3095b188c4f88608952b7619297c385dec98df16b336a3ad7fcd2c2514542c4e0053664e81400a729a8183d6a84fd04202826e143c63a4e5aff133f6a071
-DIST pax-utils-1.3.5.tar.xz 119764 BLAKE2B 13bd4dbdadefb382133bf42a2b1e740e84ac11661595b082346c80ff05fc7423f5d75cc01ff8a651d921310ae66c2b39a862d0b9db5d7f18e11d393360627fcf SHA512 f2b1753e15907461cc395abffe033d7f7ab8eb15e296b874e2c9d00507458672347b32d7f2f05d3a8625fc3afbdbf0721543f84e062afce7181a726d967e4836
 DIST pax-utils-1.3.7.tar.xz 113740 BLAKE2B d801df9c426f318c871655f238fe27b53e656c2789ef8508019997c98bbc540987b611642d87e76ae9f76a95f6cce1acd0b10e3491a146d1e3b3f727a6f96bdc SHA512 f1b87a564573da838a02c4cc10e0d5f9754c3b004ecb172a6290b48a8179b30695ae556942457dfac3caf07b91dd56eb1d801475c35e9708e4d671aa507f9576
-EBUILD pax-utils-1.3.5.ebuild 1925 BLAKE2B d9c9de8a3e8c247daa50a49c79d52a44e459c4513a42a8bff9f84a64cd681341261037413f57bce15c003967e37957961a6a477110607881cfa5da88367bb57d SHA512 72a41a8c1fb21995e2698e403f0dcffd00d8d017080a9ed772e279ec1fcd6c8fb6c0ab0014e55be3483c254548939fba4c8602237d44682dd3009c8e3606ed5c
-EBUILD pax-utils-1.3.7.ebuild 1854 BLAKE2B 0928f205d7facb226b1ba61838244c4bf3f9eda8e0ebc43e32af7adf603fc50759a3131be0ea7549d8c3cd8af7c3d5960dc8f2f342155a085bcfb3f2608050ac SHA512 f7fcb52d6d72f8cc4a720882542cbe5d5652201d0e89835a4dc6f9dd1539ffdd9b43eca5a542c484e76cb7f2016deebe239204d81e649e9404579ed1da1c3678
-EBUILD pax-utils-9999.ebuild 1863 BLAKE2B da324b536a590124f8437c13ae88816514fb9b9af00f77a9bea214eb4f8fd9335eded94e667c0e69128bc5e11397c0acf973268080c521af8b411c79a8ec159c SHA512 b82d1cd4e63e74a058459d9494b2f2c3ce566fcd01d19d66859ae9e562082c1e315f6a97d6251c1148a06d4112c2c68275ec1d4798ac921830a9d26d06effb2e
+EBUILD pax-utils-1.3.7.ebuild 1854 BLAKE2B b7dd190febeb1a3ac34d1f22290a3bcaf15f8d19368ea31204afe42e3a944015d9f54d499d181c344438c58c6911e65585c856b9760185dd0e90aed46360a701 SHA512 f855fd22a43e9d327ff1ff23aa34b04790ae1ec36c9c6f63e9d83531f8d0dd3c371fe574e16f7e44b062e79f4f903799a8a271a19605d80ab65c63c1f9632cc7
+EBUILD pax-utils-9999.ebuild 1863 BLAKE2B b2c55d42040aa2899dc49d716b6c48f3d2e4ec3822d3867044cd3b7f04efff3fcaa60830f4961757a7f9ae4bb9b2224a4f4a4230773094aa3c19ad78d9bc4e20 SHA512 3ffa923b5847121307321ab8ac26ebef5302c56f5602660fcdbe325fabac3714e9e446262df2720d88010abd8d098e6a9df1c8dca2c2ad559b0bdfdb69e7c8e6
 MISC metadata.xml 780 BLAKE2B a1bd460e70b7a2a4bc0e5012fb28a31890ebe745e9d1d99ad427b0382d9df9ffb8363dbf8907aef9e35da0ee59e489b80f084dce205250040d437ccc229ce49c SHA512 61246256f126a5533829b7e0af50168e7a7395f98fc21a64abc970955892874bc690901a36f791bd73a36e7b659e3843b63c504a9f360c5e41f1ce3678b08b5e
diff --git a/app-misc/pax-utils/pax-utils-1.3.5.ebuild b/app-misc/pax-utils/pax-utils-1.3.5.ebuild
deleted file mode 100644
index 61d80fca9097..000000000000
--- a/app-misc/pax-utils/pax-utils-1.3.5.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Note: if bumping pax-utils because of syscall changes in glibc, please
-# revbump glibc and update the dependency in its ebuild for the affected
-# versions.
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit meson python-single-r1
-
-DESCRIPTION="ELF utils that can check files for security relevant properties"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Hardened/PaX_Utilities"
-
-if [[ ${PV} == 9999 ]]; then
-	EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/pax-utils.git"
-	inherit git-r3
-else
-	SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz
-		https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
-	KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="caps +man python seccomp test"
-
-_PYTHON_DEPS="
-	${PYTHON_DEPS}
-	$(python_gen_cond_dep '
-		dev-python/pyelftools[${PYTHON_USEDEP}]
-	')
-"
-
-RDEPEND="caps? ( >=sys-libs/libcap-2.24 )
-	python? ( ${_PYTHON_DEPS} )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
-	caps? ( virtual/pkgconfig )
-	man? ( app-text/xmlto )
-
-	python? ( ${_PYTHON_DEPS} )
-"
-REQUIRED_USE="
-	python? ( ${PYTHON_REQUIRED_USE} )
-	test? ( python )
-"
-RESTRICT="
-	!test? ( test )
-"
-
-PATCHES=(
-	"${FILESDIR}/pax-utils-1.3.5-man-reorder-xmlto-arguments.patch"
-)
-
-pkg_setup() {
-	if use test || use python; then
-		python-single-r1_pkg_setup
-	fi
-}
-
-src_configure() {
-	local emesonargs=(
-		"-Dlddtree_implementation=$(usex python python sh)"
-		$(meson_feature caps use_libcap)
-		$(meson_feature man build_manpages)
-		$(meson_use seccomp use_seccomp)
-		$(meson_use test tests)
-
-		# fuzzing is currently broken
-		-Duse_fuzzing=false
-	)
-	meson_src_configure
-}
-
-src_install() {
-	meson_src_install
-
-	use python && python_fix_shebang "${ED}"/usr/bin/lddtree
-}
diff --git a/app-misc/pax-utils/pax-utils-1.3.7.ebuild b/app-misc/pax-utils/pax-utils-1.3.7.ebuild
index 533f1b106d01..5b93dc47b744 100644
--- a/app-misc/pax-utils/pax-utils-1.3.7.ebuild
+++ b/app-misc/pax-utils/pax-utils-1.3.7.ebuild
@@ -6,7 +6,7 @@ EAPI=8
 # Note: if bumping pax-utils because of syscall changes in glibc, please
 # revbump glibc and update the dependency in its ebuild for the affected
 # versions.
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
 
 inherit meson python-single-r1
 
diff --git a/app-misc/pax-utils/pax-utils-9999.ebuild b/app-misc/pax-utils/pax-utils-9999.ebuild
index 26cbf8dbb922..191841deb477 100644
--- a/app-misc/pax-utils/pax-utils-9999.ebuild
+++ b/app-misc/pax-utils/pax-utils-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=8
@@ -6,7 +6,7 @@ EAPI=8
 # Note: if bumping pax-utils because of syscall changes in glibc, please
 # revbump glibc and update the dependency in its ebuild for the affected
 # versions.
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
 
 inherit meson python-single-r1
 
-- 
cgit v1.2.3