From dc41efad78c64df9b74ed6f94dcf25391b8fc5e1 Mon Sep 17 00:00:00 2001
From: V3n3RiX <venerix@koprulu.sector>
Date: Sat, 9 Mar 2024 18:44:29 +0000
Subject: gentoo auto-resync : 09:03:2024 - 18:44:28

---
 app-crypt/yubioath-flutter-bin/Manifest            |  2 +
 .../yubioath-flutter-bin-6.4.0.ebuild              | 79 ++++++++++++++++++++++
 2 files changed, 81 insertions(+)
 create mode 100644 app-crypt/yubioath-flutter-bin/yubioath-flutter-bin-6.4.0.ebuild

(limited to 'app-crypt/yubioath-flutter-bin')

diff --git a/app-crypt/yubioath-flutter-bin/Manifest b/app-crypt/yubioath-flutter-bin/Manifest
index 833ee2b1b52f..cbc0543c6d9f 100644
--- a/app-crypt/yubioath-flutter-bin/Manifest
+++ b/app-crypt/yubioath-flutter-bin/Manifest
@@ -1,3 +1,5 @@
 DIST yubico-authenticator-6.1.0-linux.tar.gz 46363854 BLAKE2B f50f8dc6cdca9044c9c1a0f370cc71d627358038bd00f34bb3801d9b5cc31a5fc904ba817e5ad613c6947c9546691d965e6b373c89e220314747a5eb0321e217 SHA512 e4a63aa40e06ae4cbeee5fc32b749bcc94c9a22b86104ff32e8f94dcd34cf0a0e61e686efd4a21ea8965f37e997f53d452739bb4c332af2387473dccd5b72b99
+DIST yubico-authenticator-6.4.0-linux.tar.gz 34381501 BLAKE2B 472de3d5a3a0dc2f604f3626d50850dd28ab1ae70219dff9d98b91005f2899643f1aa2e7ceb9d7019acc42aaa61fad9b14f6adf8465e1cb0a0ad8bbb19872a00 SHA512 a9cb633233ed142edf288483f3e0e109c10fa01cf3639388403983ac8336df7fcd47d4dedfe76c7fa7b35fa643668a06a185fe1ae4875a7e3729db9b738c8f86
 EBUILD yubioath-flutter-bin-6.1.0-r3.ebuild 2330 BLAKE2B 9572de2146f97fae7dc0649ece52a1a9e9524f35bc66bcac1843a5c4f9fc48971ed08b50dff3a73f62d8c37b2be9a7052fdcd33a53a50c1b57118964c34f18c3 SHA512 6a4a92991be5a09a04713e3c767ce81b143de40637d8776f8a5bca4cb448eab8f077c0d6e6c6a214087a8e578624238c82719d6bbd1fcbb6df303eb33e8e717a
+EBUILD yubioath-flutter-bin-6.4.0.ebuild 2383 BLAKE2B 9c9ca550d3f6d5b0d5f949e7d35a636bb30540ed5c850952eb589359d9fbc9f1c62a14397d78640f910d3e39d75728bd1800a5d475df5d4d5c5d65d81823dd10 SHA512 3083871ccafd75bdc8e7bbbde0bbc1778e6d47d553f2dda2afb67cf75f4b556e47e6c0751d1908b225f4cbaeb9d2b05180daff34545c99cd064d37100904ed14
 MISC metadata.xml 333 BLAKE2B 7f04bc0877fb881af8d867ef35b9e9998e22be0c69747a2f36e16de3632cf0cb7835483430396244551dcac978021e9281301ebf0bde51a3ae2f022b9a03f354 SHA512 f857a7150979f6a9e93c21ab6a60dcfaf70998021605e94eb486d8db73371c9bcf7f02b80f4b65dcda84ead94fd3641acd00ed78a92e807f57ddd59a78080093
diff --git a/app-crypt/yubioath-flutter-bin/yubioath-flutter-bin-6.4.0.ebuild b/app-crypt/yubioath-flutter-bin/yubioath-flutter-bin-6.4.0.ebuild
new file mode 100644
index 000000000000..2de2d7c0e0f2
--- /dev/null
+++ b/app-crypt/yubioath-flutter-bin/yubioath-flutter-bin-6.4.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="Yubico Authenticator for TOTP"
+HOMEPAGE="
+	https://developers.yubico.com/yubioath-flutter/
+	https://github.com/Yubico/yubioath-flutter"
+SRC_URI="https://github.com/Yubico/yubioath-flutter/releases/download/${PV}/yubico-authenticator-${PV}-linux.tar.gz"
+S="${WORKDIR}/yubico-authenticator-${PV}-linux"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RDEPEND="
+	app-accessibility/at-spi2-core:2
+	app-crypt/ccid
+	dev-libs/glib:2
+	media-libs/libepoxy
+	sys-libs/glibc
+	x11-libs/cairo
+	x11-libs/gdk-pixbuf:2
+	x11-libs/gtk+:3
+	x11-libs/libxcb
+	x11-libs/pango"
+BDEPEND="app-admin/chrpath"
+
+# "Modern" app, built using Google's flutter framework.
+#
+# Don't even *think* about unbundling the dependencies, they're all
+# hardcoded into the main binary and the helper, including but not
+# limited to a full-fledged python interpreter that gets dlopen'd, an
+# assortment of python packages, the X11 kitchen sink, random GCC
+# libraries, and OpenSSL 1.1, oftentimes using git checkouts instead of
+# released versioned libraries.
+#
+# The only way to avoid this mess would be to build flutter from source,
+# but unfortunately life is too short to be dealing with whatever is
+# Google's framework-de-jour on a regular basis.
+QA_PREBUILT="opt/yubico-authenticator/*"
+
+src_install() {
+	einstalldocs
+	rm -r README* || die
+
+	sed -e 's|@EXEC_PATH/authenticator|authenticator|' \
+		-e 's|@EXEC_PATH/linux_support/com.yubico.yubioath.png|com.yubico.yubioath|g' \
+		-i linux_support/com.yubico.authenticator.desktop || die
+	domenu linux_support/com.yubico.authenticator.desktop
+	doicon -s 128 linux_support/com.yubico.yubioath.png
+	rm -r linux_support || die
+
+	exeinto /opt/yubico-authenticator
+	doexe authenticator
+	rm authenticator || die
+
+	exeinto /opt/yubico-authenticator/helper
+	doexe helper/authenticator-helper
+	rm helper/authenticator-helper || die
+
+	# prevent rpath_security_checks() trigger
+	chrpath -d helper/_internal/libjpeg-*.so* helper/_internal/pillow.libs/libjpeg-*.so* || die
+
+	insinto /opt/yubico-authenticator
+	doins -r .
+
+	dosym ../../opt/yubico-authenticator/authenticator /usr/bin/authenticator
+}
+
+pkg_postinst() {
+	xdg_pkg_postinst
+
+	elog "Make sure you are a member of the pcscd group"
+	elog "and the pcscd service is running."
+}
-- 
cgit v1.2.3