From 38423c67c8a23f6a1bc42038193182e2da3116eb Mon Sep 17 00:00:00 2001
From: V3n3RiX <venerix@redcorelinux.org>
Date: Sat, 25 Apr 2020 11:37:10 +0100
Subject: gentoo resync : 25.04.2020

---
 app-arch/rpm/Manifest               |   2 +-
 app-arch/rpm/rpm-4.14.2.1-r1.ebuild | 141 ++++++++++++++++++++++++++++++++++++
 app-arch/rpm/rpm-4.14.2.1.ebuild    | 139 -----------------------------------
 3 files changed, 142 insertions(+), 140 deletions(-)
 create mode 100644 app-arch/rpm/rpm-4.14.2.1-r1.ebuild
 delete mode 100644 app-arch/rpm/rpm-4.14.2.1.ebuild

(limited to 'app-arch/rpm')

diff --git a/app-arch/rpm/Manifest b/app-arch/rpm/Manifest
index 688f6d1396f0..8aa921c5f8b6 100644
--- a/app-arch/rpm/Manifest
+++ b/app-arch/rpm/Manifest
@@ -5,5 +5,5 @@ DIST rpm-4.14.1.tar.bz2 4103880 BLAKE2B 3fa7579a251b02ec89943b5505ad9ca7303a444e
 DIST rpm-4.14.2.1.tar.bz2 4156574 BLAKE2B 2eb0cf621eecef7d8977d28d52be922156ceb64b14d2aefda0f5a927b90cf3d3e9c055d773e05ed52422254397153b79557dc94bdb43ca28a2ea126153a43c1f SHA512 0aad457f91918904c15649a1764ce7cbfaf38e083678031286e866f7997be0435a6b7b73596706d97e9263cff7b4df4a3150b142d81e6e3fddbfcf67bd83f990
 EBUILD rpm-4.14.1-r1.ebuild 3370 BLAKE2B 91d16125d242b9e47d3d5d574a1fb3bcb06eea579a6a9dd86c74ba68f589b43ceab3ebb92e8e34101a3962c5c2f37fa264035fae2cad266a1de82fa464fc9870 SHA512 04970130008be7b6af851317db973f418363958805c851d090e046d9406fc82a233618f5c356f9bbf2c457690304a732ef5f245ec90edecc4467570189335e1b
 EBUILD rpm-4.14.1.ebuild 3226 BLAKE2B 688ea6295eab51b9c822f124070e3b0a45388f91c213392ee2fb7b70ad73614592e3afa04201ff645ec9ba0813d1e4bbf8dc68cdc5291856471a26e84663eb0a SHA512 d1fdbeb1010e1948ba93c23f2785e76844401edfd0faae29fc4031fa647b8bc253669df78548f2c2990470f8cd72cd07865b07456fb42c6c6c5c73f34a3f47ae
-EBUILD rpm-4.14.2.1.ebuild 3442 BLAKE2B 26439f164abf522c84d70ed279c4f13d8ae10e4de5ae642788320895c35d30fb23e9523f38cfd915d8ab7faa90137b08280ea0a109dcd1c653a48403ffd4ea23 SHA512 c3aad1d7759d7aeb66147b2fd2d606225dd0c43934066aa66e9a2cb6a2a24ed0a80189d294283ee319cee89c0efe5d828186b2f2cd1dfce7eb2f6535fd654d0b
+EBUILD rpm-4.14.2.1-r1.ebuild 3469 BLAKE2B 72b4077aa7b68fcffaeab8d2e81820739f553e469e07d86491ba0fd1e466c587f6c2688dc694aad81c185423ec621f24a42057cd886c8b398937245662a4570e SHA512 171147bf5e1f766df5cac9ad13a283731255460be6c373e41193cc885848322992b61526ad10d2d1116122489028b5f176ead192f1a0b779d596128f4621602a
 MISC metadata.xml 337 BLAKE2B d01523bdc86c3b93ae548f601265338290470dcb578a79757ba7d3b2c4be257c89e76c97b5d411f9271d9ee754981a004b03e2a5cfe9b6bd56e32932796771c9 SHA512 20a89c9f7af0c1a7dd5f325eb3c1af65044a6f09e6ea8c70033bf35819ee18faf8c3a0ee2cebcbc0849a84e962dbbdd2111e02b3369d0feccf3719dc0bcfa6cc
diff --git a/app-arch/rpm/rpm-4.14.2.1-r1.ebuild b/app-arch/rpm/rpm-4.14.2.1-r1.ebuild
new file mode 100644
index 000000000000..6275cdc3a4ce
--- /dev/null
+++ b/app-arch/rpm/rpm-4.14.2.1-r1.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+
+inherit autotools flag-o-matic perl-module python-single-r1 eapi7-ver
+
+DESCRIPTION="Red Hat Package Management Utils"
+HOMEPAGE="https://rpm.org
+	https://github.com/rpm-software-management/rpm"
+SRC_URI="http://ftp.rpm.org/releases/rpm-$(ver_cut 1-2).x/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# Tests are broken. See bug 657500
+RESTRICT="test"
+
+IUSE="acl caps doc dbus lua nls python selinux test zstd"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+CDEPEND="!app-arch/rpm5
+	app-arch/libarchive
+	>=sys-libs/db-4.5:*
+	>=sys-libs/zlib-1.2.3-r1
+	>=app-arch/bzip2-1.0.1
+	>=dev-libs/popt-1.7
+	>=app-crypt/gnupg-1.2
+	dbus? ( sys-apps/dbus )
+	dev-libs/elfutils
+	virtual/libintl
+	>=dev-lang/perl-5.8.8
+	dev-libs/nss
+	python? ( ${PYTHON_DEPS} )
+	nls? ( virtual/libintl )
+	lua? ( >=dev-lang/lua-5.1.0:*[deprecated] )
+	acl? ( virtual/acl )
+	caps? ( >=sys-libs/libcap-2.0 )
+	zstd? ( app-arch/zstd )
+"
+DEPEND="${CDEPEND}
+	nls? ( sys-devel/gettext )
+	doc? ( app-doc/doxygen )
+	virtual/pkgconfig
+	test? ( sys-apps/fakechroot )
+"
+RDEPEND="${CDEPEND}
+	selinux? ( sec-policy/selinux-rpm )
+"
+
+pkg_setup() {
+	use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+	eapply "${FILESDIR}"/${PN}-4.11.0-autotools.patch
+	eapply "${FILESDIR}"/${PN}-4.8.1-db-path.patch
+	eapply "${FILESDIR}"/${PN}-4.9.1.2-libdir.patch
+
+	# fix #356769
+	sed -i 's:%{_var}/tmp:/var/tmp:' macros.in || die "Fixing tmppath failed"
+	# fix #492642
+	sed -i "s:@__PYTHON@:${PYTHON}:" macros.in || die "Fixing %__python failed"
+
+	eapply_user
+
+	eautoreconf
+
+	# Prevent automake maintainer mode from kicking in (#450448).
+	touch -r Makefile.am preinstall.am
+}
+
+src_configure() {
+	append-cppflags -I"${EPREFIX}/usr/include/nss" -I"${EPREFIX}/usr/include/nspr"
+	econf \
+		--without-selinux \
+		--with-external-db \
+		--with-crypto=nss \
+		$(use_enable python) \
+		$(use_with doc hackingdocs) \
+		$(use_enable nls) \
+		$(use_enable dbus inhibit-plugin) \
+		$(use_with lua) \
+		$(use_with caps cap) \
+		$(use_with acl) \
+		$(use_enable zstd zstd $(usex zstd yes no))
+}
+
+src_install() {
+	default
+
+	# remove la files
+	find "${ED}" -name '*.la' -delete || die
+
+	# fix symlinks to /bin/rpm (#349840)
+	for binary in rpmquery rpmverify;do
+		ln -sf rpm "${ED}"/usr/bin/${binary} || die
+	done
+
+	if ! use nls; then
+		rm -rf "${ED}"/usr/share/man/?? || die
+	fi
+
+	keepdir /usr/src/rpm/{SRPMS,SPECS,SOURCES,RPMS,BUILD}
+
+	dodoc CREDITS README*
+	if use doc; then
+		for docname in hacking librpm; do
+			docinto "html/${docname}"
+			dodoc -r "doc/${docname}/html/."
+		done
+	fi
+
+	# Fix perllocal.pod file collision
+	perl_delete_localpod
+
+	use python && python_optimize
+}
+
+src_test() {
+	# Known to fail with FEATURES=usersandbox (bug #657500):
+	if has usersandbox $FEATURES ; then
+		ewarn "You are emerging ${P} with 'usersandbox' enabled." \
+			"Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
+	fi
+
+	emake check
+}
+
+pkg_postinst() {
+	if [[ -f "${EROOT}"/var/lib/rpm/Packages ]] ; then
+		einfo "RPM database found... Rebuilding database (may take a while)..."
+		"${EROOT}"/usr/bin/rpmdb --rebuilddb --root="${EROOT}" || die
+	else
+		einfo "No RPM database found... Creating database..."
+		"${EROOT}"/usr/bin/rpmdb --initdb --root="${EROOT}" || die
+	fi
+}
diff --git a/app-arch/rpm/rpm-4.14.2.1.ebuild b/app-arch/rpm/rpm-4.14.2.1.ebuild
deleted file mode 100644
index 138f3de74f04..000000000000
--- a/app-arch/rpm/rpm-4.14.2.1.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit autotools flag-o-matic perl-module python-single-r1 eapi7-ver
-
-DESCRIPTION="Red Hat Package Management Utils"
-HOMEPAGE="https://rpm.org
-	https://github.com/rpm-software-management/rpm"
-SRC_URI="http://ftp.rpm.org/releases/rpm-$(ver_cut 1-2).x/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-
-# Tests are broken. See bug 657500
-RESTRICT="test"
-
-IUSE="acl caps doc dbus lua nls python selinux test zstd"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-CDEPEND="!app-arch/rpm5
-	app-arch/libarchive
-	>=sys-libs/db-4.5:*
-	>=sys-libs/zlib-1.2.3-r1
-	>=app-arch/bzip2-1.0.1
-	>=dev-libs/popt-1.7
-	>=app-crypt/gnupg-1.2
-	dbus? ( sys-apps/dbus )
-	dev-libs/elfutils
-	virtual/libintl
-	>=dev-lang/perl-5.8.8
-	dev-libs/nss
-	python? ( ${PYTHON_DEPS} )
-	nls? ( virtual/libintl )
-	lua? ( >=dev-lang/lua-5.1.0:*[deprecated] )
-	acl? ( virtual/acl )
-	caps? ( >=sys-libs/libcap-2.0 )
-	zstd? ( app-arch/zstd )
-"
-DEPEND="${CDEPEND}
-	nls? ( sys-devel/gettext )
-	doc? ( app-doc/doxygen )
-	virtual/pkgconfig
-	test? ( sys-apps/fakechroot )
-"
-RDEPEND="${CDEPEND}
-	selinux? ( sec-policy/selinux-rpm )
-"
-
-pkg_setup() {
-	use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
-	eapply "${FILESDIR}"/${PN}-4.11.0-autotools.patch
-	eapply "${FILESDIR}"/${PN}-4.8.1-db-path.patch
-	eapply "${FILESDIR}"/${PN}-4.9.1.2-libdir.patch
-
-	# fix #356769
-	sed -i 's:%{_var}/tmp:/var/tmp:' macros.in || die "Fixing tmppath failed"
-	# fix #492642
-	sed -i "s:@__PYTHON@:${PYTHON}:" macros.in || die "Fixing %__python failed"
-
-	eapply_user
-
-	eautoreconf
-
-	# Prevent automake maintainer mode from kicking in (#450448).
-	touch -r Makefile.am preinstall.am
-}
-
-src_configure() {
-	append-cppflags -I"${EPREFIX}/usr/include/nss" -I"${EPREFIX}/usr/include/nspr"
-	econf \
-		--without-selinux \
-		--with-external-db \
-		--with-crypto=nss \
-		$(use_enable python) \
-		$(use_with doc hackingdocs) \
-		$(use_enable nls) \
-		$(use_enable dbus inhibit-plugin) \
-		$(use_with lua) \
-		$(use_with caps cap) \
-		$(use_with acl) \
-		$(use_enable zstd zstd $(usex zstd yes no))
-}
-
-src_install() {
-	default
-
-	# remove la files
-	find "${ED}" -name '*.la' -delete || die
-
-	# fix symlinks to /bin/rpm (#349840)
-	for binary in rpmquery rpmverify;do
-		ln -sf rpm "${ED}"/usr/bin/${binary} || die
-	done
-
-	if ! use nls; then
-		rm -rf "${ED}"/usr/share/man/?? || die
-	fi
-
-	keepdir /usr/src/rpm/{SRPMS,SPECS,SOURCES,RPMS,BUILD}
-
-	dodoc CREDITS README*
-	if use doc; then
-		for docname in hacking librpm; do
-			docinto "html/${docname}"
-			dodoc -r "doc/${docname}/html/."
-		done
-	fi
-
-	# Fix perllocal.pod file collision
-	perl_delete_localpod
-}
-
-src_test() {
-	# Known to fail with FEATURES=usersandbox (bug #657500):
-	if has usersandbox $FEATURES ; then
-		ewarn "You are emerging ${P} with 'usersandbox' enabled." \
-			"Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
-	fi
-
-	emake check
-}
-
-pkg_postinst() {
-	if [[ -f "${EROOT}"/var/lib/rpm/Packages ]] ; then
-		einfo "RPM database found... Rebuilding database (may take a while)..."
-		"${EROOT}"/usr/bin/rpmdb --rebuilddb --root="${EROOT}" || die
-	else
-		einfo "No RPM database found... Creating database..."
-		"${EROOT}"/usr/bin/rpmdb --initdb --root="${EROOT}" || die
-	fi
-}
-- 
cgit v1.2.3