summaryrefslogtreecommitdiff
path: root/x11-terms/kitty/kitty-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/kitty/kitty-9999.ebuild')
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index b51c9110b0ed..a458d0c67387 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python3_{5,6} )
-inherit python-single-r1 toolchain-funcs
+inherit python-single-r1 toolchain-funcs gnome2-utils
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
@@ -48,7 +48,7 @@ DEPEND="${RDEPEND}
"
PATCHES=(
- "${FILESDIR}"/${PN}-0.7.1-flags.patch
+ "${FILESDIR}"/${PN}-0.9.1-flags.patch
"${FILESDIR}"/${PN}-0.7.1-svg-icon.patch
)
@@ -84,3 +84,11 @@ src_install() {
dodoc CHANGELOG.rst *.asciidoc
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}