summaryrefslogtreecommitdiff
path: root/x11-misc/xstroke/xstroke-0.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xstroke/xstroke-0.6-r1.ebuild')
-rw-r--r--x11-misc/xstroke/xstroke-0.6-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-misc/xstroke/xstroke-0.6-r1.ebuild b/x11-misc/xstroke/xstroke-0.6-r1.ebuild
new file mode 100644
index 000000000000..8d03a8cf83eb
--- /dev/null
+++ b/x11-misc/xstroke/xstroke-0.6-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="Gesture/Handwriting recognition engine for X"
+# Dead upstream?
+#HOMEPAGE="http://www.xstroke.org/"
+HOMEPAGE="http://freshmeat.net/projects/xstroke/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha ~amd64 hppa ~mips ppc sparc x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXpm
+ x11-libs/libXrender
+ x11-libs/libXtst
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/flex
+ virtual/pkgconfig
+ virtual/yacc
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-sigsegv_sprintf.patch \
+ "${FILESDIR}"/${P}-underlinking.patch
+ eautoreconf
+}