summaryrefslogtreecommitdiff
path: root/x11-misc/pypanel
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/pypanel')
-rw-r--r--x11-misc/pypanel/Manifest5
-rw-r--r--x11-misc/pypanel/metadata.xml22
-rw-r--r--x11-misc/pypanel/pypanel-2.4-r2.ebuild27
3 files changed, 54 insertions, 0 deletions
diff --git a/x11-misc/pypanel/Manifest b/x11-misc/pypanel/Manifest
new file mode 100644
index 000000000000..e092c976552d
--- /dev/null
+++ b/x11-misc/pypanel/Manifest
@@ -0,0 +1,5 @@
+DIST PyPanel-2.4.tar.gz 29857 SHA256 4e612b43c61b3a8af7d57a0364f6cd89df481dc41e20728afa643e9e3546e911 SHA512 acda16cbf4f725ee3f0e97e11f04177fc819f6c09d0bcc864c9de1fc0c1bc0bfe2593233e5b8b85399ad41bc07763ad87d7045bac4dece9dc15d6eaf3136895e WHIRLPOOL 79e64c13a20af9837d3b54b555adcfc477649a01d477f2adf7d82bd594a951dbd8f141d969fff17a93aec4a0e6a6381ca48230a73d6be6072c6b77e6309adbfa
+EBUILD pypanel-2.4-r2.ebuild 568 SHA256 11770f34ec925936b08d2b79cb9192f9c4121b35682382fa6870f94f9c1b1270 SHA512 ce66dfc3d7d612638aeeb353751ba54271ccb15a905767c21796cfba8b537482a80385faf2a9feb61fc91f010cc707278431252499b0ef3d1ed590ce6094b7e7 WHIRLPOOL 24782342d6222ad434e219d744fe3295173720458ce2a691d2ee4b399659e7108457ab9a989e0222698c0f639f0397cfc78a8fe77ba64e54ec5dc23b47994893
+MISC ChangeLog 2429 SHA256 337feec432311f47c54e995db702361a1cdadcb708099c6c4dcbf1d47fbce6c2 SHA512 273d853d21ed827036827118652db973ac7f74aed84a4cb9900ae40796d09a5eb3729faf11fbf0f316b65ebb0a27abbdbe021d48c8d6045ec9f7331638c81515 WHIRLPOOL cf74ce7ef85c1d6e05e763058821ea44ddfab6ec2ce0bc79bf3692a0328c0e173e1382ecb26d1b82dc4222173e3369abdcdd50cf025dcc0143f620a93580ef53
+MISC ChangeLog-2015 5445 SHA256 06d004c97712ae74c2d105f562276d33936d7be1f04609dc4c0c13f522a07a38 SHA512 7da0eab0224ca8ad947ad9a4cc08a02fc6b97f0748edd5ec0f72a26fd5b0bc02a0b9a9fb8a3bfb5874471879a92a1b40adf69db4c45e1319fde34a55fc18ed83 WHIRLPOOL 01a051f279d54057cdace31463e6b0f92c2839a40b83a377e8d828b3e2bda40c3436c992fe2286522142977c91449062aba143c8f95a5a299877428f57a3c1fc
+MISC metadata.xml 841 SHA256 38edb4854e3ed6cba51bbd5bfdfa96707bb8b1e9590df009abaac453ff4e0779 SHA512 b37b25700ac1fbaec3050a47fc8f2260b4611c3da72b5f192eff3a64f18a6e4aee8dfdf9a8203e12f7b8bfcaa912f64471bc874decf1324ef16f9d6e9fb88a08 WHIRLPOOL 28c3ba45a936b2dc9ef4a1b339c7a4e2c7bff11deaea0cf1f03b57ab259c2e537d4c02d6bfe8dab65f4a4ad7045aa69c56dd95e649d00ce13c280984ca45009a
diff --git a/x11-misc/pypanel/metadata.xml b/x11-misc/pypanel/metadata.xml
new file mode 100644
index 000000000000..b6a5bfce49f3
--- /dev/null
+++ b/x11-misc/pypanel/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>desktop-misc@gentoo.org</email>
+ <name>Gentoo Desktop Miscellaneous Project</name>
+ </maintainer>
+ <longdescription>
+PyPanel is a lightweight panel/taskbar for X11 window managers that can
+be easily customized to match any desktop theme or taste.
+
+Some of the customizable features include transparency w/ shading, panel
+dimensions and location, font type and colors, button events/actions,
+clock and workspace name display.
+
+PyPanel should work with any WM that supports the EWMH specification.
+The following have been tested: Kahakai, Openbox3, PekWM, WindowMaker.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pypanel</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/pypanel/pypanel-2.4-r2.ebuild b/x11-misc/pypanel/pypanel-2.4-r2.ebuild
new file mode 100644
index 000000000000..c1c3381177d7
--- /dev/null
+++ b/x11-misc/pypanel/pypanel-2.4-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN=${PN/pyp/PyP}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A lightweight panel/taskbar for X11 window managers"
+HOMEPAGE="http://pypanel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXft
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-libs/imlib2[X]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}