summaryrefslogtreecommitdiff
path: root/x11-misc/menumaker
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/menumaker')
-rw-r--r--x11-misc/menumaker/Manifest3
-rw-r--r--x11-misc/menumaker/files/menumaker-0.99.11-AM_PATH_PYTHON.patch100
-rw-r--r--x11-misc/menumaker/menumaker-0.99.11.ebuild58
3 files changed, 161 insertions, 0 deletions
diff --git a/x11-misc/menumaker/Manifest b/x11-misc/menumaker/Manifest
index 415c39afd1b8..bcf228f6b235 100644
--- a/x11-misc/menumaker/Manifest
+++ b/x11-misc/menumaker/Manifest
@@ -1,4 +1,7 @@
AUX menumaker-0.99.10-AM_PATH_PYTHON.patch 2517 BLAKE2B 45fc07e14f0b89106464b925e68fc3b9b8ea23c14e5091150ed45c7a3a7bf84e310d0cc2437b021f4a83c4d162200b44c5deb23c1a40740dba4379dd682ad964 SHA512 8ba6d7898f5346a6e64ac1cbf17f914c44835f603c9d5952e226063c2d7d3ad64597e41a8a0bbfa4dd12966ddbf53722bc4c28d3ee0e5c860073e08f56fa2805
+AUX menumaker-0.99.11-AM_PATH_PYTHON.patch 2579 BLAKE2B 67b3924544429c998229b439cdaac12aaf6e24aeaf647fd604a9602a25d24250a59c398d7c403744445adf81cf0dc4dcaeb88a07edb0f6181104e0e81aae175d SHA512 f36c5d30981c2e39b37a626eb235f7e9117de18bd774e91058350cceb9859ed9f99a11233f9a72a8acff7a7f84bf657a25e86935623a65986d63ce86734b3c3b
DIST menumaker-0.99.10.tar.gz 202580 BLAKE2B 2fb53359a6e4b14fe8966c3fbb6d0f381a3ad9e52463d37edbef47a409b0ecf4f17bd7221395987d4cd49f363007aa97f0d6182595a571f1baab4e7977c06bff SHA512 e7a731ac848089cbdb845fdb0e344b48e70d3bb7220870127d3616549d31fa62b61a48e3efff52d7767b597a4407a8548e776c16976072d0aa7f5c96740cd207
+DIST menumaker-0.99.11.tar.gz 205196 BLAKE2B 5f1fa9cbf4fd739499db86f9173fbbea2c96900597d13185f2a2f2b5746a0a2c05d12b115782488cb5b1df1f48638bb831dbee4bb14c414fc11328f43d241c46 SHA512 b45b8f2de4e63bad673bf4463ac074b068d4889cf37644962d51e1514d07bef827679d060d1503e59ea4bfc460fdc643d850921b3a02babd1ea57249511ffa5a
EBUILD menumaker-0.99.10.ebuild 1114 BLAKE2B 98ea44a42dc7599ba5790c8d2ae2968a14b88455fc0f88b60a7a089108bb29c33074cc1c81250f932dbfe44b295b64896e28a3f8e1fc6b833180011832823dae SHA512 b8d07d4b5e886b07231c66ea5deae6e56c3ebf431a6900b39c0a6f87ab93cedb3e4596c10aa3eb1ae6c8e094ef521e9b528bbff41d2df545387b4c36827c29c1
+EBUILD menumaker-0.99.11.ebuild 1105 BLAKE2B d74a2093d783ed3c1a0dc19e597329252777ad87d615f6de04de4f405553afa2ac5acee2c7e00e6c0e53c8cf5c52d5a74648e5ebc061acdd2b39479aee660c35 SHA512 233629568bc5d4e1978dd3b5c1334089b2486c4632530e4168d23c0aa8c9f11531d0a3bf64ac8c7852d1ab9b2879a041975333bd222e5390141080409bf68fd5
MISC metadata.xml 439 BLAKE2B cee25e15ca49508e651ba46d0598ee61f0c959bdf46a28337ab0d6071683e6779e8e0d50e36d9aa84ef761f251773ea101eae4dbf1a3b7494d08d2f8778f90e4 SHA512 5f68ee720bbfc364f200335a1045982b4c82aab73e24a8e5143d8a776919b6b676088c5af49ea74cdb09d09cf1f055b596471915f173ab6afbb17bc553a6b07c
diff --git a/x11-misc/menumaker/files/menumaker-0.99.11-AM_PATH_PYTHON.patch b/x11-misc/menumaker/files/menumaker-0.99.11-AM_PATH_PYTHON.patch
new file mode 100644
index 000000000000..73cf9b6ff80f
--- /dev/null
+++ b/x11-misc/menumaker/files/menumaker-0.99.11-AM_PATH_PYTHON.patch
@@ -0,0 +1,100 @@
+diff --git a/Makefile.am b/Makefile.am
+index b00b7bc..1c6f12b 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,15 +1,53 @@
+-ACLOCAL_AMFLAGS = -I m4
+-
+ SUBDIRS = doc
+
+ dist_bin_SCRIPTS = mmaker
+
+-nobase_dist_pkgdata_DATA = *.py MenuMaker/*.py Prophet/*.py Prophet/Desktop/*.py Prophet/Legacy/*.py Prophet/Debian/*.py Prophet/Debian/menu/*
++python_PYTHON = \
++ Config.py \
++ Keywords.py \
++ Paths.py
++
++pythonMenuMakerdir = $(pythondir)/MenuMaker
++pythonMenuMaker_PYTHON = \
++ MenuMaker/BlackBox.py \
++ MenuMaker/CLI.py \
++ MenuMaker/Deskmenu.py \
++ MenuMaker/FluxBox.py \
++ MenuMaker/IceWM.py \
++ MenuMaker/__init__.py \
++ MenuMaker/OpenBox3.py \
++ MenuMaker/PekWM.py \
++ MenuMaker/WindowMaker.py \
++ MenuMaker/xBox.py \
++ MenuMaker/Xfce4.py
++
++pythonProphetdir = $(pythondir)/Prophet
++pythonProphet_PYTHON = \
++ Prophet/Categories.py \
++ Prophet/__init__.py
++
++pythonProphetDesktopdir = $(pythondir)/Prophet/Desktop
++pythonProphetDesktop_PYTHON = \
++ Prophet/Desktop/__init__.py
++
++pythonProphetLegacydir = $(pythondir)/Prophet/Legacy
++pythonProphetLegacy_PYTHON = \
++ Prophet/Legacy/Development.py \
++ Prophet/Legacy/Editor.py \
++ Prophet/Legacy/Emulator.py \
++ Prophet/Legacy/Graphics.py \
++ Prophet/Legacy/__init__.py \
++ Prophet/Legacy/Multimedia.py \
++ Prophet/Legacy/Network.py \
++ Prophet/Legacy/Shell.py
+
+-install-exec-local :
+- echo "#!/usr/bin/env $(PYTHON_BIN)" > $(DESTDIR)/$(bindir)/mmaker
+- echo "import sys; sys.path = ['$(pkgdatadir)'] + sys.path" >> $(DESTDIR)/$(bindir)/mmaker
+- echo "import MenuMaker.CLI" >> $(DESTDIR)/$(bindir)/mmaker
++pythonProphetDebiandir = $(pythondir)/Prophet/Debian
++pythonProphetDebian_PYTHON = \
++ Prophet/Debian/__init__.py
+
+-install-data-local :
+- $(PYTHON) -c 'import compileall; compileall.compile_dir(dir="$(DESTDIR)/$(pkgdatadir)", ddir="$(pkgdatadir)")'
++pythonProphetDebianMenudir = $(pythondir)/Prophet/Debian/menu
++dist_pythonProphetDebianMenu_DATA = \
++ Prophet/Debian/menu/debian-2.2r5 \
++ Prophet/Debian/menu/debian-8.1 \
++ Prophet/Debian/menu/ubuntu-5.04 \
++ Prophet/Debian/menu/ubuntu-5.10
+diff --git a/configure.ac b/configure.ac
+index 248ffcb..1bde23b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2,22 +2,12 @@ AC_INIT(MenuMaker, 0.99.11)
+
+ AM_INIT_AUTOMAKE
+
+-#AZ_PYTHON_DEFAULT
++AM_PATH_PYTHON
+
+-#AZ_PYTHON_WITH
+-
+-#if test -z "$PYTHON"; then
+-# AZ_PYTHON_PATH
+-#fi
+-
+-#AZ_PYTHON_VERSION_ENSURE([2.7])
+-
+-#AZ_PYTHON_RUN
+-
+-AX_PYTHON
+-
+-AC_CONFIG_FILES([Makefile])
+-AC_CONFIG_FILES([doc/Makefile])
+-AC_CONFIG_FILES([Config.py])
++AC_CONFIG_FILES([
++ Makefile
++ doc/Makefile
++ Config.py
++])
+
+ AC_OUTPUT
diff --git a/x11-misc/menumaker/menumaker-0.99.11.ebuild b/x11-misc/menumaker/menumaker-0.99.11.ebuild
new file mode 100644
index 000000000000..ab1ac978b110
--- /dev/null
+++ b/x11-misc/menumaker/menumaker-0.99.11.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit autotools python-r1
+
+DESCRIPTION="Utility that scans through the system and generates a menu of installed programs"
+HOMEPAGE="http://menumaker.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+IUSE="doc"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ doc? ( sys-apps/texinfo )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-AM_PATH_PYTHON.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ configure() {
+ ECONF_SOURCE="${S}" econf PYTHON="${EPYTHON}"
+ }
+ python_foreach_impl run_in_build_dir configure
+}
+
+src_compile() {
+ compile() {
+ default
+ use doc && emake html
+ }
+ python_foreach_impl run_in_build_dir compile
+}
+
+src_install() {
+ compile() {
+ default
+ use doc && emake DESTDIR="${D}" install-html
+ }
+ python_foreach_impl run_in_build_dir compile
+ python_replicate_script "${ED}"/usr/bin/mmaker
+ einstalldocs
+}