summaryrefslogtreecommitdiff
path: root/x11-misc/idesk
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/idesk')
-rw-r--r--x11-misc/idesk/Manifest2
-rw-r--r--x11-misc/idesk/files/idesk-1-use-pkg-config-imlib2.patch38
-rw-r--r--x11-misc/idesk/idesk-1-r1.ebuild48
3 files changed, 88 insertions, 0 deletions
diff --git a/x11-misc/idesk/Manifest b/x11-misc/idesk/Manifest
index 44dd3c5ad711..7a1bcc9e0f98 100644
--- a/x11-misc/idesk/Manifest
+++ b/x11-misc/idesk/Manifest
@@ -1,3 +1,5 @@
+AUX idesk-1-use-pkg-config-imlib2.patch 1054 BLAKE2B c126a0f13b2cc398b431cdf1dc94da4c00ace1bcbda167498d0ff4144c883c94867a7601fd16c48ae272464fa4f9761350d83c24b0bf2ad58c149673c6a2dd38 SHA512 a6e1b6b68a160df2427eaaf0b6704564a63d569b69face75478535e09fcb2d119af38ca437ccdf50619ea75834b39155b9d0f3215a688033a15feee350d2a540
DIST idesk-v1.tar.gz 195147 BLAKE2B 2b2b0dacbfb1d8fb950c88d990e3674bf8b4cf82d9022ed2f7be1f32082c46ae32d8200957e2e19d0d21ea1e4d59ec092f4cba90e712f79700a04f05c3a3aa14 SHA512 3190fca7a5c9fb36b66159107d22b5f6e50b4573afa21a3a4d8b8e3e5953dabda077c924e45d2607b849ee5fea141eb80f5b89ce5288ebc2490679f319edf768
+EBUILD idesk-1-r1.ebuild 910 BLAKE2B f0b258bac8b21cfeac384fe59a9822f67606dc7e6bdfb39ed6778cba47d3e5e1e4f9f25dddc235adeaee98c841e174a2ea2075a53abf79cb27566ee8a7a15b1c SHA512 e3fd15e4959d67504ca6a6b95b64171493e473d2f558c30f8ed77ac83b95fac51a4ec1ed333d66b8edde0150548287082a669db45b7d5c0ce7f537b1a5ce4b85
EBUILD idesk-1.ebuild 792 BLAKE2B dc2ac6e6aa9e7044aff7c0e941e3f93ff92cd53a874f997a89cfc27763d4e16d4dee3b042cff9e0ec0ffbd4832a5d7f0278c6a27eb1b1ec3253c5c6f2f6008ee SHA512 ecfd30726a6f93f5428d1d240cb4651ad1becd9f9a76824c357bd39696bbec3590ed578da7323f6317d6add56d071090872bee8612536159f23851b26c051852
MISC metadata.xml 256 BLAKE2B 9cc198243be9a95645c1e88dd2838b1f70afe3cdb08cae721e59b4942a5b4b561a5bbc129baaaa52c023fde708be5629e47230eb335084c9e24bd0ff8764a7d5 SHA512 878114abde4788d790a6b61c20cad1421f652c383fcd57b63926c6bc7c906ccd22e461c50d9e2459d06077e80d29215b17f9d35fbb18db9a2e794093e8db9de7
diff --git a/x11-misc/idesk/files/idesk-1-use-pkg-config-imlib2.patch b/x11-misc/idesk/files/idesk-1-use-pkg-config-imlib2.patch
new file mode 100644
index 000000000000..36e088972543
--- /dev/null
+++ b/x11-misc/idesk/files/idesk-1-use-pkg-config-imlib2.patch
@@ -0,0 +1,38 @@
+https://github.com/antonialoytorrens/idesk/pull/1
+
+From b13626bbe2669b8a267ad53df93f1060379a462e Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Fri, 15 Jul 2022 08:22:12 +0100
+Subject: [PATCH] build: use pkg-config to find imlib2
+
+imlib2 1.7.5+ drops imlib2-config, hence pkg-config
+must now be used to find it.
+
+Bug: https://bugs.gentoo.org/828962
+--- a/configure.in
++++ b/configure.in
+@@ -94,19 +94,10 @@ LIBS="$LIBS $Xext_lib"
+
+ dnl Imlib2 detection
+
+-AC_PATH_GENERIC(imlib2, , [
+- AC_SUBST(IMLIB_LIBS)
+- AC_SUBST(IMLIB_CXXFLAGS) ],
+- AC_MSG_ERROR(Cannot find imlib2: Is imlib2-config in the path?
+- You need Imlib2 to build Idesk. Verify that you have Imlib2-dev))
+-
+-dnl the above doesn't work for some reason :/
+-IMLIB_LIBS=`imlib2-config --libs`
+-IMLIB_CFLAGS=`imlib2-config --cflags`
+-AC_SUBST(IMLIB_LIBS)
+-AC_SUBST(IMLIB_CXXFLAGS)
+-
+-CXXFLAGS="$CXXFLAGS $IMLIB_CXXFLAGS"
++PKG_PROG_PKG_CONFIG
++PKG_CHECK_MODULES([IMLIB], [imlib2 > 1.0])
++
++CXXFLAGS="$CXXFLAGS $IMLIB_CFLAGS"
+ LIBS="$LIBS $IMLIB_LIBS"
+
+
+
diff --git a/x11-misc/idesk/idesk-1-r1.ebuild b/x11-misc/idesk/idesk-1-r1.ebuild
new file mode 100644
index 000000000000..6b94e84161c4
--- /dev/null
+++ b/x11-misc/idesk/idesk-1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${PN}-v${PV}"
+
+inherit autotools
+
+DESCRIPTION="Utility to place icons on the root window"
+HOMEPAGE="https://github.com/antonialoytorrens/idesk/"
+SRC_URI="https://github.com/antonialoytorrens/idesk/releases/download/v1/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="
+ dev-libs/glib
+ dev-libs/libxml2
+ media-libs/freetype
+ media-libs/imlib2[X]
+ media-libs/libart_lgpl
+ x11-libs/libXft
+ x11-libs/gtk+:3
+ x11-libs/pango
+ x11-libs/startup-notification
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1-use-pkg-config-imlib2.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's,/usr/local/,/usr/,' examples/default.lnk || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-libsn
+}