summaryrefslogtreecommitdiff
path: root/www-client/firefox/firefox-68.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-68.1.0.ebuild')
-rw-r--r--www-client/firefox/firefox-68.1.0.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/www-client/firefox/firefox-68.1.0.ebuild b/www-client/firefox/firefox-68.1.0.ebuild
index c11aaade6576..ac1e779e823d 100644
--- a/www-client/firefox/firefox-68.1.0.ebuild
+++ b/www-client/firefox/firefox-68.1.0.ebuild
@@ -27,7 +27,7 @@ if [[ ${MOZ_ESR} == 1 ]] ; then
fi
# Patch version
-PATCH="${PN}-68.0-patches-11"
+PATCH="${PN}-68.0-patches-12"
MOZ_HTTP_URI="https://archive.mozilla.org/pub/${PN}/releases"
MOZ_SRC_URI="${MOZ_HTTP_URI}/${MOZ_PV}/source/firefox-${MOZ_PV}.source.tar.xz"
@@ -42,7 +42,7 @@ LLVM_MAX_SLOT=9
inherit check-reqs eapi7-ver flag-o-matic toolchain-funcs eutils \
gnome2-utils llvm mozcoreconf-v6 pax-utils xdg-utils \
- autotools mozlinguas-v2 virtualx
+ autotools mozlinguas-v2 virtualx multiprocessing
DESCRIPTION="Firefox Web Browser"
HOMEPAGE="https://www.mozilla.com/firefox"
@@ -163,7 +163,6 @@ DEPEND="${CDEPEND}
)
)
pulseaudio? ( media-sound/pulseaudio )
- >=virtual/cargo-1.34.0
>=virtual/rust-1.34.0
wayland? ( >=x11-libs/gtk+-3.11:3[wayland] )
amd64? ( >=dev-lang/yasm-1.1 virtual/opengl )
@@ -244,7 +243,7 @@ pkg_setup() {
pkg_pretend() {
# Ensure we have enough disk space to compile
- if use pgo || use debug || use test ; then
+ if use pgo || use lto || use debug || use test ; then
CHECKREQS_DISK_BUILD="8G"
else
CHECKREQS_DISK_BUILD="4G"
@@ -267,6 +266,12 @@ src_prepare() {
# Allow user to apply any additional patches without modifing ebuild
eapply_user
+ local n_jobs=$(makeopts_jobs)
+ if [[ ${n_jobs} == 1 ]]; then
+ einfo "Building with MAKEOPTS=-j1 is known to fail (bug #687028); Forcing MAKEOPTS=-j2 ..."
+ export MAKEOPTS=-j2
+ fi
+
# Enable gnomebreakpad
if use debug ; then
sed -i -e "s:GNOME_DISABLE_CRASH_DIALOG=1:GNOME_DISABLE_CRASH_DIALOG=0:g" \
@@ -553,9 +558,6 @@ src_configure() {
mozconfig_annotate '' --enable-extensions="${MEXTENSIONS}"
- # disable webrtc for now, bug 667642
- use arm && mozconfig_annotate 'broken on arm' --disable-webrtc
-
# allow elfhack to work in combination with unstripped binaries
# when they would normally be larger than 2GiB.
append-ldflags "-Wl,--compress-debug-sections=zlib"