summaryrefslogtreecommitdiff
path: root/www-client/firefox/firefox-60.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-60.9.0.ebuild')
-rw-r--r--www-client/firefox/firefox-60.9.0.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/www-client/firefox/firefox-60.9.0.ebuild b/www-client/firefox/firefox-60.9.0.ebuild
index 15b95565ee84..92a177f882da 100644
--- a/www-client/firefox/firefox-60.9.0.ebuild
+++ b/www-client/firefox/firefox-60.9.0.ebuild
@@ -37,7 +37,8 @@ MOZCONFIG_OPTIONAL_WIFI=1
LLVM_MAX_SLOT=9
inherit check-reqs flag-o-matic toolchain-funcs eutils gnome2-utils llvm \
- mozconfig-v6.60 pax-utils xdg-utils autotools mozlinguas-v2
+ mozconfig-v6.60 pax-utils xdg-utils autotools mozlinguas-v2 \
+ multiprocessing
DESCRIPTION="Firefox Web Browser"
HOMEPAGE="https://www.mozilla.com/firefox"
@@ -139,6 +140,7 @@ src_unpack() {
src_prepare() {
eapply "${WORKDIR}/firefox"
+ eapply "${FILESDIR}"/firefox-60.9.0-rust-1.38-compat.patch
# Enable gnomebreakpad
if use debug ; then
@@ -184,6 +186,12 @@ src_prepare() {
# Allow user to apply any additional patches without modifing ebuild
eapply_user
+ local n_jobs=$(makeopts_jobs)
+ if [[ ${n_jobs} == 1 ]]; then
+ einfo "Building with MAKEOPTS=-j1 is known to fail (bug #687028); Forcing MAKEOPTS=-j2 ..."
+ export MAKEOPTS=-j2
+ fi
+
# Autotools configure is now called old-configure.in
# This works because there is still a configure.in that happens to be for the
# shell wrapper configure script