summaryrefslogtreecommitdiff
path: root/sys-cluster/rdma-core/rdma-core-26.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/rdma-core/rdma-core-26.1.ebuild')
-rw-r--r--sys-cluster/rdma-core/rdma-core-26.1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-cluster/rdma-core/rdma-core-26.1.ebuild b/sys-cluster/rdma-core/rdma-core-26.1.ebuild
index e879e9b2b999..39537f768f10 100644
--- a/sys-cluster/rdma-core/rdma-core-26.1.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-26.1.ebuild
@@ -31,7 +31,11 @@ COMMON_DEPEND="
python? ( ${PYTHON_DEPS} )"
DEPEND="${COMMON_DEPEND}
- python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+ python? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
RDEPEND="${COMMON_DEPEND}
!sys-fabric/infiniband-diags
@@ -92,4 +96,6 @@ src_install() {
newinitd "${FILESDIR}"/ibacm.init ibacm
newinitd "${FILESDIR}"/iwpmd.init iwpmd
newinitd "${FILESDIR}"/srpd.init srpd
+
+ use python && python_optimize
}