summaryrefslogtreecommitdiff
path: root/sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild')
-rw-r--r--sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild b/sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild
new file mode 100644
index 000000000000..93907e006325
--- /dev/null
+++ b/sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit toolchain-funcs pam flag-o-matic eutils
+
+DESCRIPTION="Linux-PAM module that allows a user to be chrooted in auth, account, or session"
+HOMEPAGE="https://sourceforge.net/projects/pam-chroot/"
+SRC_URI="mirror://sourceforge/pam-chroot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/pam
+ !<sys-libs/pam-0.99"
+RDEPEND="${DEPEND}"
+
+doecho() {
+ echo "$@"
+ "$@" || die
+}
+
+src_compile() {
+ # using the Makefile would require patching it to work properly, so
+ # rather simply re-create it here.
+ doecho $(tc-getCC) ${LDFLAGS} -shared -fPIC ${CFLAGS} ${PN}.c -o ${PN}.so -lpam
+}
+
+src_install() {
+ dopammod pam_chroot.so
+ dopamsecurity . chroot.conf
+
+ dodoc CREDITS README.history TROUBLESHOOTING options || die "dodoc failed"
+}