summaryrefslogtreecommitdiff
path: root/sci-mathematics/cvc4
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/cvc4')
-rw-r--r--sci-mathematics/cvc4/Manifest2
-rw-r--r--sci-mathematics/cvc4/cvc4-1.7-r1.ebuild19
2 files changed, 10 insertions, 11 deletions
diff --git a/sci-mathematics/cvc4/Manifest b/sci-mathematics/cvc4/Manifest
index 7c431b2fdb63..49486bb48265 100644
--- a/sci-mathematics/cvc4/Manifest
+++ b/sci-mathematics/cvc4/Manifest
@@ -1,4 +1,4 @@
AUX cvc4-1.7-gentoo.patch 1665 BLAKE2B db98e67fb3b152e0c78019b21b32c99d06377f1b1c1cc6a3ac2edea5e27d6f8ba082fc209c3694e1144a94d9d3b1897418af250252ff40a26e521bbf72d7da0f SHA512 b6b7af8c48c0398375343c8fa72f3e15d8f9031848cf94e6e2880f04b5e8d695691dcf67b84daa1706464289f7db0300046af4c93adcf278f7951eccc734af89
DIST cvc4-1.7.tar.gz 6969953 BLAKE2B 3a64db14a734e0314fb7d7b8dbed79e067c9bbf1723343dac1e9c47b3f09811b1a32ff0116412667bd0afefda2489c6c1679bf109710402a67bee0d91b62dd94 SHA512 b91dfac7ddf979a3474f562eb98f2d6f17a53efa38c1be5502429309a0c059e1f2b0d85ee95e5aee17d35f34c825f01f879ec4aaf26025b1fcac835c33a867c6
-EBUILD cvc4-1.7-r1.ebuild 1416 BLAKE2B a5eea60a34ee3f52b1328631a805d54e88a1b112e1fca5c03ede60b2a1bc75f12193df482a72d3ce3aa059aaa78f0c32d7406310aeaea59e6300a56f4aee1c6f SHA512 a1f43f58c979a7d302f41075dada1fe313a4862c4fd9c01c4b634fea9946d3dde5fbc126fc895e9752dfb3886908795f0945e395a05524810bde9fdd37ef7b7a
+EBUILD cvc4-1.7-r1.ebuild 1379 BLAKE2B c806041f0941649a8108f6148ad2226647721a9396e5d8d889649e3185ba229aaa405ab1a22409aa4d1b7a21142213646df734e24bcec26b5899bbd114d92aff SHA512 d4ad9b8b61f48feb744d3ea5f6964112e63e9beba1f156b997bcde57a2aed295a54e3e93444d9570d997979a81b3fd74cae5f4fd335df201b504ba2ab9b67469
MISC metadata.xml 801 BLAKE2B a8dffba2bb9a740412d4193911d1ab118336993d12d6d7e42c758af438d297baf6798e2ce9c6aa9be4282678e366087d54b8d3f8c46b43be6d73bcf421ee318a SHA512 d90e35c93e5defc5599f5e9d9b88a757a4a845574684270f1aab0cb8194c50b31fa3135ea221f63d0d71f867619c039f32cfb46b63fa370289e8eb5205d3b25d
diff --git a/sci-mathematics/cvc4/cvc4-1.7-r1.ebuild b/sci-mathematics/cvc4/cvc4-1.7-r1.ebuild
index e50bae6113f6..36e9f4689a67 100644
--- a/sci-mathematics/cvc4/cvc4-1.7-r1.ebuild
+++ b/sci-mathematics/cvc4/cvc4-1.7-r1.ebuild
@@ -3,12 +3,12 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+CMAKE_MAKEFILE_GENERATOR=emake
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit cmake python-any-r1
-inherit python-any-r1 cmake-utils
-
-DESCRIPTION="automatic theorem prover for satisfiability modulo theories (SMT) problems"
-HOMEPAGE="http://cvc4.cs.stanford.edu/web/"
+DESCRIPTION="Automatic theorem prover for satisfiability modulo theories (SMT) problems"
+HOMEPAGE="https://cvc4.github.io/"
SRC_URI="https://github.com/CVC4/CVC4/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
@@ -25,12 +25,11 @@ RDEPEND="dev-libs/antlr-c
DEPEND="${RDEPEND}"
BDEPEND="${PYTHON_DEPS}"
-S="${WORKDIR}"/CVC4-${PV}
+S="${WORKDIR}"/${P^^}
PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
src_configure() {
- CMAKE_MAKEFILE_GENERATOR=emake
local mycmakeargs=(
-DANTLR_BINARY=/usr/bin/antlr3
-DENABLE_GPL=ON
@@ -41,7 +40,7 @@ src_configure() {
-DENABLE_PROOFS="$(usex proofs ON OFF)"
-DENABLE_REPLAY="$(usex replay ON OFF)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
@@ -54,10 +53,10 @@ src_test() {
smt2_compliance \
two_smt_engines \
statistics
- cmake-utils_src_test
+ cmake_src_test
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
mv "${D}"/usr/{lib,$(get_libdir)}
}