summaryrefslogtreecommitdiff
path: root/sci-libs/ginkgo/ginkgo-1.4.0-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/ginkgo/ginkgo-1.4.0-r3.ebuild')
-rw-r--r--sci-libs/ginkgo/ginkgo-1.4.0-r3.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/sci-libs/ginkgo/ginkgo-1.4.0-r3.ebuild b/sci-libs/ginkgo/ginkgo-1.4.0-r3.ebuild
index abd270c911c4..0a4e3d5aea71 100644
--- a/sci-libs/ginkgo/ginkgo-1.4.0-r3.ebuild
+++ b/sci-libs/ginkgo/ginkgo-1.4.0-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake toolchain-funcs
+inherit cmake flag-o-matic toolchain-funcs
DESCRIPTION="Numerical linear algebra software package"
HOMEPAGE="https://ginkgo-project.github.io/"
@@ -34,16 +34,15 @@ pkg_setup() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
-src_prepare() {
- sed -i \
- -e "s#\"lib\"#\"$(get_libdir)\"#g" \
- -e "s#\"lib/#\"$(get_libdir)/#g" \
- cmake/install_helpers.cmake || die "sed failed"
-
- cmake_src_prepare
-}
-
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/862705
+ # https://github.com/ginkgo-project/ginkgo/issues/1657
+ #
+ # Do not trust it with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local mycmakeargs=(
-DGINKGO_DEVEL_TOOLS=OFF
-DGINKGO_BUILD_TESTS=OFF