summaryrefslogtreecommitdiff
path: root/net-p2p/go-ethereum
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/go-ethereum')
-rw-r--r--net-p2p/go-ethereum/Manifest6
-rw-r--r--net-p2p/go-ethereum/go-ethereum-1.7.2.ebuild (renamed from net-p2p/go-ethereum/go-ethereum-1.5.5.ebuild)16
-rw-r--r--net-p2p/go-ethereum/metadata.xml2
3 files changed, 16 insertions, 8 deletions
diff --git a/net-p2p/go-ethereum/Manifest b/net-p2p/go-ethereum/Manifest
index e5a3ca6c49b1..607e6d45c2c3 100644
--- a/net-p2p/go-ethereum/Manifest
+++ b/net-p2p/go-ethereum/Manifest
@@ -1,3 +1,3 @@
-DIST go-ethereum-1.5.5.tar.gz 14957844 BLAKE2B fcea479dd0ab9ffd8c0ff80b55913bc543d7827edf43c2f3a3d9f262433edf4a792e0229df8f744e8436d4d93e0161d1fa60125c09a7eeacba90b556a481830b SHA512 4429d0aaceb0e6ffa92f85674ad50ddb092436b97fabb4ff09439c408a762155ae7077b0a69432cf4a2397aea2ff3c4d603713ea1cd304a831b8aa9c039314ea
-EBUILD go-ethereum-1.5.5.ebuild 646 BLAKE2B dcdf0a0052db6b70963fc61993b047df04f972294e36464da53e980a14bc8f68777408ed74a4143192029f4180370c502fd601078b977d51f9a9110f96193a3a SHA512 25298e5b286b87a9a4a040127d33bbb6fccef76d30c9fd3f7fe380bfc560667f112eceda726e42491aa7d9a0210ce07fefd4efa79ab9e87afb78183c88cc9359
-MISC metadata.xml 590 BLAKE2B 39a8d8d46e5636a853f376387220545fb2c51c92d9ac6c08701ff13fc47bab003da7a79f8e87628e4e68c950595d8727cb7799ff35bf76f90ca82aa4fa58ab7d SHA512 6a946177d4a8a65e5fca879cc48cd432661f069c1e1ac405655721ad69a88dd8749b64f2bf0ca8d899120a6d49ba57a1c933987640bf8c08634cdd59ba496fa5
+DIST go-ethereum-1.7.2.tar.gz 7037907 BLAKE2B eb1e358e42c743a931995e7ee46dc2441356159fc9095e8a886cc6a0495cb2d2e77ee7df4c6dd98bc790397819fc43cdedba6cf28de1e4f3dcdc4dd71106f8e5 SHA512 7bc5957f1523fa5ec67650c4305633aa4c6098a243ef415f9ef56a4e4763eb2ef9f69514ed15810fcdb75f11e87cbd27c4f2af802c32a03be91b37a7b08ea520
+EBUILD go-ethereum-1.7.2.ebuild 844 BLAKE2B 1b3b946a7bbdad1b891caecbd679ae4136e7ab78a2dcdc79b9922a27d47e6afb421d58f4eae3db1f94e3c7c309503c08a8cc6bacdcd1efcaf05f7777a3be5ffe SHA512 1c62060bbbfd023a6b058192edb08f5b20be10e8727ff322b1c98f4abb2c1ca6cb9f240a5667e5674beee44193d5b011f11e0edffe895b7ed763a2561bca13e4
+MISC metadata.xml 619 BLAKE2B c425c01f78c66b3c6b0bb4109cad466a9fd5a53ff982aa01c19609836a309e2ebea40c14a5cf850b32f2e3c8f632fca667c864af6e64bfe1738548442464e3bc SHA512 4cd641e4ac75451298d45e0fc37f93b5527d2aa567f1350cd48c02f7a0fd203f4c394e089fddb14ffb1365de98dd31b813ce7c268096054e01e1efbab1310419
diff --git a/net-p2p/go-ethereum/go-ethereum-1.5.5.ebuild b/net-p2p/go-ethereum/go-ethereum-1.7.2.ebuild
index 2310def0f5ef..04e769b1b60b 100644
--- a/net-p2p/go-ethereum/go-ethereum-1.5.5.ebuild
+++ b/net-p2p/go-ethereum/go-ethereum-1.7.2.ebuild
@@ -10,7 +10,7 @@ SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3+ LGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="evm opencl"
+IUSE="devtools opencl"
DEPEND="dev-lang/go:=
opencl? ( virtual/opencl )
@@ -20,13 +20,21 @@ RDEPEND="${DEPEND}"
src_compile() {
use opencl && export GO_OPENCL=true
- emake geth
- use evm && emake evm
+ emake $(usex devtools all geth)
}
src_install() {
einstalldocs
dobin build/bin/geth
- use evm && dobin build/bin/evm
+ if use devtools; then
+ dobin build/bin/abigen
+ dobin build/bin/bootnode
+ dobin build/bin/evm
+ dobin build/bin/p2psim
+ dobin build/bin/puppeth
+ dobin build/bin/rlpdump
+ dobin build/bin/swarm
+ dobin build/bin/wnode
+ fi
}
diff --git a/net-p2p/go-ethereum/metadata.xml b/net-p2p/go-ethereum/metadata.xml
index 3056bf45f275..03018cfb75ac 100644
--- a/net-p2p/go-ethereum/metadata.xml
+++ b/net-p2p/go-ethereum/metadata.xml
@@ -10,7 +10,7 @@
<name>Proxy Maintainers</name>
</maintainer>
<use>
- <flag name="evm">Build Ethereum Virtual Machine (EVM)</flag>
+ <flag name="devtools">Build Ethereum development tools (evm, abigen, puppeth, ...)</flag>
<flag name="opencl">Add OpenCL GPU mining support</flag>
</use>
<upstream>