summaryrefslogtreecommitdiff
path: root/net-im/yowsup/yowsup-2.5.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/yowsup/yowsup-2.5.7.ebuild')
-rw-r--r--net-im/yowsup/yowsup-2.5.7.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-im/yowsup/yowsup-2.5.7.ebuild b/net-im/yowsup/yowsup-2.5.7.ebuild
new file mode 100644
index 000000000000..862206fd28dd
--- /dev/null
+++ b/net-im/yowsup/yowsup-2.5.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="readline"
+
+inherit distutils-r1
+
+DESCRIPTION="A library that enables you to build applications which use the WhatsApp service"
+HOMEPAGE="https://github.com/tgalal/yowsup"
+SRC_URI="https://github.com/tgalal/yowsup/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/configargparse[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ dev-python/python-axolotl-curve25519[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/fix_newer_six_version.patch" )