summaryrefslogtreecommitdiff
path: root/media-tv/kodi/kodi-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-tv/kodi/kodi-9999.ebuild')
-rw-r--r--media-tv/kodi/kodi-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/media-tv/kodi/kodi-9999.ebuild b/media-tv/kodi/kodi-9999.ebuild
index 44cd4f61e398..3b98edc8e7e6 100644
--- a/media-tv/kodi/kodi-9999.ebuild
+++ b/media-tv/kodi/kodi-9999.ebuild
@@ -28,7 +28,7 @@ SLOT="0"
# use flag is called libusb so that it doesn't fool people in thinking that
# it is _required_ for USB support. Otherwise they'll disable udev and
# that's going to be worse.
-IUSE="airplay alsa bluetooth bluray caps cec +css dbus debug dvd gbm gles lcms libressl libusb lirc mysql nfs +opengl pulseaudio samba systemd +system-ffmpeg test +udev udisks upnp upower vaapi vdpau wayland webserver +X +xslt zeroconf"
+IUSE="airplay alsa bluetooth bluray caps cec +css dbus debug dvd gbm gles lcms libressl libusb lirc mariadb mysql nfs +opengl pulseaudio samba systemd +system-ffmpeg test +udev udisks upnp upower vaapi vdpau wayland webserver +X +xslt zeroconf"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
|| ( gles opengl )
@@ -77,7 +77,10 @@ COMMON_DEPEND="${PYTHON_DEPS}
libressl? ( media-video/ffmpeg[libressl,-openssl] )
!libressl? ( media-video/ffmpeg[-libressl,openssl] )
)
- mysql? ( virtual/mysql )
+ mysql? (
+ !mariadb? ( dev-db/mysql-connector-c:= )
+ mariadb? ( dev-db/mariadb-connector-c:= )
+ )
>=net-misc/curl-7.56.1
nfs? ( >=net-fs/libnfs-2.0.0:= )
opengl? ( media-libs/glu )