summaryrefslogtreecommitdiff
path: root/media-libs/oneVPL
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/oneVPL')
-rw-r--r--media-libs/oneVPL/Manifest3
-rw-r--r--media-libs/oneVPL/metadata.xml19
-rw-r--r--media-libs/oneVPL/oneVPL-2022.2.5.ebuild79
3 files changed, 101 insertions, 0 deletions
diff --git a/media-libs/oneVPL/Manifest b/media-libs/oneVPL/Manifest
new file mode 100644
index 000000000000..cd01742ca98d
--- /dev/null
+++ b/media-libs/oneVPL/Manifest
@@ -0,0 +1,3 @@
+DIST oneVPL-2022.2.5.tar.gz 6517210 BLAKE2B 1da487e9a4fbaa171f14213d0828c7dbed91d1f92d9641f10d9ef8fc895b4d51b33f80485b16e41e2cb15cd8d771f5c5f84370268cb2c347dc8e19d90d91a759 SHA512 7d100a347a109720f37d86c6dd86c216a75e77b9f032f5c066835fb5a3c7c7312bca81ffd3a30836c59d20e10863567788a247b4daa57721b3ba011c4e0cd34d
+EBUILD oneVPL-2022.2.5.ebuild 2131 BLAKE2B 99803b725c8b0b69626062f78b1bad90f70264588962931b54fb1285ac4a39b4d14edbc9d3873dc171891cadb9ee3bf39fc3fa8f78d6c38501a68a2998aab280 SHA512 373c1a9b2f0649d0a6db77066ea72126ef7224373558245efdeec70925242d96ed21ad30b29c310459436b3aaed1c7b7ac6d256d549bcefefbcef84026f7f58c
+MISC metadata.xml 633 BLAKE2B b53305f7c1127190352b5ba25b43411455eba014b85a2305abe07571c2d95c6e1a60b1f1872895b94b7e6292178966c5b3733d7c8b5b9d1c16925f153d60e00d SHA512 a1dcf8c3fe13311bd81d48c3afd76de850b7fc395ae89e2f5973811525e56e69c12de2c83ce8e25971ab4330ed80ba4794051e5826c271f62b86116bc520d81a
diff --git a/media-libs/oneVPL/metadata.xml b/media-libs/oneVPL/metadata.xml
new file mode 100644
index 000000000000..a3315c4abeff
--- /dev/null
+++ b/media-libs/oneVPL/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">oneapi-src/oneVPL</remote-id>
+ </upstream>
+ <use>
+ <flag name="drm">Build with DRM support</flag>
+ <flag name="experimental">Build dispatcher with experimental APIs</flag>
+ <flag name="tools">Build decode/encode/analyse/inspect tools</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-libs/oneVPL/oneVPL-2022.2.5.ebuild b/media-libs/oneVPL/oneVPL-2022.2.5.ebuild
new file mode 100644
index 000000000000..c8862a2292bb
--- /dev/null
+++ b/media-libs/oneVPL/oneVPL-2022.2.5.ebuild
@@ -0,0 +1,79 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake optfeature
+
+DESCRIPTION="oneAPI Video Processing Library, dispatcher, tools, and examples"
+HOMEPAGE="https://github.com/oneapi-src/oneVPL"
+SRC_URI="https://github.com/oneapi-src/oneVPL/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="dri drm examples experimental +tools test vaapi wayland X"
+RESTRICT="!test? ( test )"
+# Most of these flags only have an effect on the tools
+REQUIRED_USE="
+ dri? ( X drm )
+ drm? ( tools )
+ X? ( tools )
+ wayland? ( tools )
+ vaapi? ( tools )
+"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+ x11-libs/libpciaccess
+ vaapi? ( media-libs/libva[X?,wayland?,drm(+)?] )
+ drm? ( x11-libs/libdrm )
+ wayland? (
+ dev-libs/wayland
+ dev-libs/wayland-protocols
+ )
+ X? (
+ x11-libs/libX11
+ x11-libs/libxcb
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_DISPATCHER=ON
+ # Headers, cmake and pkgconfig files
+ -DBUILD_DEV=ON
+ -DBUILD_EXAMPLES="$(usex examples)"
+ -DINSTALL_EXAMPLE_CODE="$(usex examples)"
+ -DBUILD_PREVIEW="$(usex experimental)"
+ -DBUILD_DISPATCHER_ONEVPL_EXPERIMENTAL="$(usex experimental)"
+ # Fails to build with experimental tools off if tools on
+ -DBUILD_TOOLS_ONEVPL_EXPERIMENTAL="$(usex tools)"
+ -DBUILD_TESTS="$(usex test)"
+ -DBUILD_TOOLS="$(usex tools)"
+ -DENABLE_WAYLAND="$(usex wayland)"
+ -DENABLE_X11="$(usex X)"
+ -DENABLE_DRI3="$(usex dri)"
+ -DENABLE_VA="$(usex vaapi)"
+ -DENABLE_DRM="$(usex drm)"
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ # Remove these license files
+ rm -r "${ED}/usr/share/vpl/licensing" || die
+}
+
+pkg_postinst() {
+ optfeature_header "This package provides only the dispatcher, to use it install one or more implementations"
+ optfeature "CPUs" media-libs/oneVPL-cpu
+ optfeature "Intel GPUs newer then, and including, Intel Xe" media-libs/oneVPL-intel-gpu
+ optfeature "Intel GPUs older then Intel Xe" media-libs/intel-mediasdk
+}