summaryrefslogtreecommitdiff
path: root/media-libs/imlib2
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/imlib2')
-rw-r--r--media-libs/imlib2/Manifest4
-rw-r--r--media-libs/imlib2/imlib2-1.6.1.ebuild78
-rw-r--r--media-libs/imlib2/metadata.xml91
3 files changed, 133 insertions, 40 deletions
diff --git a/media-libs/imlib2/Manifest b/media-libs/imlib2/Manifest
index 77a9162b88a3..68770383b3f3 100644
--- a/media-libs/imlib2/Manifest
+++ b/media-libs/imlib2/Manifest
@@ -1,3 +1,5 @@
DIST imlib2-1.5.1.tar.gz 1020701 BLAKE2B 33213a49293fba9e86cfec312d3cd8018c2284d60040b63899778d2fa65bffe173926eb14bc893c1a80e1472084a711423f77f6288779486512074e75d92acfd SHA512 9872aa3c4d45b1e9cbb0b1d0a7d5b47256e35f01a4fe19d84d276096c2da053c55bd28554441f92464d19edf1222b427571ba7b06d716031021ff1f9b4bc9656
+DIST imlib2-1.6.1.tar.gz 1038614 BLAKE2B 89751ea5548e86b810d621cbcd5b3d37c7ddbedc9e634095f61d91779c1e96d50f87842136687e2b9cefa249b17fc98df61d07b368c7c4f466687ed38f2ed70f SHA512 0c6d874973c46c7e96e49fc391d463ec8c7c5ce9de682600cb4e28ca81ff0366a02055cbec2a2b743204051243d20b2316ab602b98df9d03dcf319297f7e6a13
EBUILD imlib2-1.5.1-r1.ebuild 2148 BLAKE2B a3ab5d15b8a28cec83cfa0a465519a4708504372edbbc1ed95f15ad14f57e23223e06224bf71d09d594f4d69b3ab19ecc2c891f1c279147f63648e7798a14f02 SHA512 b27de2fbc1670425e36ce6ce858d9fcdf3b2e431201a9b295bc6a2f55d845bee99766bb7e5a4f91d063e676966a641b678471d89fc73261c415d3890adca769a
-MISC metadata.xml 2448 BLAKE2B ca27be2f23b000d1121343dfe8d21c93062ca12cf358860b30be062744e54df49a0ba108c991f090de5f84945189e02fa1e936df081e564c777a880421e36045 SHA512 659e2887be742527de8386577bbcb0c0544b1526089e67d5bf99745b0c63eb9634f6daa4b09d31bad81bae12ec9d7c227b687ebcec2c34d052e60b9e65bd05c3
+EBUILD imlib2-1.6.1.ebuild 2288 BLAKE2B fccd874d9c0173df5ae448439cffe6f564a21e8b9a0c6bf368a85e45afb62b042048eac5db3177577e625611608ec1ffb3c4eaa7ab027d4c2544811d939e9370 SHA512 bd9dbfc1cce343fe57d26449f3b94f0f453114ee317cfe12d6ce97bbb4460e2d31216a7caba6b063010d9544ae3f730212c1b3dc57de9be13393cabde87db01e
+MISC metadata.xml 3005 BLAKE2B 1b67eed4da7c73ed10d37bc2d5706c09e6457d1c8be4420758afe8906771f0cbba1f8ccb21a2bb5988d5271e794c0460019cba7c1241572443c8f6219db4f003 SHA512 dee85662dd1ef54784c0af882ff76581e3ce6f7d67ae6015801fcaa57e6e05b6ce2e67b408e1f66177a19e0519efc9ddc84b01c208e6f397129768d470a0c424
diff --git a/media-libs/imlib2/imlib2-1.6.1.ebuild b/media-libs/imlib2/imlib2-1.6.1.ebuild
new file mode 100644
index 000000000000..bb6d29fdb685
--- /dev/null
+++ b/media-libs/imlib2/imlib2-1.6.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal toolchain-funcs
+
+DESCRIPTION="Version 2 of an advanced replacement library for libraries like libXpm"
+HOMEPAGE="https://www.enlightenment.org/
+ https://sourceforge.net/projects/enlightenment/files/imlib2-src/"
+SRC_URI="https://downloads.sourceforge.net/enlightenment/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+X bzip2 cpu_flags_x86_mmx cpu_flags_x86_sse2 doc +gif +jpeg mp3 +png +shm
+ static-libs +tiff +webp zlib"
+
+REQUIRED_USE="shm? ( X )"
+
+RDEPEND="
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ bzip2? ( app-arch/bzip2[${MULTILIB_USEDEP}] )
+ gif? ( media-libs/giflib[${MULTILIB_USEDEP}] )
+ jpeg? ( virtual/jpeg:0=[${MULTILIB_USEDEP}] )
+ mp3? ( media-libs/libid3tag[${MULTILIB_USEDEP}] )
+ png? ( >=media-libs/libpng-1.6.10:0=[${MULTILIB_USEDEP}] )
+ tiff? ( >=media-libs/tiff-4.0.4:0[${MULTILIB_USEDEP}] )
+ webp? ( media-libs/libwebp:=[${MULTILIB_USEDEP}] )
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ )
+ zlib? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
+ !<media-plugins/imlib2_loaders-1.6.0
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+BDEPEND="virtual/pkgconfig"
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_with X x)
+ $(use_with bzip2)
+ $(use_with gif)
+ $(use_with jpeg)
+ $(use_with mp3 id3)
+ $(use_with png)
+ $(use_with shm x-shm-fd)
+ $(use_enable static-libs static)
+ $(use_with tiff)
+ $(use_with webp)
+ $(use_with zlib)
+ )
+
+ # imlib2 has different configure options for x86/amd64 assembly
+ if [[ $(tc-arch) == amd64 ]]; then
+ myeconfargs+=( $(use_enable cpu_flags_x86_sse2 amd64) --disable-mmx )
+ else
+ myeconfargs+=( --disable-amd64 $(use_enable cpu_flags_x86_mmx mmx) )
+ fi
+
+ ECONF_SOURCE="${S}" \
+ econf "${myeconfargs[@]}"
+}
+
+multilib_src_install() {
+ V=1 emake install DESTDIR="${D}"
+ find "${D}" -name '*.la' -delete || die
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ local HTML_DOCS=( "${S}"/doc/. )
+ rm "${S}"/doc/Makefile.{am,in} || die
+ fi
+ einstalldocs
+}
diff --git a/media-libs/imlib2/metadata.xml b/media-libs/imlib2/metadata.xml
index 7f1dafcefc66..043e8ff987f4 100644
--- a/media-libs/imlib2/metadata.xml
+++ b/media-libs/imlib2/metadata.xml
@@ -6,50 +6,63 @@
<name>Joonas Niilola</name>
</maintainer>
<use>
- <flag name="shm">Use MIT shared memory support for X image transfer.</flag>
+ <flag name="X">Use the X window system</flag>
+ <flag name="bzip2">Bzip2 loader support</flag>
+ <flag name="gif">Gif image loader support</flag>
+ <flag name="jpeg">Jpeg image loader support</flag>
+ <flag name="mp3">ID3 loader support</flag>
+ <flag name="png">PNG image loader support</flag>
+ <flag name="shm">Use MIT shared memory support for X image transfer</flag>
+ <flag name="tiff">TIFF image loader support</flag>
+ <flag name="webp">WEBP image loader support</flag>
+ <flag name="zlib">Zlib loader support</flag>
</use>
<longdescription>
-Imlib 2 is the successor to Imlib. It is not just a newer version - it is a
-completely new library. Imlib2 can be installed alongside Imlib 1.x without any
-problems since they are effectively different libraries - but they Have very
-similar functionality.
+ Imlib 2 is the successor to Imlib. It is not just a newer version - it
+ is a completely new library. Imlib2 can be installed alongside Imlib
+ 1.x without any problems since they are effectively different libraries
+ - but they Have very similar functionality.
-Imlib2 can do the following:
-* Load image files from disk in one of many formats
-* Save images to disk in one of many formats
-* Render image data onto other images
-* Render images to an X-Windows drawable
-* Produce pixmaps and pixmap masks of Images
-* Apply filters to images
-* Rotate images
-* Accept RGBA Data for images
-* Scale images
-* Alpha blend Images on other images or drawables
-* Apply color correction and modification tables and factors to images
-* Render images onto images with color correction and modification tables
-* Render truetype anti-aliased text
-* Render truetype anti-aliased text at any angle
-* Render anti-aliased lines
-* Render rectangles
-* Render linear multi-colored gradients
-* Cache data intelligently for maximum performance
-* Allocate colors automatically
-* Allow full control over caching and color allocation
-* Provide highly optimized MMX assembly for core routines
-* Provide plug-in filter interface
-* Provide on-the-fly runtime plug-in image loading and saving interface
-* Fastest image compositing, rendering and manipulation library for X
+ Imlib2 can do the following:
+ * Load image files from disk in one of many formats,
+ * Save images to disk in one of many formats,
+ * Render image data onto other images,
+ * Render images to an X-Windows drawable,
+ * Produce pixmaps and pixmap masks of Images,
+ * Apply filters to images,
+ * Rotate images,
+ * Accept RGBA Data for images,
+ * Scale images,
+ * Alpha blend Images on other images or drawables,
+ * Apply color correction and modification tables and factors to
+ images,
+ * Render images onto images with color correction and modification
+ tables,
+ * Render truetype anti-aliased text,
+ * Render truetype anti-aliased text at any angle,
+ * Render anti-aliased lines,
+ * Render rectangles,
+ * Render linear multi-colored gradients,
+ * Cache data intelligently for maximum performance,
+ * Allocate colors automatically,
+ * Allow full control over caching and color allocation,
+ * Provide highly optimized MMX assembly for core routines,
+ * Provide plug-in filter interface,
+ * Provide on-the-fly runtime plug-in image loading and saving
+ interface,
+ * Fastest image compositing, rendering and manipulation library for X.
-If what you want isn't in the list above somewhere then likely Imlib 2 does not
-do it. If it does it it likely does it faster than any other library you can find
-(this includes gdk-pixbuf, gdkrgb, etc.) primarily because of highly optimized
-code and a smart subsystem that does the dirty work for you and picks up the
-pieces for you so you can be lazy and let all the optimizations for you.
+ If what you want isn't in the list above somewhere then likely Imlib 2
+ does not do it. If it does it it likely does it faster than any other
+ library you can find (this includes gdk-pixbuf, gdkrgb, etc.) primarily
+ because of highly optimized code and a smart subsystem that does the
+ dirty work for you and picks up the pieces for you so you can be lazy
+ and let all the optimizations for you.
-Imlib 2 can run without a display, so it can be easily used for background image
-processing for web sites or servers - it only requires the X libraries to be
-installed - that is all - it does not require an XServer to run unless you wish
-to display images.
+ Imlib 2 can run without a display, so it can be easily used for
+ background image processing for web sites or servers - it only requires
+ the X libraries to be installed - that is all - it does not require an
+ XServer to run unless you wish to display images.
</longdescription>
<upstream>
<remote-id type="sourceforge">enlightenment</remote-id>