summaryrefslogtreecommitdiff
path: root/media-gfx/pngnq/pngnq-1.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pngnq/pngnq-1.1-r1.ebuild')
-rw-r--r--media-gfx/pngnq/pngnq-1.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-gfx/pngnq/pngnq-1.1-r1.ebuild b/media-gfx/pngnq/pngnq-1.1-r1.ebuild
new file mode 100644
index 000000000000..f8d71e93fc9d
--- /dev/null
+++ b/media-gfx/pngnq/pngnq-1.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Pngnq is a tool for quantizing PNG images in RGBA format"
+HOMEPAGE="http://pngnq.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD pngnq rwpng"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="media-libs/libpng:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-libpng14.patch
+ "${FILESDIR}"/${PN}-1.0-libpng15.patch
+ "${FILESDIR}"/${PN}-1.0-Wimplicit-function-declaration.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}