summaryrefslogtreecommitdiff
path: root/games-puzzle/arrows
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/arrows')
-rw-r--r--games-puzzle/arrows/Manifest3
-rw-r--r--games-puzzle/arrows/arrows-0.6-r1.ebuild48
-rw-r--r--games-puzzle/arrows/metadata.xml8
3 files changed, 59 insertions, 0 deletions
diff --git a/games-puzzle/arrows/Manifest b/games-puzzle/arrows/Manifest
new file mode 100644
index 000000000000..14cbc0307882
--- /dev/null
+++ b/games-puzzle/arrows/Manifest
@@ -0,0 +1,3 @@
+DIST arrows-0.6.tar.gz 53374 BLAKE2B ba31d4ef1bc6e48ada197a13a359004a661a6dcf8875933da2a74f57ad90c3b0d422fd4c2427c4eb340fb26870952ebaa679ff8b0f88d7470f012bc3b8c0f868 SHA512 f6c55d616283ad25d9d830440deaa11de81bccfc2d8eabe627104626ea111d986e522f73d61e5aed58476cc34a3e2b3fe2a20ab1538b7ecef04ecb941f34d83e
+EBUILD arrows-0.6-r1.ebuild 895 BLAKE2B 2aab21a3b6e89451fe1972cd0eace456542641a47bde688958ee0602c75bce6b1fde432603c17c41e97ece3535a71eea7ad4da586dfce99928c4dac224e6e15e SHA512 bf8e71f225251531348c42b99cbd2718a9c68975e26f66f5b8ca16418f0efe4c0664bf00c7d86986d1e3bbc5fef344d413ba824ea03ea2b7131a29278c00d9cc
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-puzzle/arrows/arrows-0.6-r1.ebuild b/games-puzzle/arrows/arrows-0.6-r1.ebuild
new file mode 100644
index 000000000000..5e3b5c6834b5
--- /dev/null
+++ b/games-puzzle/arrows/arrows-0.6-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Simple maze-like game where you navigate around and destroy arrows"
+HOMEPAGE="http://noreason.ca/?file=software"
+SRC_URI="http://noreason.ca/data/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.4:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # Modify path to data
+ sed -i \
+ -e "s:arrfl:/usr/share/${PN}/arrfl:" \
+ -e 's:nm\[9:nm[35:' \
+ -e 's:nm\[6:nm[30:' \
+ -e 's:nm\[7:nm[31:' \
+ game.c \
+ || die 'sed failed'
+ sed -i \
+ -e '/^CC /d' \
+ -e '/CCLIBS/s:$: $(LDFLAGS):' \
+ Makefile \
+ || die 'sed failed'
+}
+
+src_compile() {
+ make clean || die "make clean failed"
+ emake CCOPTS="${CFLAGS}"
+}
+
+src_install() {
+ dobin arrows
+ insinto "/usr/share/${PN}"
+ doins arrfl*
+ einstalldocs
+}
diff --git a/games-puzzle/arrows/metadata.xml b/games-puzzle/arrows/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-puzzle/arrows/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>