summaryrefslogtreecommitdiff
path: root/games-emulation
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/Manifest.gzbin11688 -> 11695 bytes
-rw-r--r--games-emulation/openmsx/Manifest3
-rw-r--r--games-emulation/openmsx/files/openmsx-18.0-gcc13.patch20
-rw-r--r--games-emulation/openmsx/openmsx-18.0-r2.ebuild7
-rw-r--r--games-emulation/ppsspp/Manifest3
-rw-r--r--games-emulation/ppsspp/files/ppsspp-1.14.4-gcc13.patch58
-rw-r--r--games-emulation/ppsspp/ppsspp-1.14.4-r2.ebuild1
7 files changed, 88 insertions, 4 deletions
diff --git a/games-emulation/Manifest.gz b/games-emulation/Manifest.gz
index e3f22bfb3c4f..42e21d1f6a93 100644
--- a/games-emulation/Manifest.gz
+++ b/games-emulation/Manifest.gz
Binary files differ
diff --git a/games-emulation/openmsx/Manifest b/games-emulation/openmsx/Manifest
index 0e6b653d83ed..f309bd12747d 100644
--- a/games-emulation/openmsx/Manifest
+++ b/games-emulation/openmsx/Manifest
@@ -1,4 +1,5 @@
AUX openmsx-18.0-add-ctime.patch 362 BLAKE2B 23c1c79f0356391f40a2cb64e0e1c82ee46057e06365ddc223876b488f0a258d291466c55f012de1c97fc9f0f496ee0359f6bd6ec7d30866b07895959410ea6a SHA512 c550de0cb5d39513ba626323ce8cee5cfcaf545e9759ebf845b4249c9477bbf914c4fe5efd1f9031f590db2fa47c67e81da948983add72cb05c991fa63cfa860
+AUX openmsx-18.0-gcc13.patch 626 BLAKE2B 833be69f78396b890c4fdac73e02ea0a9140236e34a00ec2cce7e35463086bd7b2297d0168125c6cae746742f97393c519631f869d1d5fd85e63dc0dbd88e27a SHA512 60b0c6bee5d371388788d6a5116b8e01e361be4b6a698d1ccc0fbccca15a9a443753c9fe4a085ca87ea28b5e553674c27fe2382a727adb19c9373651d8ba9877
DIST openmsx-18.0.tar.gz 4151084 BLAKE2B 0d5b4e4745c12689e4227408481367b4b4faaa4c7c2830ec0c4b9a5eb90c4b415628cd21834384d39fa4a820c725431848e98f7ef722c437f7bb4f96ae7b14c4 SHA512 f395fae8eac3bcb9334251c1c266a8c4d2951d6510a7c4885ddbc95aaed39f4ef8ae12a177d4a9ff44745ca368055f55f9983029b47441f4fd9731696f79809f
-EBUILD openmsx-18.0-r2.ebuild 2952 BLAKE2B 1a6f815eed0693734e001be4adb14a8c981d6d0819b5e3cfd5b444440ee31751abcbbb55926b8ae56778e73276df5b6e92f0d921e50cd4e1bb72d3a0a435bf35 SHA512 dab7972a6afe8a120737a3a8926c4e888b27e540f0dc10f6edc445b30467208dd0a19179856ba0bec0c7fbf4a3a7ced91dac76c75c60053ee0998c5d3ccf2a25
+EBUILD openmsx-18.0-r2.ebuild 2985 BLAKE2B 42ca9a7f545dd7d07702d3f179124102edfec4dca46d26a0668abd8b9455a500c04b2bc30245cb42b61f242a7c06c6a70af420647bdbcce78ae82f915a148f0f SHA512 17be880189f6c60db1758b998315c56440a9742772ea54b40bb895fbdf9fa102d5b5237454b9fe92189e1b0c8888eccfa3240aa463fcc5928f04b06d6bb1f062
MISC metadata.xml 442 BLAKE2B 579f3b84332385ce6f79c1f927bb3d4b1b112954695bd30425849946ec3994158a855fc9dbff8407775ad532a105e518ba30b4e72f3e42d3b64e2cadffaa9220 SHA512 a24a4c4cef293439f8ea46ad1261507160ea5024cbc53947915e6306a1356d5682440fa1eb230a98e715214c53024fa7ffe4aa97f1bb3f385c66c1ee69b8323f
diff --git a/games-emulation/openmsx/files/openmsx-18.0-gcc13.patch b/games-emulation/openmsx/files/openmsx-18.0-gcc13.patch
new file mode 100644
index 000000000000..3da34aba3aa0
--- /dev/null
+++ b/games-emulation/openmsx/files/openmsx-18.0-gcc13.patch
@@ -0,0 +1,20 @@
+https://bugs.gentoo.org/898908
+https://github.com/openMSX/openMSX/commit/b50d02069c09f11c687637c64ca1b459a5def28c
+
+From b50d02069c09f11c687637c64ca1b459a5def28c Mon Sep 17 00:00:00 2001
+From: m9710797 <vermaelen.wouter@gmail.com>
+Date: Sat, 4 Feb 2023 16:37:39 +0100
+Subject: [PATCH] Added missing #include
+
+Thanks to 'musuruan' for reporting.
+https://github.com/openMSX/openMSX/issues/1487
+--- a/src/utils/hash_set.hh
++++ b/src/utils/hash_set.hh
+@@ -11,6 +11,7 @@
+ #include "unreachable.hh"
+ #include "xrange.hh"
+ #include <cassert>
++#include <cstdint>
+ #include <cstdlib>
+ #include <functional>
+ #include <initializer_list>
diff --git a/games-emulation/openmsx/openmsx-18.0-r2.ebuild b/games-emulation/openmsx/openmsx-18.0-r2.ebuild
index ba32a858f88c..d2c45954266a 100644
--- a/games-emulation/openmsx/openmsx-18.0-r2.ebuild
+++ b/games-emulation/openmsx/openmsx-18.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -38,7 +38,10 @@ the following directories: /usr/share/${PN}/systemroms
or ~/.openMSX/share/systemroms
"
-PATCHES=( "${FILESDIR}/${P}-add-ctime.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-add-ctime.patch"
+ "${FILESDIR}/${P}-gcc13.patch"
+)
src_prepare() {
default
diff --git a/games-emulation/ppsspp/Manifest b/games-emulation/ppsspp/Manifest
index 00a58c352ab3..65ddeb12f4d8 100644
--- a/games-emulation/ppsspp/Manifest
+++ b/games-emulation/ppsspp/Manifest
@@ -1,7 +1,8 @@
+AUX ppsspp-1.14.4-gcc13.patch 1395 BLAKE2B a6bc3e1b3fb4ddf26adc35d2c8815b5ac44ad836d0503356499f198b0c7bd6518dd3e84d7673ff065a2a950a004159de151a289a35d5610d96bb6bb120129329 SHA512 c720bf9441d3aa677507576b77ed839834e24436f8bc369466e45c38a021e15e4ae857c53b14a7ca4d5914fc28f685a74149ab9a02ff9ce41320aef68daa5fd4
AUX ppsspp-CMakeLists-flags.patch 913 BLAKE2B 7bd5df94b51dad35325586f7ad23284436ba670a8c2218a4a6bfb28fb5a055240aeb0543fe331310a0d86d3661cbdf418689a592139ff832802ba1fabbd10fc3 SHA512 5b2ee899b2fbed7229d4abc027e2a010327be4d334e343f977319c475feaf2d180bd74d3640022d0175b11e8256035c828dd4cf03c8a5b9240c989b2d7f72fb7
AUX ppsspp-disable-ccache-autodetection.patch 753 BLAKE2B aa580bb2c657830bb079618e83903c4a0e28aa13acd612592f58feae2b0ef98535ea6f7e3c76aa9e74004aa80367aea372aec443bb2b789d5f3e7359872ea34f SHA512 cbf1f6e9f200cfa3b51bb84e09206a85aaea38511c0036a24d5e12547c659019fe88fbf221d2f7ddbdb9f0129f8b0fabb24baa594c658ab5ab584a0a723bc1c4
DIST ppsspp-1.14.2.tar.xz 46414560 BLAKE2B 3b1cc4a1f7824be4fe0e9abaf52df333965a9b2000bb412b71ea8308a75d4f250ff80c8097856720eb6339926e0b73bb725844f6cabeededc0c2475342a003a9 SHA512 767345235faa54c6a0c19c41fead43f67c39d7f84cd3d573523a745cd082166910090789a985873be047ecaf17513ef318362041f5dcc2b068b1ff061d787f79
DIST ppsspp-1.14.4.tar.xz 46405556 BLAKE2B 6ba958e8bcefffeeb0d05f3c14cf7381737a02deed27c45d564ba4e556af5654e51ffad5c8a8f880ce85b8916db4ed51b8be13c1ca01f7b6d7b28fa266425605 SHA512 144f5af637f747c745a34d28c95d498cfc736777240ad4eb0a08721af2fcb36106cf93a73d49df0fb572ee7ec78b4bc0965c9f4b3845e9457a4d7c967b8389ec
EBUILD ppsspp-1.14.2-r2.ebuild 1399 BLAKE2B e23586f8504465887cf3ecb26991f1fe70ea2d3e871178f564b94bae62d746c54c79ee8e38e3eb4b518875ff68f7c51a74d8b6180098957ba9e4748f410bd927 SHA512 ec6834e59326a5def648b999dd488898639b6f379ae205e7ffa6d6a5dd40b0928b52a98781b4ae59057c858be5ca37ee84ef33e49069ae53664ad85d9b2cc074
-EBUILD ppsspp-1.14.4-r2.ebuild 1399 BLAKE2B e23586f8504465887cf3ecb26991f1fe70ea2d3e871178f564b94bae62d746c54c79ee8e38e3eb4b518875ff68f7c51a74d8b6180098957ba9e4748f410bd927 SHA512 ec6834e59326a5def648b999dd488898639b6f379ae205e7ffa6d6a5dd40b0928b52a98781b4ae59057c858be5ca37ee84ef33e49069ae53664ad85d9b2cc074
+EBUILD ppsspp-1.14.4-r2.ebuild 1431 BLAKE2B 59d64f76252a0e92d254d82d96a4bbc415d45cf0adba8302ef0747f4ad012a7fbce32f9983d21350e4828a32189920e3a56df0c8fed2903e4d23e5327a2ace71 SHA512 81cc79a48bdd6ea1c7a46336d0a25ebb0c889114c6e272537a74358621498d873409dc1838fd2c1813642863af0ca7d512ddc263cea63a8a23d27e86ddf05364
MISC metadata.xml 526 BLAKE2B 19d0378d36d2b1d81ce404a95d98488b54f4368c72a7397b6d7c9a444edec9c19d146295cfc247a75aca1e1b5d1643161a627b80ea76aa8d43189a5eb14380c2 SHA512 7a8c8a7c05acdc110422d7c38552c8106d1886a672e6bda1212ce9cba737ae5e89e6624010d5bc3149b8da7c061b10295a721c74e7377587ec52ec7be2237855
diff --git a/games-emulation/ppsspp/files/ppsspp-1.14.4-gcc13.patch b/games-emulation/ppsspp/files/ppsspp-1.14.4-gcc13.patch
new file mode 100644
index 000000000000..c4888f0efb6f
--- /dev/null
+++ b/games-emulation/ppsspp/files/ppsspp-1.14.4-gcc13.patch
@@ -0,0 +1,58 @@
+https://bugs.gentoo.org/898910
+https://github.com/hrydgard/ppsspp/commit/9874737087e8d24ea72b3f08b4975031b54a80a5
+
+From 822592c6b1441f7110e1cb15dcc5cd2ea1de8099 Mon Sep 17 00:00:00 2001
+From: Andreas Stieger <Andreas.Stieger@gmx.de>
+Date: Wed, 5 Apr 2023 00:20:14 +0200
+Subject: [PATCH] Fix build with GCC13: various standard includes
+
+--- a/Common/Data/Format/IniFile.h
++++ b/Common/Data/Format/IniFile.h
+@@ -8,6 +8,7 @@
+ #include <map>
+ #include <string>
+ #include <vector>
++#include <cstdint>
+
+ #include "Common/File/Path.h"
+
+--- a/Common/GPU/OpenGL/GLFeatures.h
++++ b/Common/GPU/OpenGL/GLFeatures.h
+@@ -5,6 +5,7 @@
+ #pragma once
+
+ #include <string>
++#include <cstdint>
+
+ // TODO: Replace with thin3d's vendor enum.
+ enum {
+--- a/Common/Net/NetBuffer.h
++++ b/Common/Net/NetBuffer.h
+@@ -1,5 +1,7 @@
+ #pragma once
+
++#include <cstdint>
++
+ #include "Common/Buffer.h"
+
+ namespace net {
+--- a/Core/Reporting.h
++++ b/Core/Reporting.h
+@@ -19,6 +19,7 @@
+
+ #include <string>
+ #include <vector>
++#include <cstdint>
+
+ #include "Common/CommonTypes.h"
+ #include "Common/File/Path.h"
+--- a/ext/vma/vk_mem_alloc.h
++++ b/ext/vma/vk_mem_alloc.h
+@@ -2624,6 +2624,7 @@ VMA_CALL_PRE void VMA_CALL_POST vmaFreeStatsString(
+ #include <cstring>
+ #include <utility>
+ #include <type_traits>
++#include <cstdio>
+
+ #ifdef _MSC_VER
+ #include <intrin.h> // For functions like __popcnt, _BitScanForward etc.
diff --git a/games-emulation/ppsspp/ppsspp-1.14.4-r2.ebuild b/games-emulation/ppsspp/ppsspp-1.14.4-r2.ebuild
index 653f672374ea..c908641d14a1 100644
--- a/games-emulation/ppsspp/ppsspp-1.14.4-r2.ebuild
+++ b/games-emulation/ppsspp/ppsspp-1.14.4-r2.ebuild
@@ -43,6 +43,7 @@ BDEPEND="${PYTHON_DEPS}"
PATCHES=(
"${FILESDIR}"/${PN}-CMakeLists-flags.patch
"${FILESDIR}"/${PN}-disable-ccache-autodetection.patch
+ "${FILESDIR}"/${P}-gcc13.patch
)
pkg_setup() {