summaryrefslogtreecommitdiff
path: root/games-action/brutal-legend
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/brutal-legend')
-rw-r--r--games-action/brutal-legend/Manifest6
-rw-r--r--games-action/brutal-legend/brutal-legend-20130615-r1.ebuild86
-rw-r--r--games-action/brutal-legend/brutal-legend-20130615-r2.ebuild83
-rw-r--r--games-action/brutal-legend/metadata.xml26
4 files changed, 201 insertions, 0 deletions
diff --git a/games-action/brutal-legend/Manifest b/games-action/brutal-legend/Manifest
new file mode 100644
index 000000000000..13780d728801
--- /dev/null
+++ b/games-action/brutal-legend/Manifest
@@ -0,0 +1,6 @@
+DIST BrutalLegend-Linux-2013-06-15-setup.bin 8999631895 SHA256 133cc6f565966503d347722a9bd13dd27f86c6ff75f5586cbc4e6ef6bbb8640a SHA512 4099ed07cf78d62617eeac7de396aa01e4e9b0514861a1b0e8988f383b458281be0b3c84c33e2a2e85f80fbbacf8a4b381fc880b138af2e73a226a492cf9620a WHIRLPOOL a50abc04f02bd8ef720f86c9962976c434f8aacc9c814dd6eff2e68fb5db4bbac797e5fbbdd1112298e5a9198144dc18cf18cb7693822a5df4fe95fcda569db0
+EBUILD brutal-legend-20130615-r1.ebuild 1838 SHA256 03ec6f58b36ff9e0a5f9140722a96c50d413ff6febf23f4a6f69b23f96fcb9a1 SHA512 33734a01a6c2683b48822f6f7852ef94d1f239c5dfd9d85fb6c96c52df67398d874fcb53bce825d62b89293fd3a75cec358f5cf99b51cb3352b37ed61647b931 WHIRLPOOL cff4dec5301fc19b6f54ef1c297ef64382e5cc52c71f170d689fe7aaa7d87eea37174feebd477e3489c597e09b7f7df046f51d6a0038395d4c7ec7049ac74c80
+EBUILD brutal-legend-20130615-r2.ebuild 1761 SHA256 f185ea44da998a3a0a425921b3d82f9cb53f3022c64dc0556274418b36f1c09e SHA512 ab5598c321cd1d99b5a119c3bd3c60ad9700c9d2aeec36d388d326a467fc9dbe8271aabdca52c45fc7299e47ee3867aecad9a4bcdbc7a5011c8ddb1da8f19be6 WHIRLPOOL 9bc160f1e82ea54ebfd5b4984db87284b98315d98bd9fff29b20d2f00a95bd4734bd70bfc69c5a7dc0e0fb089f37e2f240edb9a98c162a4e98712ea33d03250f
+MISC ChangeLog 2687 SHA256 b7d838450f82c3dfbb1b4da886140049e465c5c17e2d174f3bb43104fafea17f SHA512 735a313f1ee9e9dcaf581bf822c6d9df153624d8c5352e4ba447accada41bd0dbc58b9a7617981daea0498203e1d96e653fd6c0ed1e2375031582a273bdab160 WHIRLPOOL 3ac96bafd8acfdfbfa55c4664291b518351076b1d45d1cdee76eddb13b42985f0e686c2d32db974bd6325c36b6297239e9c429cdcb065a027dd3e3f26a85f4df
+MISC ChangeLog-2015 1562 SHA256 9255551b1479305f5f8dbeb31c89e89249b3664eca4f6d5c46ec2b754816ce47 SHA512 74c09b418df6588d3e97983e2a04e055e9a710ca59bbb0c5f82e3fe20475bbf0f8da4fe3ca7b883c4e6545028a40b0b8868b059d074f84cbf00152fc94d40b72 WHIRLPOOL 5b1772fb9e09abc6929da13633e9152c99764a69a2abe4e48d00c8256618e76d9097d667368fa805b068b85012d1549044c3ef7d9c7408795e08eb15e2445c5c
+MISC metadata.xml 1120 SHA256 de1e70f517a6c257f80e8e787d90a25982fd437e39277943218212a418f5fc9d SHA512 63b8868817c396e7708aaf65da803cd26eb1fb55fb5bdd9b0a9f92bcf0e5c6bb1a3488287949098b587991541eef6c595395fdfcecddff0b0d91a5686654a296 WHIRLPOOL 9201dede5cdfb11f4d7d85a4a07d24dd142448e8d489dbc4a52e0c8d7a3302a80f80f74828178a9b5e5526758815f9829f45a30ccc7569a1721293b631daaa24
diff --git a/games-action/brutal-legend/brutal-legend-20130615-r1.ebuild b/games-action/brutal-legend/brutal-legend-20130615-r1.ebuild
new file mode 100644
index 000000000000..5f4f6fae14b7
--- /dev/null
+++ b/games-action/brutal-legend/brutal-legend-20130615-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: unbundle libsdl-2
+
+EAPI=5
+
+inherit eutils unpacker gnome2-utils games
+
+TIMESTAMP=${PV:0:4}-${PV:4:2}-${PV:6:2}
+DESCRIPTION="Unleash the power of Heavy Metal to reign down fire from the sky"
+HOMEPAGE="https://www.ea.com/de/brutal-legend"
+SRC_URI="BrutalLegend-Linux-${TIMESTAMP}-setup.bin"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="bindist fetch splitdebug"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/lib/*
+ ${MYGAMEDIR#/}/Buddha.bin.x86"
+
+RDEPEND="
+ amd64? (
+ >=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)]
+ >=virtual/glu-9.0-r1[abi_x86_32(-)]
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXau-1.0.7-r1[abi_x86_32(-)]
+ >=x11-libs/libXdmcp-1.1.1-r1[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ >=x11-libs/libxcb-1.9.1[abi_x86_32(-)]
+ )
+ x86? (
+ sys-libs/zlib
+ virtual/glu
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libxcb
+
+ )"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/data
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store"
+ einfo "and move it to ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ newicon -s 256 Buddha.png ${PN}.png
+ games_make_wrapper ${PN} "./Buddha.bin.x86" "${MYGAMEDIR}" "${MYGAMEDIR}/lib"
+ make_desktop_entry ${PN}
+
+ dodir "${MYGAMEDIR}"
+ # this is over 9000!!!! ...eh, 8GB data
+ mv * "${D%/}/${MYGAMEDIR}" || die
+
+ fperms +x "${MYGAMEDIR}/Buddha.bin.x86"
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-action/brutal-legend/brutal-legend-20130615-r2.ebuild b/games-action/brutal-legend/brutal-legend-20130615-r2.ebuild
new file mode 100644
index 000000000000..b9c0096e1456
--- /dev/null
+++ b/games-action/brutal-legend/brutal-legend-20130615-r2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: unbundle libsdl-2
+
+EAPI=6
+
+inherit eutils unpacker gnome2-utils
+
+TIMESTAMP=${PV:0:4}-${PV:4:2}-${PV:6:2}
+DESCRIPTION="Unleash the power of Heavy Metal to reign down fire from the sky"
+HOMEPAGE="https://www.ea.com/de/brutal-legend"
+SRC_URI="BrutalLegend-Linux-${TIMESTAMP}-setup.bin"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="bindist fetch splitdebug"
+
+MYGAMEDIR="/opt/${PN}"
+QA_PREBUILT="${MYGAMEDIR#/}/lib/*
+ ${MYGAMEDIR#/}/Buddha.bin.x86"
+
+RDEPEND="
+ amd64? (
+ >=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)]
+ >=virtual/glu-9.0-r1[abi_x86_32(-)]
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXau-1.0.7-r1[abi_x86_32(-)]
+ >=x11-libs/libXdmcp-1.1.1-r1[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ >=x11-libs/libxcb-1.9.1[abi_x86_32(-)]
+ )
+ x86? (
+ sys-libs/zlib
+ virtual/glu
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libxcb
+
+ )"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/data
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store"
+ einfo "and move it to ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ newicon -s 256 Buddha.png ${PN}.png
+ make_wrapper ${PN} "./Buddha.bin.x86" "${MYGAMEDIR}" "${MYGAMEDIR}/lib"
+ make_desktop_entry ${PN}
+
+ dodir "${MYGAMEDIR}"
+ # this is over 9000!!!! ...eh, 8GB data
+ mv * "${D%/}/${MYGAMEDIR}" || die
+
+ fperms +x "${MYGAMEDIR}/Buddha.bin.x86"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-action/brutal-legend/metadata.xml b/games-action/brutal-legend/metadata.xml
new file mode 100644
index 000000000000..336d0fe7cf2a
--- /dev/null
+++ b/games-action/brutal-legend/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Jack Black stars as Eddie Riggs, a roadie who’s sucked into a
+ mythical Age of Rock to fight evil, liberate an army of headbangers
+ from a life of oppression, find love, and discover his life’s
+ purpose. Heavy stuff until one realizes the universe of Brütal
+ Legend has sprung up from the mind of legendary game director Tim
+ Schafer.
+
+ Enter the world of Heavy Metal where mountains are made of
+ amplifiers, killer spiders spin guitar strings, druids want to
+ kill you, and Rock Legends roam the landscape.
+
+ Armed with a massive battle-axe, guitar, and his hot-rod, Eddie
+ will rip the faces off of demons. As Eddie, expect to crush skulls,
+ ravage the road in the Deuce, and unleash the power of Heavy Metal
+ to reign down fire from the sky — all to save humanity and become
+ a brutal legend.
+ </longdescription>
+</pkgmetadata>