summaryrefslogtreecommitdiff
path: root/dev-util/eric
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/eric')
-rw-r--r--dev-util/eric/Manifest4
-rw-r--r--dev-util/eric/eric-18.03.ebuild24
-rw-r--r--dev-util/eric/eric-19.11-r1.ebuild (renamed from dev-util/eric/eric-19.11.ebuild)18
3 files changed, 27 insertions, 19 deletions
diff --git a/dev-util/eric/Manifest b/dev-util/eric/Manifest
index 253618d149e9..54833e1c69cb 100644
--- a/dev-util/eric/Manifest
+++ b/dev-util/eric/Manifest
@@ -1,5 +1,5 @@
DIST eric6-18.03.tar.gz 16517664 BLAKE2B f7f5292df8bc694fc4715ec1a250d948123a2eb99a590e6824d985318446babff86aeb745f5b5dbd0707e771638eaa943673e5b546676bea97e266888b844989 SHA512 e488010791b44cc7da782620baec9b97259aaefeb90d491023ec1d4582fb68acbc06d9eedba7beef9ddc706302e06e36b9ebb4e46d6f035b6c74e9f4eb9ac400
DIST eric6-19.11.tar.gz 16241807 BLAKE2B bd8284164c6c191e91fc08bc42f594107ebab50f71a980ef331d42fbd8d9c488d5674b2f53665718a6e723a228e838d082095fc3c3b2d40c3fb350c5be9a98ee SHA512 a8305c5185687d62231926bd4c484f3786ac1c20d125a1f8fb1b6bc0d42c57ba92bf00aaffd8699f8d7594c6432896bef8db13da85513ba4f217a60223f2f533
-EBUILD eric-18.03.ebuild 1890 BLAKE2B 4b88d3921fd5f3ab9d3a21a5eca1de9b7a914382f731578de66039fc3cf6a96bf261296e990b08501df99e1862dcec4c02d44a06a14daaa3dc9784c7e9fd40a8 SHA512 45d1567fc9e1519746441ed7853600d18c7aabfaf3bba343af02d4d0fc2006f6c486b953cd34c80363dd33478896ba90f90aec1a7919f385a1572ea2c4bb0e17
-EBUILD eric-19.11.ebuild 1381 BLAKE2B 360c32ca7d04511139008ab1902d7e606d4bd3c19e8f376b7fc56471f0e3bfd71ee3258351625a2a052bab0b66cca4eaceb4f0e71537af0057c823bf21695a3b SHA512 214d0b9b90ef9ac3935be9f931a0c4adf8d74ff0967ddbae14d1d88589f61d18606dbceef35baf7759a798e7c6368360aa8320787e1b34b88e19f715d68bbeab
+EBUILD eric-18.03.ebuild 2006 BLAKE2B cdb9fa4fde6f525b8c07ee26766735e4f262306c4f2cd8e2dec4fdefa73e92ca3cd3873d372118e552acd12885c73a181ac1f980fa73796654438bd2956527f2 SHA512 190a12f66be031dbca1e4d566f0a6e3a1ae11a1cfe770984205a3b9cb34f1afd78e3f79b40115c68d751e25d7d7f6a95bc223d4af1528f7dcdcdd2d8419f2398
+EBUILD eric-19.11-r1.ebuild 1488 BLAKE2B a37b87b2fe72c30cbf2a2c7a0ea196a143fa5cd5235ef2ef1e32016951676a08bfdbd9bf3927915d59d22de7c7d7641a9f39b6a79a097a69080e58a67c21e8a9 SHA512 5dd51dbb756ee8545a16846415e22636b7850b9d319d75faac2cdf33ce460eee2d28b9766bf689e1fb70a3e4fc028e35a7be4950fc9d7d5e800bba3e63778ccd
MISC metadata.xml 325 BLAKE2B 5c4bd806e4833d3f4c294ca46b24420c71f8ef234ea732460833f39f583e0e5156d773d6fbf7fb4d45edf409d21622a9b90e0989e9d93632d7dd94b7aa7e6c3f SHA512 e3da71c04a1a2af6b72ff068eba586c14b159034f759448c669032b30a82cc618e58467cc8cec8090d22d0e864338fc62b735f73dc31fd2a33d63cb677178f9e
diff --git a/dev-util/eric/eric-18.03.ebuild b/dev-util/eric/eric-18.03.ebuild
index 3e51fdbe81d8..c67b729ada77 100644
--- a/dev-util/eric/eric-18.03.ebuild
+++ b/dev-util/eric/eric-18.03.ebuild
@@ -19,18 +19,22 @@ IUSE=""
DEPEND="
${PYTHON_DEPS}
- >=dev-python/sip-4.14.3[${PYTHON_USEDEP}]
- >=dev-python/PyQt5-5.7.1[gui,network,printsupport,sql,svg,widgets,${PYTHON_USEDEP}]
- >=dev-python/qscintilla-python-2.10[qt5(+),${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/sip-4.14.3[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/PyQt5-5.7.1[gui,network,printsupport,sql,svg,widgets,${PYTHON_MULTI_USEDEP}]
+ >=dev-python/qscintilla-python-2.10[qt5(+),${PYTHON_MULTI_USEDEP}]
+ ')
"
RDEPEND="${DEPEND}
- || (
- dev-python/PyQt5[help,webengine,${PYTHON_USEDEP}]
- dev-python/PyQt5[help,webkit,${PYTHON_USEDEP}]
- )
- >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.1.0[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ || (
+ dev-python/PyQt5[help,webengine,${PYTHON_MULTI_USEDEP}]
+ dev-python/PyQt5[help,webkit,${PYTHON_MULTI_USEDEP}]
+ )
+ >=dev-python/chardet-3.0.4[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/coverage-4.1.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pygments-2.2.0[${PYTHON_MULTI_USEDEP}]
+ ')
!dev-util/eric:4
!dev-util/eric:5
"
diff --git a/dev-util/eric/eric-19.11.ebuild b/dev-util/eric/eric-19.11-r1.ebuild
index 425d51c2062c..bb8cee447042 100644
--- a/dev-util/eric/eric-19.11.ebuild
+++ b/dev-util/eric/eric-19.11-r1.ebuild
@@ -20,15 +20,19 @@ IUSE="spell"
DEPEND="
${PYTHON_DEPS}
- >=dev-python/PyQt5-5.12[gui,help,network,printsupport,sql,svg,widgets,${PYTHON_USEDEP}]
- dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
- dev-python/qscintilla-python[${PYTHON_USEDEP}]
- dev-python/sip[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/PyQt5-5.12[gui,help,network,printsupport,sql,svg,widgets,${PYTHON_MULTI_USEDEP}]
+ dev-python/PyQtWebEngine[${PYTHON_MULTI_USEDEP}]
+ dev-python/qscintilla-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/sip[${PYTHON_MULTI_USEDEP}]
+ ')
"
RDEPEND="${DEPEND}
- >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.3.1[${PYTHON_USEDEP}]
- spell? ( dev-python/pyenchant[${PYTHON_USEDEP}] )
+ $(python_gen_cond_dep '
+ >=dev-python/chardet-3.0.4[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pygments-2.3.1[${PYTHON_MULTI_USEDEP}]
+ spell? ( dev-python/pyenchant[${PYTHON_MULTI_USEDEP}] )
+ ')
"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"