summaryrefslogtreecommitdiff
path: root/dev-python/portend
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/portend')
-rw-r--r--dev-python/portend/Manifest1
-rw-r--r--dev-python/portend/portend-2.2-r1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/portend/Manifest b/dev-python/portend/Manifest
index 27f9e7305cff..a4eb5c7be42b 100644
--- a/dev-python/portend/Manifest
+++ b/dev-python/portend/Manifest
@@ -1,3 +1,4 @@
DIST portend-2.2.tar.gz 7974 BLAKE2B 77ffcf02b65f276a5ca1f1bdd76afd54e8f6afcb1c55b6948862017f973772dfe65c9b934ffbc98d2f36f799131d23d4a7128f46e46183010def8936f2dd0bad SHA512 1782132b0dec5b678892190b70ab795b1748dfa17e257b6655fc803f0cf19652725778cd329c3609353f969959501dd11fd2b9726cfcdf2c58689e2ce280c146
+EBUILD portend-2.2-r1.ebuild 716 BLAKE2B 509a32f062e47230cc6d62919b45f9954ce0e15cfd58843a7376ee1aad5a645278e5eee4c2e0b85db6fd4cc1c8bf4f8e82f6018017cd00b979f48dbbd4a9af5c SHA512 4dd8469cb1426b41edd40ddbff10cec085d86b751313b31295f0853a7c8d1c50aedc8c2aeb404c22a07350a972e246b5fa763717b9a7fce41aad372eff65a8b1
EBUILD portend-2.2.ebuild 721 BLAKE2B 41301119264f2c4e126083ff4ce8f941a204a2505c4e345185ef0191318f199ba1dab81c8839ea7e63f07897e4a9047cc9df2167725ec4f4b75b9eca90b890bb SHA512 32047fb041e2de07b8accc5b0e1aa2e3e21f9ba4039569b70e1cd49c85ec5ecb45e1e3522e084fcc96af65108efb31f73f5bbcdd9ba2226d439dde1845ff6ffe
MISC metadata.xml 368 BLAKE2B 3f51a162e0c69485b7fb54960635b24ccb4741cf053ad4ac314f7f45798cc56056a7416e2207b6eb1084dffeb9bed043053eaa2ae5ac3b8d0dec142a47d1fe36 SHA512 269ed8048e3bcf73a693874ab0a6a269fa24169a1a95d9cb5bebad5e87193c443be8883682df973b4a461447ebd6042cdc7a932f81019b0ea53b3da7c566bf82
diff --git a/dev-python/portend/portend-2.2-r1.ebuild b/dev-python/portend/portend-2.2-r1.ebuild
new file mode 100644
index 000000000000..aa3d5f77db5e
--- /dev/null
+++ b/dev-python/portend/portend-2.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="TCP port monitoring utilities"
+HOMEPAGE="https://pypi.org/project/portend/ https://github.com/jaraco/portend"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/tempora-1.8[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v || die "tests failed under ${EPTYHON}"
+}