summaryrefslogtreecommitdiff
path: root/dev-python/argon2-cffi
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/argon2-cffi')
-rw-r--r--dev-python/argon2-cffi/Manifest1
-rw-r--r--dev-python/argon2-cffi/argon2-cffi-21.3.0-r2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/argon2-cffi/Manifest b/dev-python/argon2-cffi/Manifest
index 73b348658f5d..82636c3c2429 100644
--- a/dev-python/argon2-cffi/Manifest
+++ b/dev-python/argon2-cffi/Manifest
@@ -1,3 +1,4 @@
DIST argon2-cffi-21.3.0.tar.gz 38446 BLAKE2B e0464f501efcdfbf33d93e0c1c6dbc519ad6aee06c0b8692417156de608f6c6acf947f86b866c064601fe994087677e51d954ae2c1225cbbbba3534cf70c6296 SHA512 6cb2a075f3bb7040ee7f552d082bfa2f3df0854649d9c84fdfdb42bb4bee2133b8a35a20be2b3c887931efda12fbbb00815d8d88170b7e20b3ca19c86f97057e
EBUILD argon2-cffi-21.3.0-r1.ebuild 1176 BLAKE2B 97b09203c17fa17030d4eeb4780d0f2b957cbb1417c91d4adba76058d53c260f926e8f4c5a4e78b6eecdd6cb55601c8e2b59567e7127b46a32036b207d4fa91e SHA512 c38e34fa4c8c9973da3039a1be22381a773288cca548b9ca4a24ce20c92968d255160c62c607e093a659978f642b7dc41a485dd48124dd1422e1b6f5a4dac563
+EBUILD argon2-cffi-21.3.0-r2.ebuild 768 BLAKE2B c489a1778d1fcc45d51e90e8890d8da1875f24310940ea3144852f2a7825d26acc2876bc30f9a1085045afb725c782472212119e40ce7899e883da14e1994381 SHA512 57d0af3507481f9c671e440c18d99b59306d238eb79543418b3f82d940dc4016fdd4cd52798ef789e61eba57e9dff3c82cfdf37e1747bac560a4029a27b1e94f
MISC metadata.xml 666 BLAKE2B 831fde25c0b52ed8610f39ab589f339783bace8dc2cc60ffa4736257c352bc82b89e110bf44181790e4a16db967e4c516f21fbc3cd1526a9975cc86b21f723f7 SHA512 543bb0e37fdf96b8c2fa4ec26eae837317dda4688b4293e82268100ce69e3f9987e91b2f141cac1be4becba9698f9806d22242801523bec825271b8fa4f14bc8
diff --git a/dev-python/argon2-cffi/argon2-cffi-21.3.0-r2.ebuild b/dev-python/argon2-cffi/argon2-cffi-21.3.0-r2.ebuild
new file mode 100644
index 000000000000..e52ba5f9cf7b
--- /dev/null
+++ b/dev-python/argon2-cffi/argon2-cffi-21.3.0-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="CFFI bindings to the Argon2 password hashing library"
+HOMEPAGE="https://github.com/hynek/argon2-cffi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND=">=dev-python/argon2-cffi-bindings-21.2.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( AUTHORS.rst FAQ.rst README.rst )
+
+distutils_enable_sphinx docs \
+ dev-python/furo \
+ dev-python/sphinx-notfound-page
+distutils_enable_tests pytest