summaryrefslogtreecommitdiff
path: root/dev-perl/Module-Runtime/Module-Runtime-0.14.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Module-Runtime/Module-Runtime-0.14.0.ebuild')
-rw-r--r--dev-perl/Module-Runtime/Module-Runtime-0.14.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Module-Runtime/Module-Runtime-0.14.0.ebuild b/dev-perl/Module-Runtime/Module-Runtime-0.14.0.ebuild
new file mode 100644
index 000000000000..db572f2d20e0
--- /dev/null
+++ b/dev-perl/Module-Runtime/Module-Runtime-0.14.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=ZEFRAM
+MODULE_VERSION=0.014
+inherit perl-module
+
+DESCRIPTION="Runtime module handling"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+SRC_TEST="do"
+
+src_test() {
+ perl_rm_files t/pod_cvg.t t/pod_syn.t
+ perl-module_src_test
+}