summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-conduit
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-conduit')
-rw-r--r--dev-ml/ocaml-conduit/Manifest3
-rw-r--r--dev-ml/ocaml-conduit/metadata.xml11
-rw-r--r--dev-ml/ocaml-conduit/ocaml-conduit-0.15.4.ebuild46
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-ml/ocaml-conduit/Manifest b/dev-ml/ocaml-conduit/Manifest
new file mode 100644
index 000000000000..e773f83f521c
--- /dev/null
+++ b/dev-ml/ocaml-conduit/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-conduit-0.15.4.tar.gz 38960 BLAKE2B 3f4631a6a67ab00ecc0d903f0f0b832035b61d3fceec57db50bea0f56454292b4fa3911f4eeb5e05f8fb9fb68f13ca0f9e6c3c078d3bd5d0a1bb7c4bcac18495 SHA512 12f61828c943cb60b2c9be080fb32c8fe5ba16d8bac46a8b788f2ea9b8b7a3a53563defbb05271d516365d18cddafe57051125391ac018328608c4f6537ec5b0
+EBUILD ocaml-conduit-0.15.4.ebuild 868 BLAKE2B b250c496f80c67c851df0ba3ad2e4b8b709149febb5d01c5c10c1314ee9db2c690fc0bdce24b5492b6dbc425553025abefc07187323daa0e31c2f3ad39d8bdab SHA512 a10c6ff240d4f2ea9fd32bf99956d25dbc8e84e733cb0a54f3a631e4ebebb603a13ad19b2724ac7b61e1f43247ad2b95ef00468ec64d410a46efc4bbf7b5435c
+MISC metadata.xml 332 BLAKE2B e3794e4c144793fc78991ac450171d22ac2c868bd03a9c120f826f609ed5a9ddfd3a460b4c46d5b4f8a2c0fa2aeecb2f174c6178250c189bd71a45e6c5ef66dc SHA512 66b243700b34216aca33384ebe7dfef68e83b8eb6b755118f56643bdf45f2f83d71db375295b72b52ebacf237849b985ed598fbd0eb52fe1fd58a9f436f2d87a
diff --git a/dev-ml/ocaml-conduit/metadata.xml b/dev-ml/ocaml-conduit/metadata.xml
new file mode 100644
index 000000000000..06a872f18368
--- /dev/null
+++ b/dev-ml/ocaml-conduit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mirage/ocaml-conduit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-conduit/ocaml-conduit-0.15.4.ebuild b/dev-ml/ocaml-conduit/ocaml-conduit-0.15.4.ebuild
new file mode 100644
index 000000000000..5690ccf9541d
--- /dev/null
+++ b/dev-ml/ocaml-conduit/ocaml-conduit-0.15.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="Dereference URIs into communication channels for Async or Lwt"
+HOMEPAGE="https://github.com/mirage/ocaml-conduit"
+SRC_URI="https://github.com/mirage/ocaml-conduit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/sexplib:=
+ dev-ml/stringext:=
+ dev-ml/ocaml-uri:=
+ dev-ml/logs:=
+ dev-ml/ocaml-cstruct:=
+ dev-ml/ocaml-ipaddr:=
+
+ >=dev-ml/lwt-3:=
+ dev-ml/lwt_ssl:=
+ dev-ml/async:=
+ dev-ml/dns:=
+ dev-ml/ocaml-ssl:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+ dev-ml/ppx_driver
+ dev-ml/ppx_optcomp
+ dev-ml/ppx_sexp_conv
+"
+
+DOCS=( TODO.md README.md CHANGES )
+
+src_install() {
+ findlib_src_preinst
+ default
+}