summaryrefslogtreecommitdiff
path: root/dev-libs/luise-bin
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/luise-bin')
-rw-r--r--dev-libs/luise-bin/Manifest3
-rw-r--r--dev-libs/luise-bin/luise-bin-0.1.1-r1.ebuild39
-rw-r--r--dev-libs/luise-bin/metadata.xml22
3 files changed, 62 insertions, 2 deletions
diff --git a/dev-libs/luise-bin/Manifest b/dev-libs/luise-bin/Manifest
index 7e45fd170219..68afa59649cb 100644
--- a/dev-libs/luise-bin/Manifest
+++ b/dev-libs/luise-bin/Manifest
@@ -1,3 +1,4 @@
DIST LUIse_0.1.1.tar.gz 393815 BLAKE2B be7e35e1f4d5f6227f92bfeb5ed414593215c194e8d7ab67036ac7316cf6faeada839bbef15d8569b6fc276f3bddf41bdaf66e7315f6e8ff1341f8d697327895 SHA512 821b62ed476088c3818cb478a3c525e1d92e9879ef4059da0eb534852a294f802550ad7169066fe439f0cb3645e98656f405594db633061029ae9d7eff86f31d
+EBUILD luise-bin-0.1.1-r1.ebuild 1000 BLAKE2B 5f2f5c5f7d1a75499bb27313931a4dd046c032e3e4f7ac69c211b1fb886c842b2e407a86034cecc2d0d75a91dc106629ac4595a187ffa2da6f6deb429879b127 SHA512 be7a2113830d898804813d778cec3e91200f294afbdc114ce868e86f64ed6e249fe462e6e612d446541591e3665a43739e96b5e6a606ac0d0930dec8702740bd
EBUILD luise-bin-0.1.1.ebuild 956 BLAKE2B 8f6bae020414fb375dc2cb533c95424635c799afa2780569d233cfa51bf94aed84118eaeeff607ec36c84c3dccbc02fdc583622838f541d9ab2b4e86b0bfabe7 SHA512 1a43b77112f275ddfb7ef16b9a8e006e888b38e725e9f742a670440434157207cad18f52c75dc7078b4cb053eda601e178c5a895e8c49e8d7a0814a14288779f
-MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
+MISC metadata.xml 1313 BLAKE2B 18110903546bc63acdabc23a02b0acc5e74a6ae34912a8224e6a7c57b6c235278b3469c9620ea8dc55e461c9aafdeb7d7b53961d8324d5c4d716884c5875b219 SHA512 cf23b2da2f293cbb12caffb1dfa4bc228acdc0eb9ebf454319e1c6875619b43aa64bcbcefb1f50330b135268132f05c0e5ae446b948a8a00960bcded46b80448
diff --git a/dev-libs/luise-bin/luise-bin-0.1.1-r1.ebuild b/dev-libs/luise-bin/luise-bin-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..0b998ae7bf27
--- /dev/null
+++ b/dev-libs/luise-bin/luise-bin-0.1.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="LUIse"
+
+inherit multilib
+
+DESCRIPTION="Programming interface for the Wallbraun LCD-USB-Interface"
+HOMEPAGE="https://web.archive.org/web/20130718114020/http://wallbraun-electronics.de/"
+SRC_URI="https://www.bl4ckb0x.de/files/${MY_PN}_${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="examples"
+
+RDEPEND="virtual/libusb:0"
+
+S="${WORKDIR}/${MY_PN}_${PV}"
+
+QA_PREBUILT="
+ usr/lib/libluise.so.${PV}
+ usr/lib64/libluise.so.${PV}
+"
+
+src_install() {
+ insinto /usr/$(get_libdir)
+ newins $(usex amd64 '64' '32')bit/libluise$(usex amd64 '_64' '').so.${PV} libluise.so.${PV}
+ dosym ../../usr/$(get_libdir)/libluise.so.${PV} /usr/$(get_libdir)/libluise.so.${SLOT}
+ dosym ../../usr/$(get_libdir)/libluise.so.${PV} /usr/$(get_libdir)/libluise.so
+
+ insinto /usr/include
+ doins $(usex amd64 '64' '32')bit/luise.h
+
+ dodoc doc/*
+ use examples && dodoc -r samples/luise-test
+}
diff --git a/dev-libs/luise-bin/metadata.xml b/dev-libs/luise-bin/metadata.xml
index 6f49eba8f496..31373f78eb1f 100644
--- a/dev-libs/luise-bin/metadata.xml
+++ b/dev-libs/luise-bin/metadata.xml
@@ -1,5 +1,25 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ The libluise.so lib provides a very simple interface for programming
+ the USB LCDs ready. The programmer has three independent screens available,
+ a text screen and two graphic screens. The screens are each 320x240 pixels.
+ By the two separate graphic screens can be very easily superimposed static and
+ represent dynamic data. This is for example when using background images
+ helpful because the environment of the dynamic data / graphics is not constantly recalculated
+ got to. All three screens will appear "on top of each other" on the LCD and will go through
+ previously defined parameters (LUI_LCDmode ()) corresponding to each other bitwise
+ connected. The coordinate origin (x = 0, y = 0) of a screen is always in the
+ left upper corner. In addition, the inversion and the rotation of the screens
+ supports (90 ° steps), while saving the programmer the coordinates conversions stay.
+ </longdescription>
</pkgmetadata>