summaryrefslogtreecommitdiff
path: root/dev-java/commons-math
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/commons-math')
-rw-r--r--dev-java/commons-math/Manifest7
-rw-r--r--dev-java/commons-math/commons-math-2.1-r2.ebuild42
-rw-r--r--dev-java/commons-math/commons-math-3.2.ebuild53
-rw-r--r--dev-java/commons-math/files/commons-math-2.1-r2-buildfixes.patch19
-rw-r--r--dev-java/commons-math/files/commons-math-3.2-build.xml288
-rw-r--r--dev-java/commons-math/metadata.xml8
6 files changed, 0 insertions, 417 deletions
diff --git a/dev-java/commons-math/Manifest b/dev-java/commons-math/Manifest
deleted file mode 100644
index 29816a8283d3..000000000000
--- a/dev-java/commons-math/Manifest
+++ /dev/null
@@ -1,7 +0,0 @@
-AUX commons-math-2.1-r2-buildfixes.patch 770 BLAKE2B 99782f38b6efdfa94b0b69390bc04d487ef20698fe1bea456c8919ea88a635d009b10c8d27e7124f0e4f0bb9a1c97110a959421cbd4f6aee70ebb9f5821bb812 SHA512 75a0174c839425a7f1387ef582a08899b7433dcc2090d773642ea120dc220c69d741fef5b44508ad9fdb3e2f24d8fe2b9dfc92146985f88416dae8178a5d7798
-AUX commons-math-3.2-build.xml 12448 BLAKE2B 04021b793945a00a95152ef98772dfb5735cce14307d33772701a6240a8d5a094b2156faf4fc775454c0c369df066f9404a0d5a5671f809647ae1e5389648ec4 SHA512 7f7d4a469843b218e90e3482360101058f027cf7d2319f1f7a5a4af7c09b6e4b05237c594eb217d5ffc3f07793fcabaa733be52686148af94a12727e4fda89ed
-DIST commons-math-2.1-src.tar.gz 1099423 BLAKE2B 83c52abc10eebb6c749aec218aa435df4cd05106e6bcbead5061df7381d168aa9392ab70dce8eb0b8e254d6d95a372cacddc8f7714198a186a95a04a394bda9d SHA512 53ed8c0400402c588d824c15365ebe60bef41697ff9728270a9fdc3ac30eb60c4c397caf939ccda839eb701453d98af4eac9eae2090575fcfdee4df2d6f6045b
-DIST commons-math3-3.2-src.tar.gz 2602474 BLAKE2B a818ca5ab1b9799359bad1c84d2774329c7c2605aeea3e13769eed9f1578d412555ad90a8de68971daa42b270d4bcd5fbf0fe79714e839d41b08077e32633125 SHA512 132c4725be582e25f67a955c7b3b8c7ef155606d8f4da07770464c422ded6b5e6efd1a13a6e98cff222f4fcac73606d512ee1ab9e3b1c4befcc1ba16ab68787b
-EBUILD commons-math-2.1-r2.ebuild 903 BLAKE2B 2b390b4109fd875bc79f957b2fc22a0e3ce1536476ed331bd57e32d1e90417200002f14045cd7af145f0a1a172e23773531682ac427f0a20e905cb10b8ae305f SHA512 aacd02d27d30d7f27c5bb35cad318b21a4235b0264282527244d892f509e3e0032eaf5407bfbab9b6c4f548c7e9efcbe68629bf0502899c1e9c6d32fb8ad9a4e
-EBUILD commons-math-3.2.ebuild 1315 BLAKE2B a0fe207cc34dae87b52df7709e27f9fc4588e591347d507f8b69cf46ded1eb0b2d23943a93af9997ab215146873fd60479628c80fbcc72dcf8cd1d3c5dc1b72f SHA512 a1f5e7f79e7b36e011a16ed87de7aecf5a9cf8ae8570cdc5fff90a79505bde6120c475df96e188129daec1c436d0409e1260136849c36edafef29e9a70389329
-MISC metadata.xml 236 BLAKE2B 5a64c4404c26415501f50132968e687d4f1b852738cb0e1a5aef8cc4de9e4ea623066f46068fce3d80514ff122d85304e3fd12282c4b1513a4084523ef8bef07 SHA512 1755c2590e59060f697294c5ad125b83f2d50e05a71f7091b7de75953941914cd2db3a893bd6154a2c90fa4aff5e313e75e3e174dbba1edd5c112787da5be253
diff --git a/dev-java/commons-math/commons-math-2.1-r2.ebuild b/dev-java/commons-math/commons-math-2.1-r2.ebuild
deleted file mode 100644
index b18fc803124f..000000000000
--- a/dev-java/commons-math/commons-math-2.1-r2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-JAVA_PKG_IUSE="doc test source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Lightweight, self-contained mathematics and statistics components"
-HOMEPAGE="https://commons.apache.org/math/"
-SRC_URI="mirror://apache/commons/math/source/${P}-src.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="2"
-KEYWORDS="amd64 x86"
-
-DEPEND="
- >=virtual/jdk-1.6
- test? (
- dev-java/ant-junit4
- dev-java/hamcrest-core:0
- )"
-
-RDEPEND="
- >=virtual/jre-1.6"
-
-S="${WORKDIR}/${P}-src"
-
-PATCHES=( "${FILESDIR}"/${PF}-buildfixes.patch )
-
-src_test() {
- java-pkg_jar-from junit-4
- java-pkg_jar-from hamcrest-core
- ANT_TASKS="ant-junit4" eant -Djunit.jar=junit.jar test
-}
-
-src_install() {
- java-pkg_newjar target/${P}.jar ${PN}.jar
-
- use doc && java-pkg_dojavadoc target/apidocs
- use source && java-pkg_dosrc src/main/java/org
-}
diff --git a/dev-java/commons-math/commons-math-3.2.ebuild b/dev-java/commons-math/commons-math-3.2.ebuild
deleted file mode 100644
index 7d4b8f2dc93e..000000000000
--- a/dev-java/commons-math/commons-math-3.2.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-# Tests are currently broken due to nasty -lib argument.
-JAVA_PKG_IUSE="doc source" # test
-
-inherit java-pkg-2 java-ant-2 java-osgi
-
-MY_PN="${PN}3"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Lightweight, self-contained mathematics and statistics components"
-HOMEPAGE="https://commons.apache.org/math/"
-SRC_URI="mirror://apache/commons/math/source/${MY_P}-src.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="3"
-KEYWORDS="amd64 x86"
-
-DEPEND=">=virtual/jdk-1.5"
-
-# Tests are currently broken due to nasty -lib argument.
-# test? (
-# dev-java/ant-junit4
-# dev-java/hamcrest-core:0
-# )"
-
-RDEPEND=">=virtual/jre-1.5"
-
-S="${WORKDIR}/${MY_P}-src"
-
-java_prepare() {
- cp "${FILESDIR}"/${P}-build.xml build.xml || die
-
- sed -i 's/manifest=".*MANIFEST.MF"//g' build.xml || die
- sed -i '/name="Main-Class"/d' build.xml || die
-}
-
-# Tests are currently broken due to nasty -lib argument.
-# src_test() {
-# java-pkg_jar-from junit-4
-# java-pkg_jar-from hamcrest-core
-# ANT_TASKS="ant-junit4" eant -Djunit.jar=junit.jar test
-# }
-
-src_install() {
- java-osgi_newjar target/${MY_P}.jar ${MY_PN} ${MY_PN} "Export-Package: ${MY_PN}"
-
- use doc && java-pkg_dojavadoc target/site/apidocs
- use source && java-pkg_dosrc src/main/java/org
-}
diff --git a/dev-java/commons-math/files/commons-math-2.1-r2-buildfixes.patch b/dev-java/commons-math/files/commons-math-2.1-r2-buildfixes.patch
deleted file mode 100644
index 6d768969e79c..000000000000
--- a/dev-java/commons-math/files/commons-math-2.1-r2-buildfixes.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- build.xml 2010-10-24 11:20:46.000000000 +0300
-+++ build.xml.fixed 2010-10-24 11:25:42.000000000 +0300
-@@ -114,6 +114,7 @@
- <pathelement location="${build.home}/classes"/>
- <pathelement location="${build.home}/test-classes"/>
- <pathelement location="${junit.jar}"/>
-+ <pathelement location="hamcrest-core.jar"/>
- <path refid="downloaded.lib.classpath"/>
- </path>
-
-@@ -232,7 +233,7 @@
-
- <!-- ========== Create Jar ================================================ -->
-
-- <target name="jar" depends="test" description="Create jar file">
-+ <target name="jar" depends="compile" description="Create jar file">
-
- <mkdir dir="${build.home}/classes/META-INF"/>
- <copy file="LICENSE.txt" tofile="${build.home}/classes/META-INF/LICENSE.txt"/>
diff --git a/dev-java/commons-math/files/commons-math-3.2-build.xml b/dev-java/commons-math/files/commons-math-3.2-build.xml
deleted file mode 100644
index 905d12657e26..000000000000
--- a/dev-java/commons-math/files/commons-math-3.2-build.xml
+++ /dev/null
@@ -1,288 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!-- ====================================================================== -->
-<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
-<!-- ====================================================================== -->
-
-<!-- ====================================================================== -->
-<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
-<!-- ====================================================================== -->
-<!-- -->
-<!-- Any modifications will be overwritten. -->
-<!-- -->
-<!-- Generated by Maven Ant Plugin on 5/29/13 1:59 PM -->
-<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
-<!-- -->
-<!-- ====================================================================== -->
-
-<project name="commons-math3-from-maven" default="package" basedir=".">
-
- <!-- ====================================================================== -->
- <!-- Build environment properties -->
- <!-- ====================================================================== -->
-
- <property file="${user.home}/.m2/maven.properties"/>
- <property file="maven-build.properties"/>
-
- <property name="maven.build.finalName" value="commons-math3-3.2"/>
- <property name="maven.build.dir" value="target"/>
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
- <property name="maven.build.srcDir.0" value="src/main/java"/>
- <property name="maven.build.resourceDir.0" value="src/main/resources"/>
- <property name="maven.build.resourceDir.1" value="."/>
- <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
- <property name="maven.build.testDir.0" value="src/test/java"/>
- <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
- <property name="maven.build.testResourceDir.1" value="."/>
- <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
- <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
-
- <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
- <property name="maven.settings.offline" value="false"/>
- <property name="maven.settings.interactiveMode" value="true"/>
-
- <!-- ====================================================================== -->
- <!-- Defining classpaths -->
- <!-- ====================================================================== -->
-
- <path id="build.classpath"/>
- <path id="build.test.classpath">
- <pathelement location="${maven.repo.local}/junit/junit/4.10/junit-4.10.jar"/>
- <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"/>
- </path>
-
- <!-- ====================================================================== -->
- <!-- Cleaning up target -->
- <!-- ====================================================================== -->
-
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile" depends="get-deps" description="Compile the code">
- <mkdir dir="${maven.build.outputDir}"/>
- <javac destdir="${maven.build.outputDir}"
- encoding="UTF-8"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.5"
- verbose="false"
- fork="false"
- source="1.5">
- <src>
- <pathelement location="${maven.build.srcDir.0}"/>
- </src>
- <classpath refid="build.classpath"/>
- </javac>
- <copy todir="${maven.build.outputDir}">
- <fileset dir="${maven.build.resourceDir.0}"/>
- </copy>
- <mkdir dir="${maven.build.outputDir}/META-INF"/>
- <copy todir="${maven.build.outputDir}/META-INF">
- <fileset dir="${maven.build.resourceDir.1}">
- <include name="NOTICE.txt"/>
- <include name="LICENSE.txt"/>
- </fileset>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Test-compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile-tests"
- depends="compile"
- description="Compile the test code"
- unless="maven.test.skip">
- <mkdir dir="${maven.build.testOutputDir}"/>
- <javac destdir="${maven.build.testOutputDir}"
- encoding="UTF-8"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.5"
- verbose="false"
- fork="false"
- source="1.5">
- <src>
- <pathelement location="${maven.build.testDir.0}"/>
- </src>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- </classpath>
- </javac>
- <copy todir="${maven.build.testOutputDir}">
- <fileset dir="${maven.build.testResourceDir.0}"/>
- </copy>
- <mkdir dir="${maven.build.testOutputDir}/META-INF"/>
- <copy todir="${maven.build.testOutputDir}/META-INF">
- <fileset dir="${maven.build.testResourceDir.1}">
- <include name="NOTICE.txt"/>
- <include name="LICENSE.txt"/>
- </fileset>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Run all tests -->
- <!-- ====================================================================== -->
-
- <target name="test"
- depends="compile-tests, junit-missing"
- unless="junit.skipped"
- description="Run the test cases">
- <mkdir dir="${maven.test.reports}"/>
- <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
- <sysproperty key="basedir" value="."/>
- <formatter type="xml"/>
- <formatter type="plain" usefile="false"/>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- <pathelement location="${maven.build.testOutputDir}"/>
- </classpath>
- <batchtest todir="${maven.test.reports}" unless="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/*Test.java"/>
- <include name="**/*TestBinary.java"/>
- <include name="**/*TestPermutations.java"/>
- <exclude name="**/*AbstractTest.java"/>
- </fileset>
- </batchtest>
- <batchtest todir="${maven.test.reports}" if="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/${test}.java"/>
- <exclude name="**/*AbstractTest.java"/>
- </fileset>
- </batchtest>
- </junit>
- </target>
-
- <target name="test-junit-present">
- <available classname="junit.framework.Test" property="junit.present"/>
- </target>
-
- <target name="test-junit-status"
- depends="test-junit-present">
- <condition property="junit.missing">
- <and>
- <isfalse value="${junit.present}"/>
- <isfalse value="${maven.test.skip}"/>
- </and>
- </condition>
- <condition property="junit.skipped">
- <or>
- <isfalse value="${junit.present}"/>
- <istrue value="${maven.test.skip}"/>
- </or>
- </condition>
- </target>
-
- <target name="junit-missing"
- depends="test-junit-status"
- if="junit.missing">
- <echo>=================================== WARNING ===================================</echo>
- <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
- <echo>===============================================================================</echo>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Javadoc target -->
- <!-- ====================================================================== -->
-
- <target name="javadoc" description="Generates the Javadoc of the application">
- <javadoc sourcepath="${maven.build.srcDir.0}"
- packagenames="*"
- destdir="${maven.reporting.outputDirectory}/apidocs"
- access="protected"
- old="false"
- verbose="false"
- encoding="UTF-8"
- version="true"
- use="true"
- author="true"
- splitindex="false"
- nodeprecated="false"
- nodeprecatedlist="false"
- notree="false"
- noindex="false"
- nohelp="false"
- nonavbar="false"
- serialwarn="false"
- charset="ISO-8859-1"
- docencoding="UTF-8"
- source="1.5"
- linksource="true"
- breakiterator="false">
- <link href="http://download.oracle.com/javase/6/docs/api/"/>
- <link href="http://download.oracle.com/javaee/6/api/"/>
- </javadoc>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Package target -->
- <!-- ====================================================================== -->
-
- <target name="package" depends="compile,test" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- manifest="/var/tmp/portage/dev-java/commons-math-3.2/work/commons-math3-3.2-src/target/osgi/MANIFEST.MF"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html">
- <manifest>
- <attribute name="Main-Class"/>
- </manifest>
- </jar>
- </target>
-
- <!-- ====================================================================== -->
- <!-- A dummy target for the package named after the type it creates -->
- <!-- ====================================================================== -->
-
- <target name="jar" depends="package" description="Builds the jar for the application"/>
-
- <!-- ====================================================================== -->
- <!-- Download dependencies target -->
- <!-- ====================================================================== -->
-
- <target name="test-offline">
- <condition property="maven.mode.offline">
- <equals arg1="${maven.settings.offline}" arg2="true"/>
- </condition>
- </target>
-
- <target name="get-deps"
- depends="test-offline"
- description="Download all dependencies"
- unless="maven.mode.offline">
- <mkdir dir="${maven.repo.local}"/>
- <mkdir dir="${maven.repo.local}/junit/junit/4.10"/>
- <get src="http://repository.apache.org/snapshots/junit/junit/4.10/junit-4.10.jar"
- dest="${maven.repo.local}/junit/junit/4.10/junit-4.10.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- <get src="http://repo.maven.apache.org/maven2/junit/junit/4.10/junit-4.10.jar"
- dest="${maven.repo.local}/junit/junit/4.10/junit-4.10.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- <mkdir dir="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1"/>
- <get src="http://repository.apache.org/snapshots/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
- dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- <get src="http://repo.maven.apache.org/maven2/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
- dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- </target>
-
-</project>
diff --git a/dev-java/commons-math/metadata.xml b/dev-java/commons-math/metadata.xml
deleted file mode 100644
index 952a4b9b605c..000000000000
--- a/dev-java/commons-math/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
- </maintainer>
-</pkgmetadata>